Answered

Sonos Beam Gen 1 - Doesn't Work with Samsung TV from time to time

  • 19 January 2023
  • 8 replies
  • 84 views

  • Contributor I
  • 7 replies

My Sonos Beam Gen 1 can’t connect with my Samsung TV from time to time. I had re-setup the Tv again then the next day, the connection is lost when I turn on the TV.  I have Mi-Box (Android TV) to connect the same Samsung TV.

icon

Best answer by Corry P 26 January 2023, 17:37

View original

8 replies

Userlevel 7

Try disabling the CEC controls on the Mi Box. 

Settings > Device Preferences > HDMI CEC

I had disabled the HDMI CEC in my MiBox since day 1. The problem is occurred since the Sonos move to S2 spec.  Also, it is audio delay(silence) while the TV turn on for about 10+ seconds. 
 

william

Userlevel 7

What model Samsung TV do you have?

Samsung Q80-65

Userlevel 7

In the TV settings, set HDMI-eARC Mode to OFF and Digital Output Audio Format to Pass-Through.

Also try this:

Disconnect everything from the TV including the Beam. Unplug the TV and Beam from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Anynet+ is enabled in the TV settings. Run TV Setup in the Sonos app. When the app instructs you, connect the Beam to the TV using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect the Mi Box to the TV.

Same problem occurs another day!

Userlevel 7
Badge +18

Hi @wmar 

Welcome to the Sonos Community!

If you still have this issue after following all the steps provided by @GuitarSuperstar, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

Thanks.  Will try later!

Reply