Answered

Sonos Arc stopped working with LG Oled CX 77 inch


My Sonos Arc suddenly stopped working with my LG OLED CX 77” TV. Both are brand new and had been working perfectly for 8 months. I got a new and slightly nicer LG OLED TV for a different room and another Arc. The issue is something with the 77” TV. Anyone else have this issue?  

icon

Best answer by GuitarSuperstar 28 August 2021, 16:42

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 7

I’m stumped. LG CX owners usually don’t have issues with the TV connecting to the Arc. It’s probably time to contact Sonos Support:

https://support.sonos.com/s/contact?language=en_US

Yes, if I connect the Apple TV, it auto detects, connects, and audio works. Thanks for the help!

Userlevel 7

If you connect any other device to the HDMI eARC port on the TV, does the TV detect it?

@GuitarSuperstar. I’ve updated the LG OS to 30.23.25. And tried all permutations of your advice on other threads. Simplink on with earc off. Unplug both tv and Sonos from power for a few minutes. And all hdmi. Then power back on for both and then follow the Sonos tv setup process where it says to connect hdmi. Arc is never recognized. Not sure what else to do?

I wasn’t. I tried the hdmi cable that came with the Sonos. And tried it without any other devices connected. Same result. Sonos is not detecting the tv earc port. I’m stumped. 

Userlevel 7

Are you using the HDMI cable that came with the Arc?

Do you have any other devices connected to the TV? If so, disconnect those devices first and redo the TV Setup process.

thanks for the help! Yes. But it says HDMI arc is not detected. All is new and works with another lg oled tv. So I don’t know why it doesn’t detect it

Userlevel 7

Have you tried to redo the TV Setup process in the Sonos app? Also be sure Simplink (CEC) is enabled on your TV and the HDMI cable is connected to the HDMI ARC/eARC port.

The Sonos arc no longer communicates with the tv so no sound from the tv.  Otherwise, Sonos arc is perfect and works fine with a 65” of a slightly nicer lg oled.  I thought it was from an LG update, but the LG tech just replaced the main computer board and updated the software to 13.30.15. I turned off the surge protector cutting power for a few minutes and rebooted the router. No change. Still doesn’t work

Userlevel 7

What exactly do you mean by “stopped working”?

Try unplugging the Arc and TV from power for a couple of minutes and reboot your router.