All peripherals disconnected (includes diagnostic number)

  • 20 November 2023
  • 14 replies

About 2 days ago while watching a show, my Sub Mini and both One SLs just seemed to lose connection. The Arc was still working fine so I went into the app and sure enough it said there were 3 issues. Cool, so I went in to "fix it" but I kept receiving an error that no products could be found and to try again later. Fine, we were about to go to bed so I tried again yesterday, same issue. 

I attempted to research and troubleshoot this for hours yesterday and have started back this morning.. I'm becoming exhausted. This has never happened before and NOTHING has changed with my network. The Arc still shows "Excellent Connection" in the app.

At this point, I've tried resetting the router and modem and even factory resetting the speakers. When I factory reset the sub for example, I do get a message that prompts me to set up the sub mini. So cool, its definitely being recognized. It connects to the wifi! Getting excited I proceed thinking I'm making progress.. then I go into my settings > system > Living Room > Connect Sub.... can't be found, "make sure it's connected to the same wifi." Yes.. it is 1000% connected to the same wifi.

I'm getting burnt out.. I can't do ethernet as I'd have to run really long cables across the living room to reach my One SLs and that's just not feasible and everything has been working fantastic until all this.

I've attached a diagnostic number in hopes that someone, anyone from Sonos can help me out here..

Diagnostic number - 443662360




Even as a last effort, I factory reset everything again, including the Arc this time.

The Arc connected back with absolutely 0 effort. Was super fast and simple. None of the other devices will still connect..

Moderator edit: combined posts


Best answer by Ken_Griffiths 21 November 2023, 01:10

View original

14 replies

Even as a last effort, I factory reset everything again, including the Arc this time.

The Arc connected back with absolutely 0 effort. Was super fast and simple. None of the other devices will still connect..

Can you wire just the Arc with Ethernet? If so try it. 

Hi ratty, this didn’t change anything unfortunately. Tried rebooting each speaker again (unplug for 10 seconds as per Sonos) after plugging the ethernet to the Arc. Lights show solid white so it shows they’re connected and functioning properly, but still when I go to add them to the Arc I just get the same message about not finding any devices on the Wifi.

I assume the “WiFi” wasn’t disabled on the Arc when wired?

What does the network look like? Just a router, or is there a mesh WiFi system?

Someone else who reported a similar issue recently in the community - reset their Sonos App (App Preferences) and connected it back to the ‘existing’ system, then got things to work. I’m not sure why it worked, but just mentioning it here in case you may want to try that, if all else continues to fail.

I am also assuming that the One SL’s were not factory reset and added back to the system as a ‘stereo pair’ - as they need to be separate/standalone to bond them to the Arc as surrounds. This would not explain though why the Sub isn’t bonding to the Arc.

@ratty - I tried with WiFi enabled and disabled just in case. Network is just a router. Nothing crazy.


@Ken_Griffiths - I just tried resetting the app and joined existing system. Connected back immediately but still showing 3 issues (both SLs and Sub not connecting). And yes, the SLs were added back standalone.


If I go to Settings > System and look under ‘Products,’ there are 4 “Living Room” listed now and there was only 1 previously - Living Room (R + L + Sub). Now ‘Products’ showing is showing 3 Living Room as Not Connected, then a 4th Living Room as “Living Room (? + ? + ?).


This has become an absolutely incredible pain….. 

What I’m not quite understanding here @Kaeyon, is you mentioned that you factory reset the Arc in your opening post and have not been able to add the surrounds/sub back to it, but its showing like the surrounds/sub were (are) bonded to the Arc at some stage. What do you see in the ‘Settings/System/About My System’… are all your products listed with an IP address?

Also do you have more that one wireless access point in your network (anything besides the main router?) Which router are you using - make/model?

@Ken_Griffiths - I factory reset the Arc and all peripherals. Got the Arc added back. Then I proceeded to get a pop up for each peripheral prompting to set them up. So I set both SLs and the Sub Mini back up. Even get the prompt to add them to the system. Everything shows successful. However, when I go back into the app it says there are the issues mentioned in my previous reply. All of them now say not connected. And the only IP I see is for the Arc.

Trust me, I’m not understanding either.. App says everything connected successfully yet… the app says they’re not connected after the fact. Thus, my frustration.. I’ve had this system approx ~1 year and it’s been perfect. Not one hitch. Probably not even a single disconnect. Moved homes, new WiFi, no problems. Then just randomly all of this..

And do you see all devices/IP addresses in the About My System area of the App?

What make/model of router is it, any other WiFi access points?

Only IP showing is the Arc. Router is just the one received from Spectrum. Model SAX1V1S. No other access points.

I think you may have possibly ‘accidentally’ split your Sonos system into two separate Sonos households on the same WiFi network during the ‘factory reset’ of your devices - but this is just a guess. 

Before making a suggestion to perhaps fix it, can you recall what the steps were when you factory reset your devices earlier …and also did you notice if, at any point, you lost your saved playlists, favourites and Music services?

I’ve also just noted too that there have been some reported difficulties with similar spectrum router models (and others). So also see this earlier community thread:


Having read the other Spectrum router thread (and a few other threads besides), my thoughts are to initially power off all speakers, wire just one speaker at a time to the router and open the App and remove their WiFi credentials (see this LINK how to do that) and rinse & repeat with each speaker, when all have been done then wire the Sonos Arc only to the router and leave it wired and wait 10 minutes or so, just see if that solves the issue. If not, power off the surrounds Sub and ‘factory reset’ the Sub just one further time only and add that back to the system as follows..

Ensure your mobile app is fully updated and that the mobile device meets these system requirements…

  • Fully close the Sonos App and reopen and ensure the Arc is showing in the App.
  • With the resetSub status LED flashing green, goto ‘Settings/System/Add Product’ and follow the onscreen instructions to add it to your system and bind it to your Sonos Arc.
  • If that works, then do the same steps with each Sonos One-SL device and see if they will now bond to your Sonos Arc.

If any step above fails, then it’s time to get in touch with Sonos Support - best to give them a call, I think, which can be sorted via this link: