Answered

Wired sonos surround dropping connection


I have a beam with a sub and two play 1 speakers setup as a surround system. They have a wired Ethernet connection with WiFi disabled. I’ve assigned them all static IP addresses. The audio source is hdmi arc from my tv. 
 

The surround speakers keep shutting off and on while watching a show. I ran a diagnostic and the number is: 341897523

Am I missing something?

icon

Best answer by John B 23 May 2020, 20:33

Hi. Yes I think you are missing something.  The way that Sonos HT systems are designed to work is by the components communicating directly over 5GHz radios.  By disabling the wireless radio on the Beam or surrounds you are preventing that.  Also you should not wire surrounds, especially if nothing else is wired, because that is a suboptimal way of running SonosNet.

If you are going to wire anything, wire the Beam. Re-enable wifi on all speakers.  Don’t wire the surrounds.

I hope that helps.  

View original

6 replies

Hi. Yes I think you are missing something.  The way that Sonos HT systems are designed to work is by the components communicating directly over 5GHz radios.  By disabling the wireless radio on the Beam or surrounds you are preventing that.  Also you should not wire surrounds, especially if nothing else is wired, because that is a suboptimal way of running SonosNet.

If you are going to wire anything, wire the Beam. Re-enable wifi on all speakers.  Don’t wire the surrounds.

I hope that helps.  

Thank you very much! 

So basically the beam connects to the internet and controls the the other speakers in the area via a private wireless connection so wiring them potentially causes conflicts.

I’ve modified the setup as you suggested and it seems more stable so far.

Thanks again!

 

@zachg99, Also remove the WiFi details from the system, if the Beam is now wired.

On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to 'Settings → System → About my Sonos System' and see if WM:0 is being displayed next to each unit.

Thank you!

Removed and it does say WM:0 on all the devices.

I have other speakers in the house that are not wired, it sounds like these are all connecting through the beam then?

Userlevel 5
Badge +13

@zachg99 Thank you for bringing your question(s) to us here and welcome to the Sonos Community. John B and Smilja have provided you great steps for troubleshooting. I was able to look at your diagnostic report number you had provided and all I can add is to do a complete Sonos product re-boot off/on for 15 seconds, even the Sub. When you do this our products will listen to the Beam sending out Sonosnet as the wired product to the router. Your other Sonos products will hear, create it and send it out to the others.

Anytime you can wire us to the router great, if not just have at least one wired for Sonosnet. Also, as John B points out, with the HT setup you would only need the Beam wired. As for your other rooms in the Sonos app the same applies. If you can wire them great, but leave the wifi card on so that products not wired can pick up and share Sonosnet to each other.

Thank you!

Removed and it does say WM:0 on all the devices.

I have other speakers in the house that are not wired, it sounds like these are all connecting through the beam then?

Yes. You are using SonosNet so everything is connecting through the Beam because that is the wired device.

Any Sonos speaker, or a Boost, can be wired to trigger SonosNet. That is a different issue from the fact that the Beam is managing the sound played through its surrounds and Sub.

But the key thing is that you have a much better configuration and hopefully it will be fine from here.

Reply