Answered

Surrounds Flash Green


Badge

I have an arc and have just purchased 2 Sonos one SL's to try and create a surround system. Initially,  all went well, everything was connected and working fine. I then became aware there was no sound coming out of the ones and they had  a flashing green light. I factory reset them,  re-added them to Sonos added them as surround speakers and they instantly flash green as soon as they are set up. I have totally factory reset the entire system and yet as soon as they become surround speakers they flash green. Any help would be gratefully accepted.

icon

Best answer by Corry P 7 July 2022, 11:54

View original

33 replies

OK.  I suggest the next experimental step is turn off the mesh node, assuming that the Arc can connect wirelessly to the main router.  Remove the surrounds from the Arc, and power them off and on again.  Add them again as surrounds.  Please then report back.

You don’t have any other Sonos speakers?

You should stop factory resetting as it won’t achieve anything here.

Badge

Thanks to all who responded in an attempt to assist. The fault developed even stranger. With the surrounds (supposedly) set up, although there was no sound actually coming from them! When I switched the TV on, sound came out of the Arc but the surrounds switched off, When i switched the surrounds back on sound disappeared from the Arc. increasing the volume on the Arc switched off the surrounds. Anyway I took the advice of John B and Corry P and rang support. It was sorted in about 10 minutes. Wonderful service and I should have called earlier - it’s just that some support lines can be very hard work.

Thanks again all

Badge

Hi nik9669a - I’m afraid they didn’t just that they could see what the problem was!

Userlevel 7

What model router are you using?

Also, make sure the surrounds aren’t being disabled in the Sonos app:

“This light appears on home theater surrounds that have been disabled using the Sonos app.

You can re-enable your home theater surrounds in the Sonos app for iOS or Android in the  Settings tab. Under System, choose your home theater product from the list, then tap Surround Audio and re-enable the Surrounds option.”

Have you checked the LED states FAQ?

How are they showing up in your controller? Generally, surrounds will show up as +RS and +LS in the settings>system area, for the room that they’re part of.

Ah, another point would be that you can’t have the “radio” or “Wifi” turned off on either the Arc, or the surrounds, as they use that to communicate. 

You are sure there is nothing from the surrounds?  In the Arc settings, under surround sound, is music set to FULL or AMBIENT?  make sure it is set to FULL then play a music source, i.e. not TV.  Still nothing?

Is it practically possible - just as an experiment - to connect the Arc by Ethernet to the Router?

I added a further comment to my post as you were replying, so please note that.  Tell us a bit more about the mesh.  Does the Velop system have a device that acts as router, or do you still use an ISP router to which the mesh connects?

By ‘normal’ router you mean not part of the Velop system?

I am troubled by your comment ‘I am connecting wirelessly to the main router’  Does that mean you have a choice of wireless networks, main router and Velop?

Edit: posted before I saw your latest reply

OK.  The thing that is puzzling me is that you have the +RS+LS yet the speakers don’t appear to be enabled (green flashing light).  It may be that the Velop router is struggling to give IP addresses to the surrounds, as these get their data from the Arc by direct routing.  But that is speculative.

You could also try turning off the 5GHz band temporarily.  But only if that is easy, as I doubt very much it would help with your issue.

Please post back when you have tried a few experiments.

If you had had another Sonos speaker with an Ethernet connection I was going to suggest wiring that instead of the Arc to make the logistics of connecting easier, but the Move doesn’t have one.

Final thought - if you had said you had a non-Velop router I would have suggested trying Velop in ‘Bridge mode’.  But you don’t, so let’s hold off on that for now.

Settings>System>(Room name with surrounds)>Scroll down to Hardware>Status Light - off (affects all speakers in that ‘room’)

Settings>System>(Room name with surrounds)>Scroll down to Hardware>Status Light - off (affects all speakers in that ‘room’)

When the status light is set to OFF. The ARC & surrounds white LED’s turn OFF.

However if the volume is muted the ARC & surrounds green LEDs come ON.

If the status light is OFF and the surrounds are set to OFF then the green LEDs will flash ??

Oh, my apologies. Yes, I agree, when muted, the speakers have always given an indication that they are muted, and to my knowledge, that can’t be turned off. When that’s an issue for me, I usually turn them down to the lowest level without muting it, and usually, because I’m listening to something else, any low level sound that might be coming from them is lost. But then again, my surrounds tend to be “behind” me, so I don’t really notice that light, unless I’ve darkened the room for some reason, and then turn my head. I have, for other LEDs such as the microphone, covered it with a piece of electrical tape, or a dot from LightDims

Not ideal solutions, in any case, but I think Sonos is more concerned about reducing support calls about how the speakers don’t work, when in fact they’re just muted. 

For your your third scenario, I’ve never had a time where I wanted to turn off the surrounds. In fact, I have them set to “Full” rather than “Ambient”, so that when playing music, they act as stereo speakers, and not just supporting to the sound coming from my Arcs.

Userlevel 7
Badge +18

Did they say what the fix was? Just in case it crops up again for anyone else…

Badge

Thanks for your replies. The router is a Linksys Velop and I think that’s what the problem is! I’ve checked the controller and the surrounds are enabled. They are visible as +RS, +LS. Wifi is enabled on all 3 speakers. If anyone can assist with conecting when using Linksys Velop Mesh system I would appreciate it. Thanks again.

Badge

Thanks for your comment John B, I’ll give it a try when I get home.

Badge

Thanks again John B. It is possible that i could connect the Arc to Ethernet but I will have to lift a couple of floorboards so was going to trry that this weekend. asfar as the Linksys Velop goes it’s a normal router that has a scond router linked to it to create the mesh system I am connecting wirelessly to the main router. This post seems to highlight a lot of the problems with Velop system: Working with Linksys Velop | Sonos Community

Badge

Sorry, John B, No it’s the main velop router. The one I initially set up before I added the mesh node.

Badge

No, sorry again, my lack of understanding of this area. I have 3 wifi connections available, from my velop system. One is a 2.4 ghz, one a 5 ghz and one guest. My phone (and hence my Sonos controller is connected to the 2.4 Ghz)

Badge

Thanks for your advice John B. I’m at work at the moment so intend to crack on with it this weekend. I do have a Sonos move which works fine.

I will do as you suggest and disconnect the node.

I will also try connecting an ethernet connection to the Arc, which is what lots of peole are suggesting on other forums.

I have had my Arc for some time now and that has been faultless, it was only when I tried to connect the One SL’s that the problem started.

I’ll let you know how I get on with your suggestions. Thanks

Badge

Hi John B. Ok, I disconnected the node to the router and disabled the 5ghz connection. I connected the Arc to ethernet and ensured it was selected to ethernet via the controller. I recreated the surround system via the controller and it is exactly the same. The Arc is working fine and the one SL’s are flashing green. I switched off the TV to play some music to see what effect that had and when I opened the sonos controller I got a Living Room not configured ?(+RS +LS) I had to go through the whole setup process again and, again, when I connected the surrond they flashed green. Back to the music I tried to pay musc from  my Spotify Account and Alexa said it was playing but there was no sound output (I checked the volume and it was turned up) when I checked Alexa the Arc was not visible, tried to connect it but alexa couldnt see it. 

So even the Arc won't play now?  It's beginning to look like a hardware fault  maybe with the.wireless radio on the Arc. If you just keep the Ones as separate 'rooms', not surrounds,  do they play?

I too have ARC with 2 x ONE SL surrounds. I have them OFF in the app settings- surround audio on/off option by choice during the day.

what is annoying is the flashing green LED. I’d like an option to turn the LED’s off

Reply