Answered

Surround Sound Help from TV

  • 25 November 2018
  • 2 replies
  • 231 views

I purchased a pair of Sonos One speakers yesterday and set them up in the living room successfully, grouped alongside my Beam as surround speakers.
True Tone was set up perfectly and the speakers work perfectly with music apps like Spotify etc but anything from the TV only gets sound from the Beam sound bar.
How can I get the surround sound to work for the TV so I can get the sound for use with Netflix, the Playstation, the footy etc??
The tv is a Sony KD-60X690E if that helps. ARC connection to the Beam. Wifi to the two surround One's.
icon

Best answer by Keith N 25 November 2018, 23:07

Hi there, carts60. It sounds like the Beam is only getting a stereo signal. Have you verified that the audio settings on your TV are set properly? Additionally, you will want to verify that the content you are watching is encoded in Dolby Digital 5.1 in order to fully utilize the surround Sonos One's.

Alternatively, if your content is not in Dolby Digital 5.1, you may want to try out boosing the TV Level settings in Room Settings -> Room with surrounds -> Advanced Audio -> Surround Settings. After, you can also use Balance to set them as if they were further than 10 feet away. This will turn up the surrounds and use "more" of the surround speakers. Keep in mind this is not surround sound, this is much closer to a "full stereo" type-effect. I use this for my game console in my bedroom since none of the content I play in there is in 5.1 Dolby.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +19
Hi there, carts60. It sounds like the Beam is only getting a stereo signal. Have you verified that the audio settings on your TV are set properly? Additionally, you will want to verify that the content you are watching is encoded in Dolby Digital 5.1 in order to fully utilize the surround Sonos One's.

Alternatively, if your content is not in Dolby Digital 5.1, you may want to try out boosing the TV Level settings in Room Settings -> Room with surrounds -> Advanced Audio -> Surround Settings. After, you can also use Balance to set them as if they were further than 10 feet away. This will turn up the surrounds and use "more" of the surround speakers. Keep in mind this is not surround sound, this is much closer to a "full stereo" type-effect. I use this for my game console in my bedroom since none of the content I play in there is in 5.1 Dolby.
@carts60 - I am also having the same issue and have the same TV. The signal coming to my speakers is 'stereo' If you find a setting to change to sound signal, let me know.

I am going to take the advice of Keith as well.

Thanks.