Question

Stereo / Dolby


Userlevel 1
Badge

Hi all, 

 

Forgive my questions if they seem silly but I am a newbie to Sonos! I’ve ensured the sound setting on my LG is set to ‘Dolby Digital’ and have a Beam (nothing else as yet). On my Sonos app it always says Stereo 2.0 even though I’m currently watching a Blu Ray with Dolby sound. Is this because I don’t have any surround speakers as yet? Will it only flip over to say Dolby when I have the surrounds in place? I assumed that it didn’t say that previously because I was just watching TV but now I’ve set up my Blu Ray player, it’s still saying Stereo. 

 

Thank you!


18 replies

Which sound setting do you have set to Dolby Digital? My LG TV only offers PCM or Auto for HDMI-ARC and optical. Of course our TVs may differ. 

It doesn't depend on surrounds.

You may need to also check the audio settings on your Blu-ray player, and make sure it is set up to send a Dolby Digital signal, and also be playing a Dolby Digital soundtrack. For instance, if the soundtrack your playing is a DTS one, it likely will default down to Stereo due to the HDMI CEC communication from the Beam to the TV (hub) and then back to the Blu-ray player.

Userlevel 1
Badge

Aha Bruce, thank you! I’ll check that. it’s such an old blu ray player but very good still. 

 

John - it’s under Sound then Additional Settings - called DTS Audio Setting and the options are MPEG, Dolby Digital, Dolby Digital Plus, HE-AAC and Auto. I kept seeing posts saying to make sure your TV was set to Dolby and this was the only place I could find Dolby! I’m pretty ignorant though haha. 

 

Thank you both. 

Go into the TV Sound menu.

Find 'Sound out'

Select 'Audio Out (Optical/ HDMI-ARC)'

Under that, set Digital Sound Out to 'Auto' not 'PCM'

Most discs default to the DTS soundtrack, you usually have to choose to play the Dolby Digital track in the disc’s menu. Also, most Blu-ray players don’t do the automatic decoding from DTS to Dolby Digital for you. Those are fairly scarce devices these days, unfortunately.  

Bruce is right. Do you have a DVD you could try because then we can be confident that we have a DD5.1 source. 

Userlevel 4
Badge +7

I hope this is just a matter of getting the right settings. 
 

When I first got my Playbar many years ago, getting the right signal was a constant struggle. Most TVs back then wouldn’t event pass on the right signal so many of us had to buy switches enabling us to manually bypass the tv and get audio directly from the source to the Playbar - and that was only after actually getting our hands on a Blu-ray player that would transcode DTS on the fly. 
 

I can’t help but feeling a little disappointed/sad seeing new users experiencing these same struggles 7 years later with relatively new products as the Beam and also the Arc for that matter (although the Arc is definitely better features with a much wider support Dolby-codecs).

 

And as mentioned, getting your hands on blue-ray players that will transcode on the fly isn’t getting any easier. Xbox One/PS4 can do it. I have an old Samsung Blu-Ray player which will also do the trick so those might be worth looking into. 
 

But it is worth  the effort - DD sounds much better on the Beam than stereo PCM. 
 

Userlevel 1
Badge

Oh this is all so interesting thank you! John - what does ‘auto’ do and what is PCM? I’ve found it and changed it. Next stage, check the DVD/Blu Ray player and then I’ll look for a suitable DVD - are DVDs more likely to use Dolby than Blu Rays then? I’ll check the menus as well. You learn something new every day! So grateful. 

Userlevel 4
Badge +7

Oh this is all so interesting thank you! John - what does ‘auto’ do and what is PCM? I’ve found it and changed it. Next stage, check the DVD/Blu Ray player and then I’ll look for a suitable DVD - are DVDs more likely to use Dolby than Blu Rays then? I’ll check the menus as well. You learn something new every day! So grateful. 

Yes. DVDs are almost always DD. Don’t think I’ve ever come across a DVD with DTS. 

Oh this is all so interesting thank you! John - what does ‘auto’ do and what is PCM?

'PCM', here, is stereo. 'Auto' doesn't specify a format. With PCM in this setting you were never going to get anything other than stereo. 

 

 

I’ve found it and changed it. Next stage, check the DVD/Blu Ray player and then I’ll look for a suitable DVD - are DVDs more likely to use Dolby than Blu Rays then?

 

As ​​​@Tejs Dyrvig Ernst said, yes. I believe DD5.1 is a requirement in the DVD spec.

 

Userlevel 1
Badge

OK this is really random. Found the sound settings on the Blu Ray but both the Dolby possibilities seem only to come with ‘extras’ - i.e. one is with audio description and the other is with commentary. If I want to watch the film alone it seems only to be available in DTS. How weird!

Userlevel 1
Badge

PS The Dolby definitely sounds better, I just don’t want all the peripheral speaking with it!

Userlevel 1
Badge

OK, yes it’s different with the DVD - popped onto ‘audio’ and I have ENG 5.1ch Dolby Digital. HOWEVER the Sonos app still says Stereo 2.0? I’m not very good at this, am I?! 

Userlevel 1
Badge

Tejs - thank you for your response also! Sorry, only just seen it. It sounds pretty good so I feel like I might be getting Dolby Digital now after playing around with all those settings (seriously though, if you didn’t come on here you wouldn’t know to do this!) but the app seems to indicate otherwise so god only knows! Not sure what else to tinker with (!) 

Have you refreshed the About my System screen?

And DD5.1 is set for output on your BR player?

Userlevel 4
Badge +7

OK this is really random. Found the sound settings on the Blu Ray but both the Dolby possibilities seem only to come with ‘extras’ - i.e. one is with audio description and the other is with commentary. If I want to watch the film alone it seems only to be available in DTS. How weird!

That’s how it usually is. Also, if you come across Blu-ray’s with different languages, the main language will typically be in DTS and any additional languages in DD 5.1. My guess is that DTS takes up more space. 
 

OK, yes it’s different with the DVD - popped onto ‘audio’ and I have ENG 5.1ch Dolby Digital. HOWEVER the Sonos app still says Stereo 2.0? I’m not very good at this, am I?! 

 

Do you have an option of using the optical dongle and connecting the Beam straight to the Blue-ray player? That could isolate the issue to the tv. 
 

Some TVs will actually not pick up DD 5.1 from a HDMI-source and pass it on to a soundbar. I don’t think this is a common issue with more recent TVs but it was a widespread issue a few years back. 

Userlevel 4
Badge +7

You could also try using a build-in app on the tv if you have Netflix on the tv for instance. The tv should be able to send DD 5.1 to the Beam from it’s own apps and this would narrow the issue to the TV not picking up DD 5.1 from a HDMI-source and passing it on. 

Userlevel 1
Badge

Thanks SO much guys - the advice has been invaluable and I’VE DONE IT!! It finally says Dolby 5.1 on the Sonos app :) Went into all the settings on the blu ray player and just selected what looked right. Now to try Netflix. It’s a small thing but I’m very happy haha! Have a lovely weekend :) 

Reply