Sony TV has long start up with ARC HDMI plugged in

  • 5 August 2020
  • 3 replies
  • 64 views

Anyone out there have a 900F series Sony with a Sonos ARC plugged in? Once I connected the ARC to the TV it does a hard boot up if the TV has been off for awhile. I have called tech support a few times and they finally said they were talking with Sony. I have two 900F series TV that two seperate ARC’s are causing the TV to start up long. If I disconnect the HDMI from the ARC it starts up fine. 


3 replies

Userlevel 4
Badge +5

Two options:

  1. Turn on simple IP control (it’s in the network settings)
  2. Turn off wifi.

This is due to bug with Sony TVs’ deep sleep behavior. It sometimes wakes up and sends Arc a wrong signal. Either of the above options will solve your problem.

I can not use simple IP since I have Control 4 turning on my TV over the network. I also have the TV connected via WiFi because I ran out of room on my switch. 

 

Question 1: Do you work for Sonos or Sony?

2: Why don’t they know this information? I can’t even count how many hours I have wasted on hold to talk to tech support  for either of the companies. 

3: Do you know when the update should be out that will resolve the issue?

Userlevel 4
Badge +5

I can not use simple IP since I have Control 4 turning on my TV over the network. I also have the TV connected via WiFi because I ran out of room on my switch. 

 

Question 1: Do you work for Sonos or Sony?

2: Why don’t they know this information? I can’t even count how many hours I have wasted on hold to talk to tech support  for either of the companies. 

3: Do you know when the update should be out that will resolve the issue?

I don’t work for Sonos or Sony. I know this information since I have a Sony TV and Sonos products. When I got my TV (Sony x850e) I decided to turn off wifi because I had read about the TV dark-waking up every 5 minutes reporting home. It’s a bug. It is on the Sony radar and hasn’t been fixed in 3 years. I don’t think it’ll ever be fixed. (My TV isn’t allowed to connect to the internet at all; I use an external streaming box, but this may not suit everyone.) 
 

This bug really doesn’t affect most devices, but for some reason Sonos devices are extra sensitive. I don’t know why. I can’t tell you why tech support wouldn’t know it. I am glad I can help. 
 

Try to turn on simple IP control. This should not affect the TV’s ability to wake over the network using a mobile device.  
 

For some documentation on the Sony dark wake bug, see here: https://github.com/CiNcH83/sony_atv/issues/8

Reply