Sonos Playbar cutting in & out intermittently when playing music if the audio optical cable is connected to Sony XBR-75X950H TV and the TV is turned off

  • 12 February 2021
  • 15 replies
  • 573 views

Sonos Playbar cutting in & out intermittently when playing music if the audio optical cable is connected to Sony XBR-75X950H TV and the TV is turned off. 

If I unplug the optical cable from the Sony TV (TV power is off) the playbar does not cut out and plays continuously with no problem.

The playbar does not cutout when the TV is on and audio optical cable is connected with the TV sound coming through the playbar (surround sound).


15 replies

Userlevel 7

Have you tried unplugging your TV and Playbar from power for about a minute or two to see if it fixes the problem?

I’m experiencing the same issue since purchasing a Sony KD-75X9500H using an Optical cable to connect to my Sonos Playbar. It cuts out for about 3 to 4 seconds every minute or so. My Sonos Move doesn’t cut out, obviously because it’s not connected via the optical cable to the TV.

I’ve checked the optical cable is connected and not damaged. 

I’ve tried power cycling both devices. 

 

As above:

If I unplug the optical cable from the Sony TV (TV power is off) the playbar does not cut out and plays continuously with no problem.

The playbar does not cutout when the TV is on and audio optical cable is connected with the TV sound coming through the playbar..

 

Has anyone found a fix for this? (Other than removing the optical cable which means the TV sound doesn’t work on the speaker!)

thanks 

Not a fix but I did get some workarounds you can try. I haven’t tested the workarounds yet, Sonos support just gave them to me today.

They did acknowledge that this is a known issue with some new Sony TV’s but I didn’t get any info on a resolution before my chat was cut off. 

From Sonos support:

There's a certain issue we've been tracking with some Sony TV's which is causing this. Could you head into the Sony TV's settings and check for software updates if your TV is connected to the internet? 

There are some workarounds that we can apply to alleviate the issue that we have seen work for other users with the same issue. On the TV, could you try changing these settings for us?
Turning on IP Simple Control
Open Settings
Go to Network and Internet
Go to Home network
Go to IP control
Go to Simple IP control
Toggle On 

Setting  RS232C Control to "Via Serial Port"
Open Settings
Go to Remotes and Accessories
Go to RS232C Control
Set it to "Via Serial Port" 

I’m having the same issue (Sony XBR-85X950G) - all audio sources play fine on all speakers, except the playbar. If a non-TV source is playing, audio will cutout at the playbar. When playing the TV source all speakers play perfectly. If I unplug the optical cable from the playbar, no speakers cutout.

 Did any of the suggestions work? I’m trying them now.

I’m having the same issue (Sony XBR-85X950G) - all audio sources play fine on all speakers, except the playbar. If a non-TV source is playing, audio will cutout at the playbar. When playing the TV source all speakers play perfectly. If I unplug the optical cable from the playbar, no speakers cutout.

 Did any of the suggestions work? I’m trying them now.

I would perhaps enable the two suggestions anyway … see the links to the YouTube videos below:

Turning on IP Simple Control
Open Settings
Go to Network and Internet
Go to Home network
Go to IP control
Go to Simple IP control
Toggle On 

https://youtu.be/VXDYspxEClg


Setting  RS232C Control to "Via Serial Port"
Open Settings
Go to Remotes and Accessories
Go to RS232C Control
Set it to "Via Serial Port" 

https://youtu.be/StZc22GENe8

Thanks bud, I enabled the settings yesterday and so far no cutouts. I’ll give it a week and report back.

I was experiencing cutouts when my Sony’s audio output was set to Auto 2.  I changed it to Auto 1 and so far no problems.

I was experiencing cutouts when my Sony’s audio output was set to Auto 2.  I changed it to Auto 1 and so far no problems.

I spoke to soon, the cut out started back up again last week.  I think it might have been caused by a software update on the TV. Tried the other outputs with no luck.   I’ll try Ken_Grifiths suggestion and report back.

Thank you all! I thought I was going crazy. How can a TV optical audio input cause a problem with my Sound bar when the TV is off? I thought I was being gas lighted by someone!

I have the EXACT same issue on my new Sony XR-55A80CK. I was on with SONOS (not Sony) support today and they took my waaaay down a wrong road and conviced me it was insufficient band width on my WiFi. Turns out is is not as the problem persistes even with the Soundbar hardwired to the router but, as has been pointed out, the problem disappears when the optical  audio cable is removed. It definatley appears to be a SONY not SONOS problem and I look forward to a solution from them. In the meantime, I will try the workaround cited above.

Thanks all.

 

Just an update on the above Sony supplied work around. It WORKED! I changed the settings on the Sony TV as suggested above and I no longer have the music cutting out issue. Thank you, Ken Griffiths, for posting the solution here! Now if only I could get the Sonos to respond to the volume control on my Apple TV remote, I’d have nothing to occupy me all day!

 

 

 

Just an update on the above Sony supplied work around. It WORKED! I changed the settings on the Sony TV as suggested above and I no longer have the music cutting out issue. Thank you, Ken Griffiths, for posting the solution here! Now if only I could get the Sonos to respond to the volume control on my Apple TV remote, I’d have nothing to occupy me all day!

 

Perhaps see if this support link might assist you to resolve the issue with the Apple TV remote.

https://support.sonos.com/s/article/3403

Hi. I have the same issue with a new Sony TV connected to my old Sonos bar when playing music via Spotify (TV off). Pulled the optic cable and problem fixed - well, not really. My Sony TV did not have the RS232 setting but turning on “Simple IP Control” seems to have fixed the problem: 

  • Open Settings
  • Go to Network and Internet
  • Go to Home network
  • Go to IP control
  • Go to Simple IP control
  • Toggle On 

I’m curious about ARC’s TV Autoplay setting. If Autoplay is enabled and the TV spits out an extraneous block of data on its optical output, ARC will switch to the TV.

Userlevel 1

Not a fix but I did get some workarounds you can try. I haven’t tested the workarounds yet, Sonos support just gave them to me today.

They did acknowledge that this is a known issue with some new Sony TV’s but I didn’t get any info on a resolution before my chat was cut off. 

From Sonos support:

There's a certain issue we've been tracking with some Sony TV's which is causing this. Could you head into the Sony TV's settings and check for software updates if your TV is connected to the internet? 

There are some workarounds that we can apply to alleviate the issue that we have seen work for other users with the same issue. On the TV, could you try changing these settings for us?
Turning on IP Simple Control
Open Settings
Go to Network and Internet
Go to Home network
Go to IP control
Go to Simple IP control
Toggle On 

Setting  RS232C Control to "Via Serial Port"
Open Settings
Go to Remotes and Accessories
Go to RS232C Control
Set it to "Via Serial Port" 

What a crazy combo BUT IT WORKED!

Reply