Answered

Sonos Beam short IR range with TV remote


same here. I tried 2 remotes. they do work but I have to point super close. hopefully a software update will help. I am using alexa now for volume control
icon

Best answer by Ryan S 16 August 2018, 22:23

Hi everyone, to keep things clean, I've moved the posts from the duplicate thread for this issue over here. Pardon the dust as a few comments might not make sense. In short, this is the main thread.

The IR sensor on the Beam is pretty low on the device, so if there's a lip on your table or something that could be blocking the bottom part of the Beam, make sure to move that. If you'd tried out a few locations and still have trouble with the IR range, I'd suggest that you give us a call on our support line and a technician can help out. Though it's possible an individual unit could have a bad sensor, it's always best not to make that assumption right away as it could be a number of other environmental concerns.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

48 replies

Badge
I bought the Sonos Beam today and connected it via optical with the adapter.
I went into the settings and did the short remote setup.
It does respond to the remote but only at around 2 or 3 feet!
When further away it doesn't respond! I tried replacing the batteries, used other remotes witch also function only arround 2 or 3 ft.
I have also placed the Beam elsewhere in my house, still the same problem!
Is my IR sensor busted or what?
Able to setup remote, several actually, but can’t get them to work past 5 feet.

PS: I recreated the topic as it was deleted from the community yesterday.
Had same problem. Tried several remotes, all had the same limited range of a few feet. Moved the unit into kitchen to avoid possible interference with plasma tv with no change.

Solution: returned unit and got a new one. Remote works from 20 feet away.
Badge
@smartandee & @Pierro O, from witch countries are you guys? I'm from Holland! This will maybe point out how wide spread this problem actually is.
Anyway i contacted Sonos and i will be getting my 3rd Beam now, but this time directly from them! I'll report if this fixes my problem too.
Badge
@Megamol, ruil je Beam om via Sonos zelf! Bel: +31-800-5551234
Ik had mijn Beam ook bij Media Markt Den Bosch gekocht, daarna omgeruild bij Media Markt voor een nieuwe maar helaas had die hetzelfde probleem.
Vandaag kreeg ik mijn derde via Sonos zelf en die werkt perfect!
Volgens mij is er een hele batch aan Beam's met een productie fout in omloop met name te koop bij Media Markt zo te zien.
Userlevel 7
Badge +26
Hi everyone, to keep things clean, I've moved the posts from the duplicate thread for this issue over here. Pardon the dust as a few comments might not make sense. In short, this is the main thread.

The IR sensor on the Beam is pretty low on the device, so if there's a lip on your table or something that could be blocking the bottom part of the Beam, make sure to move that. If you'd tried out a few locations and still have trouble with the IR range, I'd suggest that you give us a call on our support line and a technician can help out. Though it's possible an individual unit could have a bad sensor, it's always best not to make that assumption right away as it could be a number of other environmental concerns.
Userlevel 7
Badge +26
Glad you're all set now, Dynamike. We're definitely looking into it, which is why I suggest giving us a call so that the team can get all the right data. It's just good to first do the basic steps, like making sure nothing is in the way first. Just because sometimes it's a bad IR sensor or other component, doesn't mean it's always a bad IR sensor.
Just an update... Sonos sent me a replacement unit (beam) and all remote controls work with no issues. My original purchase must have been defective. Support was quite helpful and we literally tried every test in the book before they sent my replacement.
@Megamol, ruil je Beam om via Sonos zelf! Bel: +31-800-5551234.
Thanks. I called support and after doing some tests they let me trade my Beam for a new one. This one is working perfectly! It's much more convenient to control the volume using a remote than your smartphone.
Badge
@smartandee i traded in my Beam for a new one and still does the same thing! It's either a software bug or a very stupid design flaw. Can someone from Sonos please respond?
I’m adding up to this one- same issue here
Add me to the list. I've been working with their support team and I've tried multiple remotes, multiple rooms, different TVs, ARC vs optical, and switched out with a Playbar that works fine with every combination. Currently waiting on their Tier 2 support team for anything new. Was thinking of running out to the local retailer to pick up another one instead of waiting, but after seeing above response, doesn't sound like a slam dunk.
Badge
@stempy my second Beam does exactly the same thing as the first one. I'm really beginning to think this is a design flaw, or that they cheaped out on the IR receiver, thinking most people will connect via HDMI ARC anyway.
I'm sure when you hooked it up via HDMI ARC, that you didn't have that problem like me, But that's only because your remote then talks to your TV first and sends out instructions to the Beam via HDMI CEC. Optical talks directly to the weak IR receiver of the Beam!
Look at this YouTube film: https://youtu.be/kaLwqyIIA2M
Anyway i'm also in contact with Sonos and i told them to duplicate our problem. They said they would call me yesterday but didn't receive a phone call so far.
Userlevel 7
Badge +26
Thanks for your feedback everyone. If you don't mind, can you post what model TV and if your remote has a special model, that too?

Also, though it may not be the case here, I've seen plasma TVs cause interference on the IR in some cases.
Badge
Hi Ryan, thanks for your response, but i already knew this TV response was coming.
I have a Samsung KS8000 ( KS9000 in the US ) it's one of the highest model TV's from Samsung in 2016.
But it really doesn't matter as the problem is with the Beam itself! I also placed the Beam somewhere far away from all my other devices, ( TV included) but still has the same issue.
I ask with urgency that your higher tech guys at Sonos replicate this problem!? You'll see.
PS. If you try to replicate the problem do not use HDMI ARC to connect the Beam! Just use it by itself or connect it via Optical!
My TV is a 2011' LG 37 LV4500 using optical out. There is no ARC in this LG oldie. I used the original remote and a Logitech Harmony 650.
But I am with Dynamike - it is a problem with the Beam, not a TV thing
Same here, the distance from remote to Beam seems to be less than 1m ( 2-3feet?). Which is pretty short. Hope Sonos can fix it. Sound is great though.
Badge
I just uploaded a video to my YouTube channel about this issue.

https://youtu.be/dmra-ifCtOE
Userlevel 7
Badge +21
I have a Beam connected to a Samsung TV (don't know the model off hand) through the optical connection and didn't run across the issue. I wasn't really testing for it though, so perhaps I missed it. I was mostly looking at music and tested the tv with a firetv input, so didn't use the remote much. I'll take a look at it this afternoon.
Badge
@melvimbe thanks alot, me, the other people on this page and Sonos would appreciate your feedback enormously. I talked to Sonos in the Netherlands and they did not encounter that issue.
Support said it's to early to jump to conclusions, but it can also be certain batches of Beam's that have this problem.
I'll just patiently wait for other users or Sonos to report on this matter. Their costumer support has been great so far i must say.
Hi @Dynamike. Actually, I did have the same issue with ARC. Maybe I got an extra foot of range (4ft instead of 3). Original planned room for the Beam has an LG plasma with optical. I also moved it to another room with a newer TCL Roku LED that has ARC. The Beam remote issue was the same in this room with ARC or with optical. I normally have a Playbar connected to this other room (with the TCL tv). I've tried the Playbar in both locations and it's worked fine. I've given Sonos Support model #s of everything involved. I love the products, so hoping to help find a potential fix for everyone affected.
Userlevel 7
Badge +21
I'm not able to reproduce the issue. The Beam is responding to volume up, volume down, and mute commands. Other commands do not cause the light on the Beam to flash in recognition, which is what I expected. My Beam is not blocking the IR receiver for the TV.

The TV is model UN55EH6000 and the remote model is AA59-00600A. Both are different from your situation.

I did watch @Dynamike's video and I noticed a significant difference. The light on my beam is white. Volume up/down commands will cause the light to blink. Mute will turn the color to a solid green. In the video, your Beam has a solid green light (it was solid, not blinking, correct?). According the document below. a solid green does in fact mean that the unit is on mute.

https://support.sonos.com/s/article/226#Solid_Green

Given that, I would take a look at the current volume setting in the Sonos app, and see what happens with the LED colors when you change volume/mute from with the app. Is it already on mute? Is it operating as it should?

It's hard to tell what the issue is. It could hardware, but perhaps firmware or an issue occurring during setup. It could be some sort of messed up configuration with the remote IR codes. It's best to have Sonos staff come to a conclusion, but I think the LED colors are probably an important clue.
Badge
@Danny, thanks alot for your feedback. My light is solid green because i turned down my volume to the absolute minimum.
I did this so you guys could clearly see a response ( blinking from green to white ) when i push volume down again.
It's a very strange issue, and i really hope this is a software issue.
I used 4 remotes and 2 of these add some extra centimetres to the range.
Sonos is also aware of my YouTube video and are gonna study it.
I'll keep reporting here if i know more. Thanks alot again!
Userlevel 7
Badge +21
Well then, I guess that lights aren't really telling us anything. Nevermind.
Same issue here. Brand new Sonos Beam: bought on Saturday, installed on Sunday. And today is Monday...