Question

Sonos Beam disconnects from Samsung TV.

  • 1 August 2020
  • 3 replies
  • 178 views

My Beam continually disconnects from the TV. I’ve updated the app, ensured the devices on my system are up to date, tried TV Setup (won’t recognise the HDMI-ARC is connected when it is), disconnected all other devices, turned it off and on again… everything that in the past has worked. 
This is becoming an ever more frequent issue, despite the device working perfectly fine for days or weeks at a time it will stop working when there’s been no change to anything else. 
It is at the point now where I would no longer recommend Sonos to anyone. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +16

Hi @dpr861, Thanks for reaching out and welcome to the community. Thanks for bringing this up and we understand where you're coming. I appreciate you taking the time to do some basic troubleshooting to resolve the issue. About your concern on the Sonos Beam that keeps on being disconnected from the TV. I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.
 

Diagnostic submitted 1173909896
 

This is now a daily occurrence despite following all the other trouble shooting tips (no other devices connected, software up to date, setting the TV to HDMI-ARC as audio out...)

 

I have to reset the whole system to get it to work but within 24hrs the problem returns. The TV will recognise the Beam but then disconnect within a few seconds and revert back to the inbuilt speakers. I didn’t spend £400 to look at an expensive ornament...

Userlevel 6
Badge +16

Hi @dpr861, thanks for the update. Thanks for bringing this up and we understand where you're coming from. I appreciate you taking the time to submit the diagnostic report. Upon checking on the diagnostic report. It shows that the HDMI Arc is offline. Kindly try to unplug the HDMI Arc cable from the TV and from the Sonos Beam, and replug it back in after 1-2 minutes. Also, check the CEC settings on the TV if it is enabled. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.