Question

sonos beam and lg ubk80

  • 23 November 2019
  • 8 replies
  • 174 views

Last year I purchased a lg ubk80 disc player.  I have LG 65” tv, and also have the beam soundbar, along with sonos ones.  I would like to listen to cd’s through my beam.  How do I do this


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

As it’s a Blu-ray/DVD/CD player, I assume it will play a Music CD out to your TV and therefore output the playing audio to the connected Beam? Is that not happening for you?

I have never tried my LG Blu-ray Disc player with a DVD or CD. I have used the magic wand, and it appears to be recognized with the right HDMI. Using the remote from the LG, I hit play, and nothing. I do see what appears to be a screen saver on my LG flat screen when I click on the DVD option. 

I can certainly do this with my old PlayStation. I just insert the music CD and play the tracks  from the music menu and it outputs to my Sonos Beam over HDMI-ARC connected to my LG OLED C9 TV.

I would assume the LG disc player would do the same thing? If says it plays music CDs in the reviews I saw online.

I must have a setting wrong. I do not see a music menus on the screen. 

It says here that it plays audio CD’s..

https://www.johnlewis.com/lg-ubk80-smart-3d-4k-uhd-hdr-blu-ray-dvd-player/p3535113

You perhaps need to look at the disc player’s user manual and get it playing on your TV … if necessary, get it playing to your TV internal speakers first, then afterwards switch on your LG TV external Sonos speakers, ‘simplink’ and ‘auto power sync’ to output to your Beam over HDMI-ARC using either the ’auto’ output setting or ’pass-through’, if your TV supports that option.

 I have used the magic wand, and it appears to be recognized with the right HDMI. Using the remote from the LG, I hit play, and nothing. I do see what appears to be a screen saver on my LG flat screen when I click on the DVD option. 

If you see the black and white 'stripey’ screensaver from your Sonos HT device, then you are on the wrong HDMI, or Optical, port. You need to be viewing on the TV port that your playing audio source is connected to.

Hope that solves your issue.👍