Sonos Beam and Bose QC headphones in Samsung TV

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

154 replies


Paid £599 pounds for asmall, low power amp and it wont let me connect my Sennheisser PXC550 headphones at night.

They released the AMP with the marketing giving its main USP that it had been set up for TV, except they knew it disabled a core functionality.


I expect a full refund, inuding my speakers and speaker cables if an update isnt rushed out. This is really pathetic and what one would expect of apple, come on Sonos, the Venn diagram of the type of people who would buy a Sonos AMP / Soundbar and who also listen to wireless headphones in the evening is pretty large.

Either Sonos dont know their customers, dont care about their customers or their beta testing program involves me, in which case I require a refund and asalary thanks.

Very upset the apparent market leader released a new product without mentioning a known fault.


Surprisingly, this issue has been there for 2+ years and it’s still there. I just bought an Arc yesterday (5/2/2021)and got problem with my Bose headphone being hijacked after few seconds.


Someone said due to spec of CEC/HDMI bla...bla. and turning off Any+net, ... Then why Samsung HW-Q800A/ZA soundbar has no such problem? The Samsung soundbar also connected to TV via the same wire and same port (eArc), why it allows me to switch among TV Speakers, Headphone, and Soundbar seamlessly?


I like Arc sound more than Samsung’s, but I have to return the Arc due to this annoying problem. I use headphone a lot at night, so I can accept this issue. Blaming on TV doesn’t make sense because others  can produce theirs soundbar with the same technology and have no such problem

Userlevel 1
Badge +1
So can we assume, due to the lack of any update, that Sonos has given up trying to solve this issue?
I just recently bought a beam and have the same problem with a SamsungTV, Bluetooth headphones and the beam. A fix (other than the proposed clunky workarounds) would be appreciated.
Userlevel 7
Badge +17

A solution to the headphone issue would be OK. But please don’t mess with the HDMI function that automatically turns the sound to the Beam. For this purpose guiding the sound to the Beam is not “stealing” but the way it is supposed to work…….


I have difficulty understanding why you would buy an expensive speaker and then would want to use the low rent TV speakers, even for news .

Instead of fussing with an HDMI switch, with the challenge of passing through ARC, just do as suggested several times in this thread and connect an inexpensive BT transmitter to the TV's optical out. 

I have Samsumg Q950 82” TV with Beam and also Sony XM3 headphones. I find it completely crazy that Sonos does not follow standard CEC protocol and requires me to use separate Bluetooth transmitter for headphones (connected to optical out) because of this stupid “feature”.

Sonos, please disable stealing sound output from TV every 5 seconds. Modern TV:s have good output selection features built in, there is no good reason to override this.
At least let users choose if they need this or not.




I was thinking about recommending this product to my father who needs a soundbar (that supports headphones flawlessly) but sadly, I can't recommend Sonos Beam because of this issue.

A small external Bluetooth transmitter fed from the TV's optical output offers more flexibility, better codec quality, and improved lip-sync. Clunky workaround? It's in fact an upgrade.Stop pushing this as the answer

I'll post as I wish, thank you very much, within the board codes of conduct. Some posters on this thread have appreciated the advice.

Just get onboard the ‘Sonos Fix It’ bus.

I wasn't aware I was offboard the 'Fix It bus', whatever that may be, but don't you think that if it was such a simple 'fix' Sonos would have implemented it? Clearly the TV software has a key part to play since the complaints have involved relatively few TV manufacturers.

In the meantime there's an inexpensive, better quality, lower latency, more flexible alternative, using an external BT transmitter which can if necessary be tucked behind the TV and USB-powered from it. Feel free to ignore it. In any case those Bose headphones wouldn't be able to benefit from the "better quality, lower latency" aspect.

This needs a fix, it's ridiculous. 

Also very interested in this. Any update?

If unplugging/cutting electricity kills a Sonos product, then that’s what I’d call real product quality… Do you have it on 24/7/365 then?

Not 365, but the units are usually powered all the time the house is occupied. They’re designed to be. 

As for ‘product quality’ it’s well known that, of the various factors which determine the lifespan of any electronic component, powering-cycling -- thereby administering repeated electrical and thermal shocks -- is by far the most significant. Typically when a device eventually fails it’s at power-on time.


I’m having the same issue. Tried to turn off TV autoplay in the Sonos app, but this didn’t help. It’s definitely a software issue.
Userlevel 4
Badge +2
Here is the DM I got, for the record:

“The Beam is designed to always take audio priority when connected to your TV via an HDMI-ARC connection. The workaround of toggling Anynet off and on would likely be the best approach. Alternatively removing the HDMI connection from your Beam while using an alternative audio source should also prevent that behavior.”
Userlevel 7
Badge +21
I suppose since I'm in the menus to change the audio output to headphones, I may as well turn off AnyNet+ too... annoying, yes, but I suppose it'll work. I still consider this to be a bug though, and that's just a workaround, IMHO.
Exact same issue here:

Samsung QE55Q8CAM
Sonos Beam via HDMI-ARC port
Parrot Zik V1.10 Headphones and Bose SoundSport Wireless Earphones
Same issue here:
Samsung UE40MU6100
Sonos Beam via HDMI-ARC port
Tested with three headphones: Jabra Halo 2, JBL and Sony
This tv also has optical out. When the Beam is connected via Optical out, the Bluetooth connection remains stable. However, this is not the way I was hoping to use the Beam, because sometimes the internal speaker of the tv wants to add it's voice.
Most annoying to watch in the settings is the Samsung feature to have multiple audio output to internal speakers and Bluetooth, bus this option is greyed out when Anynet is on.
Userlevel 7
Badge +21
The Samsung OneRemote does IR, but it needs to be set up in the "Universal Remote" functionality in your TV. See the support article linked below for more details on how to set it up...

Configure Sonos home theater speakers with Samsung One Remote
I'd hazard a suggestion that you complain to the governing body of HDMI-CEC, who set up the standard that Sonos is complying with?
Userlevel 4
Badge +2
Thanks the reports, everyone. We've been looking into this issue. It's caused by the way the TV handles a command the Beam sends as part of the process to issue CEC commands to the TV like "off" and "on".

I'll make sure to let the team know you're running into this and that it's causing you trouble.

Any progress on this, Ryan?
Userlevel 7
Badge +26
Hi everyone, this is still something that's being looked at, but there isn't any news to share on if there will be a resolution at this time. Because it's caused by the way that the Beam establishes CEC control for TVs, it's a side effect of the core functionality of a feature. Currently, the best solution if you use your headphones a lot is to either disable CEC in the TV settings, unplug the Beam while using Bluetooth audio output, or use the Optical Adapter to connect the Beam to your TV instead.
Hi Ryan - I'm a new Sonos user (recently purchased a Beam, a pair of Sonos Ones, and a pair of Play:5s as we begin to set up our new home), and although I am generally happy with the products, I also find this issue frustrating. I'm hoping that Sonos pushes forward with a better solution for this ASAP.
Set up a profile and adding to this thread to voice my frustration as well.

I just wasted 30 min on the phone with Samsung figuring out why my brand new TV keeps kicking me off my wireless headphones.
They had no resolve obviously.

Can’t wait to hear about the fix and/or compensation for all of our extra time plugging and unplugging 😃
Because I have exactly the same problem (Samsung TV, Sonos Beam, Bose QC35 headphones) I found this Tread.

However, it is frustrating that this problem became known more than a year ago and no viable solution has yet been found.

In today's era of automation, the headphones should be able to be taken off the charging station (once set up) and turned on. Then the audio output of sonos should move immediately to the headphones. No adjustments must be made in menus.

😫I can not suggest the proposed solution to my wife, who would ban the sonos from the house.

On my Samsung TV, I will run into the issue with the HDMI “claiming” the audio output back even when I select digital optical output if I was just to connect a BT transmitter via the digital optical output and keep the beam connected via HDMI (since optical digital is not “always on”). 

Hmm. I guess not all Samsung TVs are born equal then. 

So, I will need to drive both the beam and the BT transmitter from the digital output of TV (and not use HDMI at all) either via splitter or daisy chaining beam from Avantree BT transmitter. This in turn leads to some other inconveniences (eg controlling volumes of the BT output and the beam, using iPhone/sonos app to mute beam etc) 

You can train a Beam to respond to an IR TV remote. On the BT front hopefully you’d have volume control at the headphones themselves.