Question

sonos beam(5.1 with 2x play:1 and sub 2nd gen)-ps4 pro-sony bravia x950g


Hello, 

I’m having nearly a second of audio lag I’ve noticed on my PS4 pro connected to Sony Bravia x950g connected to Sonos beam 5.1 setup. I’m connected via arc in the correct port abut I’ve noticed that in games that are HDR there is definite lag in audio unless I switch to pcm mode on the tv (which sounds horrible). Has anyone else found this to be an issue? 
driving me crazy and must be a fix surely 

 

many thanks for your time

 

Somers


3 replies

Userlevel 5
Badge +15

@somers Thank you for bringing your concerns to us here and welcome to the Sonos Community. We do not have diagnostic report numbers to look at but can you confirm that your PS4 is setup with its audio out as PCM or Dolby and not Bitstream which may be the default setting. Also, are you having any other audio issues with the Beam with TV audio or streaming a music service like Sonos Radio, TuneIn or Pandora? After confirming the audio format please test the audio and reply back with any further issues and a new diagnostic report number.

Also, let us see if any other Community users have come across this issue and can chime in with their feedback as well.

@somers Thank you for bringing your concerns to us here and welcome to the Sonos Community. We do not have diagnostic report numbers to look at but can you confirm that your PS4 is setup with its audio out as PCM or Dolby and not Bitstream which may be the default setting. Also, are you having any other audio issues with the Beam with TV audio or streaming a music service like Sonos Radio, TuneIn or Pandora? After confirming the audio format please test the audio and reply back with any further issues and a new diagnostic report number.

Also, let us see if any other Community users have come across this issue and can chime in with their feedback as well.


Hi John, thanks for getting back to me and welcoming me I appreciate that! It is set to Dolby on the PS4. I also have an nvidia shield tv and that audio is fine and in sync, as is the normal terrestrial tv!?

i have switched to linear PCM on the PS4 and it’s better but still seems out of sync slightly 

Userlevel 5
Badge +15

@somers Thank you for the follow up information and testing steps. Did you grab a diagnostic report number when the issue is happening? Please also confirm that the audio issues are not happening with testing a streaming music service. Basically, if there is no issue with a streaming service and the audio is being heard after the video it will come down to the PS4 and its settings, the TV and its settings or the HDMI Arc cable.

If by any chance you are hearing the audio first then seeing the video move you can try to adjust the sync level in your Sonos product.

Reply