Sonos Arc + Samsung Q90T | Sound Cutting Out | Anyone else?


Userlevel 4
Badge +2

So I recently picked up the Sonos Arc + Sub and a Samsung Q90T TV (which has HDMI 2.1/eArc) and I am experiencing the sound cutting out periodically. Some details:

  • Only devices I can test with are an Xbox One S, Xbox One X and the built-in Samsung TV Apps

  • Sonos, Xboxes and Saumsung are properly set to have Dolby Atmos

  • I have experienced sound cutting out on both Atmos and 5.1 

  • I have experienced sound cutting out from both the Xboxes as well as the built-in Samsung TV Apps (only tested the Netflix app) . . . so I know the Xboxes aren't the issue

  • At times the sound cuts out very infrequently (minutes apart) and other times about every 10 to 20 seconds and there is no discernible pattern on what changes this.

  • There is a sound setting on the TV showing ‘sound output’ that should should normally say ‘Receiver(HDMI-eARC)’ when you have the ‘HDMI eARC Mode’ set to ‘auto’ but sometimes shows ‘Receiver(HDMI)’ instead (as if it lost the eARC signal).

  • The most stable I have seen the sound (though it did cut out once during a 30 to 40 minute session, so perhaps it is just much less likely) is if I go to the Samsung TV settings and set ‘HDMI eARC Mode’ to ‘off’ (only other option is ‘auto’). When doing this Dolby Atmos still works (at least it says so in the Sonos app).

I don't know if this is a Samsung issue, a Sonos issue, or just the two of them working together. Curious if this is some form of eARC / HDMI signaling issue.

Perhaps related side-note: the Samsung settings do say when playing with the settings it may cause temporary muting, which is kind of what this is, so wondering if when in 'auto eArc' mode, there is a problem. Unfortunately there is no way to force on, just 'off' and 'auto'.

On reddit, someone with a Samsung Q80T also said they had this issue. They also mentioned that toggling ‘Dolby Atmos compatibility’ fixed it (though obviously no Atmos). My experience was more temperamental. Sometimes it got better and sometimes it didn’t.

Anyone else experiencing anything like this?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

98 replies

Badge

On advice from Sonos CS I added a CEC LESS adapter which did not eliminate the cut out. I am Still pursuing with Sonos.

Same problem.  Thought I had a nice Xmas gift, but nope!   My TV is Samsung QN65, so it’s certain not limited to the QT90 or any other size/brand.    (multiple brands are mentioned here)

The original post says the Speaker Output flips between ‘Receiver(HDMI)’ and Receiver(HDMI-eARC).   That’s exactly what happens to mine…. anywhere from 5 to 17 minutes apart.   I found I  can easily see  this “flip” occur when, on the TV, I turn ON the HDMI-eARC option, and then go back a screen to watch the Speaker Output flip from ‘Receiver(HDMI-eARC)’ and Receiver(HDMI) … and at the same time the sound cuts-out.   And, watching it for a few minutes, it flips back the other way.

Badge

Is there a fix for ARC audio cut out problem?

Badge

Same issue with Samsung here.  Swapped HDMI cable initially and it was a fix for about a week.  Issue came back yesterday.

Does Sonos have a fix?

Badge
Me he comunicado 4 veces con asistencia de SONOS, finalmente reconocieron que hay un error entre dispositivos SAMSUNG - SONOS, me dijeron que están trabajando en ello pero esta discusión tiene 3 años por lo que no se ha solucionado. Tengo el mismo problema de cortes de audio cada 15 minutos (tv samsung q70t-Sonos beam gen 2).

Bought a Samsung QN 75 6 months ago used my old Samsung power bar and worked fine, at Christmas I got the Sonos Arc hood everything up to the E-Arc hdmi. From the get go sound keeps cutting out every 15 sec off 15 seconds on what is happening the HDMI keeps loosing connection. When TV setting is on auto keeps bouncing back and forth from tv speakers and Sonos hdmi. Not sure what to do return the Sonos Arc for a Bose 900 ???you spend all this money and can’t enjoy 

Same problem here, QN90a + Arc. Sound randomly will not function at all after TV has been powered off for any period of time. Setting audio mode on Samsung TV to Auto corrects the problem, but downgrades audio to Stereo PCM on some inputs (Nintendo Switch among them). Setting back to Pass-Through on the TV options resolves this once more, restoring full surround on affected devices (e.g. 5.1 on Switch)… but only until power cycling TV again, after which it's back to no audio at all.

I am aware that Samsung TVs have some issues with Pass-Through audio. However there has to be a fix for this…

Cables are all high quality 48 Gbps Cable Matters from Amazon. Connections all good. Firmware of all devices is latest.

I was unable to resolve the issue after numerous calls to Sonos including system diagnostic submissions. I returned the ARC and went back to using my old Playbar. There is obviously some issue with the HDMI Arc connection because the optical connection on the playbar works fine.

Have you submitted a systems diagnostic, and contacted Sonos support?

Userlevel 2

Hello. Has anyone fixed this issue? 

I have Sonos Arc, 2SL and Sub with Samsung Q90T and Apple TV. 

The sounds cuts on average about 5 times per hour for a second or two when watching through Apple TV. This occurs with both Dolby Atmos and 5.1 through Netflix and Disney app. 

If I watch something on the TV’s native app, the sound cuts out completely after about 15 minutes. The sound setting no longer says ‘eArc’ and it just says HDMI. I have to go into settings to get it to work again. 

I am running the latest TV software. I am running the latest Apple TV software. I have tried different HDMI cables. I have factory reset everything multiple times. The retailer has even replaced the Sonos Arc. I have tried various settings on the TV. 

I have no idea but from all the similar postings I’m not the only one with the problem. My son has an ARC connected to an LG and has no issues. Maybe it’s a Samsung compatibility thing but I’m certainly not going to replace my TV just to use the ARC. Sonos support was unable to resolve it after 5 calls.

It’s odd, I’ve had two Arcs since they were initially released, connected via ARC or eARC to a pair of Vizio TVs, although one is technically connected to a HD Fury Arcana, and have had zero issues with either one, since installation. The data feeds are XBoxes, DirecTV, and Apple TV devices. Wonder why mine have no issues, and you seem to have significant dropouts. 

I just returned my new Arc and reinstalled my old Playbar. Frequent random audio dropouts made the Arc unusable. Rebooting my connected TV (Samsung Q 90) resolved the issue temporarily until the next dropout. Five calls to Sonos tech support failed to resolve the issue. We tried every suggested fix I’ve read about in the forum but…. nada. I have numerous Sonos products and have been very satisfied until now but seeing all these postings for the same issue makes it obvious that the Arc is not ready for prime time. Besides, the audio from the Playbar is just as good for music and most types of programming. In fact, I think dialog may be even clearer with the Playbar. 

Similar setup and same issues. Really regretting my arc purchase with the lackluster help on this

I’ve had the same problem on a Q80T, with audio dipping for a second or two once every 15 mins or so with Atmos content.   I’ve done some experimenting and setting a 10ms audio delay in the audio settings seems (touch wood) to have resolved the issue.  The delay is so slight that it’s not noticeable, but it seems to give the TV time to do whatever processing it’s doing that I’m unable to switch off!

Userlevel 7
Badge +17

@Slettec If you own a 2020 Samsung with  Connectbox you could apply to Sonos to install the software patch mentioned here: Sonos Arc Samsung Frame TV eARC not working | Sonos Community

First of all, I am having this same problem and will be returning the Arc if they can’t fix it. Might need to return all my Sonos products since the entire point of the Arc was integrating the various rooms in my house, and I don’t want an entirely different system in my den. This is on top of the fact that Sonos seemingly does not care about the issue with their flagship home theater product.

Second, Michel, you should exchange your TV. You are experiencing what seems to be an entirely different problem. I used to have my Sonos beam connected to my Q90T and never experienced issues with sound cutting out. My tv has never asked me to “activate” any ports and HDMI-CEC works just fine with all my devices. With the Arc, my sound cuts out intermittently but otherwise all is well with the TV and the various devices I use.

Sonos needs to fix this. It’s insane that we pay this much for a product that doesn’t work as advertised.

Hi there,

Like many are asking in this thread, it becomes hard to troubleshoot when you have two products working, or in this case, failing hand in hand. Hopefully this post will shed a new light.

I stumbled here has I was Googling for QT90 brief sound cut. Although I own some Sonos products, I have not yet gotten a Sonos Arc because A) I just got the TV and B) The ARC is back-order. In fact, I was hoping to fix that problem by adding an ARC, looks like it won’t. Still, it is on my wish list of things to get. So what I’m saying is that I’m experiencing the 1 sec. sound cut using only the built-in speakers, thus removing the ARC, at least from that aspect of the problem.

So far, my Q90T only has a cable box connected to HDMI 1. I taught it might be that I was using an old 1.4 HDMI cable so I bought a 2.1, that I was planning to buy anyway for a PS5 (also back ordered). No change. Last week-end I streamed a movie using one of the built-in TV app, with no sound cut. As far as the cable box goes, it was working perfectly on an old 26” 720P TV days ago and for years on a 1080P projector.

It is a bit aggravating as a few weeks ago, my daughter bought a much less expensive Crystal 43” ($740) Samsung and we don’t have this sound cut with an identical cable box. Cable box that was from the start recognize as a Videotron device while I had to manually set mine on the Q90T 65” ($2,500) it just seems unable to read the manufacturer’s information from the device. This is something I would have totally missed-out if I had not set-up my daughter TV just before. It was a breeze. Found the box, identified the provider, set-up the remote with no intervention.

One last thing, when my daughter power on her TV while the source is HMDI 1, the cable box gets powered on by the HDMI communication. With my Q90T, it brings me to a screen, asking to Activate the port. It just does not seem to be able to work as seamlessly.

I’m highly disappointed to have pay bigger $$$ and have more issues. So to me, the problem is with Samsung Q series and the way they handle HDMI ports communication. Hopefully it is a firmware issue and not an hardware problem. The good new is that I was now thinking that my TV got damaged during Amazon shipment but now I see that I’m not the only one facing this problem.

Michel

Userlevel 1
Badge

So I recently picked up the Sonos Arc + Sub and a Samsung Q90T TV (which has HDMI 2.1/eArc) and I am experiencing the sound cutting out periodically. Some details:

  • Only devices I can test with are an Xbox One S, Xbox One X and the built-in Samsung TV Apps

  • Sonos, Xboxes and Saumsung are properly set to have Dolby Atmos

  • I have experienced sound cutting out on both Atmos and 5.1 

  • I have experienced sound cutting out from both the Xboxes as well as the built-in Samsung TV Apps (only tested the Netflix app) . . . so I know the Xboxes aren't the issue

  • At times the sound cuts out very infrequently (minutes apart) and other times about every 10 to 20 seconds and there is no discernible pattern on what changes this.

  • There is a sound setting on the TV showing ‘sound output’ that should should normally say ‘Receiver(HDMI-eARC)’ when you have the ‘HDMI eARC Mode’ set to ‘auto’ but sometimes shows ‘Receiver(HDMI)’ instead (as if it lost the eARC signal).

  • The most stable I have seen the sound (though it did cut out once during a 30 to 40 minute session, so perhaps it is just much less likely) is if I go to the Samsung TV settings and set ‘HDMI eARC Mode’ to ‘off’ (only other option is ‘auto’). When doing this Dolby Atmos still works (at least it says so in the Sonos app).

I don't know if this is a Samsung issue, a Sonos issue, or just the two of them working together. Curious if this is some form of eARC / HDMI signaling issue.

Perhaps related side-note: the Samsung settings do say when playing with the settings it may cause temporary muting, which is kind of what this is, so wondering if when in 'auto eArc' mode, there is a problem. Unfortunately there is no way to force on, just 'off' and 'auto'.

On reddit, someone with a Samsung Q80T also said they had this issue. They also mentioned that toggling ‘Dolby Atmos compatibility’ fixed it (though obviously no Atmos). My experience was more temperamental. Sometimes it got better and sometimes it didn’t.

Anyone else experiencing anything like this?

Same, same. Waiting for a solution from either Samsung or Sonos. May not be a Sonos issue in the end, but the perception is out there that it might be Sonos’s problem.  Either way, when folks buy equipment like this it’s often at the same time—Sound/ AV and TV. They might be inclined to ditch the lot for a refund or return just the Sonos since they can do with just the TV audio if they’re really sick of the lack of support. 

Badge

Further update. SONOS support contacted me directly on the 15th Jan and installed a patch to resolve Samsungs out of compliance HDMI, which seems to have resolved the issue for me for my Sonos Arc and Samsung Q95T. Since then I’ve had no issues and not had to reboot once. They did advise it was a temporary patch while they work on a permanent fix, but so far it’s worked for me.

If anyone is still having problems I would recommend mentioning this patch to Sonos Support and see if they can get it to you.

SO far so good for me on the Q90T, I set the audio to passthrough and am using a Chromecast with google tv + Samsung os apps.

 

 

Same here is happening with a brand new samsung Q80T. Sonos said it is a known issue and to report through the app each time the sound is cutting.

 

It is only happening when playing Atmos content.


 

For me its happens when the tv and arc comes back from standby after the night. With all types of content. Cutting audio, like 1s sound 2s mute. 
 

we are all a bunch of beta testers.. 

 

 

Same here is happening with a brand new samsung Q80T. Sonos said it is a known issue and to report through the app each time the sound is cutting.

 

It is only happening when playing Atmos content.

Is there any progress in this issue?

 

I bought Samsung The Frame and a Sonos Arc Home Theater -kit i November.. and had nothing than problems with cutting audio. Both from native Samsung apps and with a Apple TV.

 

And this thread is from June? 
 

Is Sonos a startup and the users beta testers?

 

This is a huge problem, just Google it.

 

Best Regards

A very disappointed customer.

I am running into an issue where I have my Q90T using the eARC to the Sonoc Arc. When we pause the tv for some time, the audio will drop and the only way I can get it back is to restart the tv. Anyone have any suggestions for this?