Answered

Sonos arc - no Dolby Atmos with LG OLED55G16LA

  • 21 June 2022
  • 5 replies
  • 100 views

My setup is:

  • LG OLED55G16LA
  • Sonos Arc connected through eARC
  • XBOX series X 
  • Nintendo Switch

From another thread in the formal I followed this suggestions:

From https://www.avforums.com/threads/lg-oled-g1-evo-owners-and-discussion-thread.2352393/page-26

  1. Change your Sound Out to HDMI ARC
  2. Go to All Settings -> Sound -> Additional Settings and turn on eARC.
  3. Under All Settings -> Sound -> Additional Settings -> Digital Sound Out select “Pass Through”

 

When I use the Xbox Series X I see in the iPhone app that sound reproduced is Dolby Atmos.

When I use the TV apps (Disney+, Apple TV+, prime video, HBO max) and I select a movie with Dolby Atmos tracks, then I don’t see in the iPhone app that it’s reproducing Dolby Atmos I see Dolby Digital Plus 5.1 or Dolby Digital 5.1… so no Dolby Atmos.

If I use the TV apps (Disney+, Apple TV+, prime video, HBO max) with the same movies and without the Sonos arc then I see the TV reproducing Dolby Atmos for those movies.

 

How can I get Dolby Atmos from the TV apps with Dolby Atmos content in the Sonos arc?

icon

Best answer by petewhiteside80 24 June 2022, 18:20

View original

5 replies

Userlevel 7

If you set Digital Sound Output to Auto instead of Pass Through, does it make a difference?

With the sound output changed to automatic then the iPhone app shows a different sound mode. The mode displayed with auto is dolby multichannel PCM 5.1 I still don’t see dolby atmos when playing movies directly from the streaming tv apps.

Userlevel 7

With the sound output changed to automatic then the iPhone app shows a different sound mode. The mode displayed with auto is dolby multichannel PCM 5.1 I still don’t see dolby atmos when playing movies directly from the streaming tv apps.

Keep the setting on Pass Through. And go ahead and set HDMI Input Audio Format to Bitstream.

Are you using the HDMI cable that came with the Arc?

Also be sure you are using the English or original language audio track.

I have the same tv LG G1.

 

Settings for Atmos confirmed working on my TV, Atmos always shows in the App playing Atmos Content

 

Sound Out : HDMI(ARC) Device

Digital Sound output : Pass Through

Input Audio Format : Bitstream

eARC Support : Enabled

 

Are you definitely using a HDMI 2.1 Cable between the eARC HDMI port on the G1 and the Arc  ? 

 

 

 

I’ve been using the HDMI 2 port of the tv, that is the eARC port with the same hdmi cable that came with the Sonos arc.

I don’t see the “input audio format” option in the menu. I’ve been searching for it and I can’t find it.

 

Though since Friday, the iPhone app is displaying dolby atmos magically where there were no atmos before. So it seems it began to work with movies and series where the app was nos showing atmos. It’s curious because I haven’t changed any configuration of the tv, and I haven’t changed any connection or cable. And the bar was updated since I took it out of the box.

but now it’s working. Thanks for your help.

Reply