Question

Sonos amp - doesn’t remember group on Autoplay

  • 6 December 2019
  • 8 replies
  • 93 views

Recently installed a amp on my TV and when it auto plays it doesn’t pull in the grouping it was previously tied to. I have no the unground on auto play turned off. 

 

I previously had a connect amp and a line in from the the TV and it worked flawlessly for ~5 year. Keeping the grouping from previous and auto playing. I updated to the new amp for ARC and the increased power. 
 

Any suggestions?

 

 


8 replies

I am not quite sure what you are saying. No Sonos product has ever 'remembered' how it was previously grouped. If the speakers are not grouped at the point the Autoplay takes effect, they won't group. 'Include grouped rooms' or 'ungroup on Autoplay' just determines whether an existing grouping is maintained.

Sorry if I explained it poorly!  

My previous setup, was

Connect Amp, ZP120, with line in from TV

Autoplay turned on

Connect tied to 12ch amp powering overhead speakers in kitchen

 

Old setup

Whenever I turned on the TV, the connect Amp ZP120  would come on and it would play/ group with the previous group it was tied to when it turned off last (my kitchen in this case).  This configuration has worked flawlessly for the last 5 years.  Thus I know it’s possible.  

 

New setup/ my issue

When I turn on TV, new Sonos Amp plays sound from TV but it never plays sound from any other group, my kitchen, no matter what, regardless of if ‘ungroup on autoplay’ is selected or not on the Sonos amp.  I have to manually go in and group the TV to my kitchen every single time - super annoying.  

 

99% of the time when I turn on the TV I want it to play from the TV Sonos amp and Kitchen group.  Kitchen group is a centrally located Connect sending sound through my in-ceiling kitchen speakers.  

Make sense?  

Any existing group should be maintained. Is the TV connected to the HDMI or the RCA line in?

Go into settings on the Amp, go to TV Settings, turn Ungroup on Autoplay to off.

Go into settings on the Amp, go to TV Settings, turn Ungroup on Autoplay to off.

According to OP it is already off, but I was wondering if it was the right input.

Any existing group should be maintained. Is the TV connected to the HDMI or the RCA line in?

Tv is connected via hdmi. 
 

per other question ungroup on autoplay is off. 
 

Maintaining groups is exactly what I’m looking for and is what it’s NOT doing. 

Thought I would add a little more details.  Tired a few things.  
 

Reset the amp to factory settings - same issue. 
 

If play music with my living room and kitchen grouped then turn on the TV to the living room the living room will ungroup (even with ungroup on auto play off). 
 

Previously the group would stay and TV sound would play through the group.  

Did I stump the forum?!

 

Will call back into Sonos support but wasn’t super impressed last time so was really hoping someone on here had a quick/ easy fix :)

 

 

Reply