Sonos 5.1 + Samsung + ATV 4K settings help

  • 18 December 2018
  • 0 replies

Userlevel 2
Badge +1
I have Playbar + Sub + 2xPlay 1. It's hooked up to the toslink cable from my Samsung (KS7005) TV's "One Connect" box. 99,5% of my viewing is done from my ATV 4K, which is connected via HDMI to the "One Connect" box - the remaining 0,5% is watching DVD/BD from my old BD player (also connected to the "One Connect" box via HDMI).

My ATV 4K is setup to output Dolby Digital 5.1. I stream my own movies from my NAS using the Infuse Pro App. The Infuse Pro app is set to "Auto" (I can also select Passthrough). My movies feature a mixture of DD5.1, TrueHD, DTS and DTS HD-MA.
I also watch Netflix, HBO and stream TV from my ATV 4K (these apps have no sound options).

In the Sonos app controls everything for my Playbar+Sub+2xPlay1 are standard settings (Loudness on and all levels in the middle).

My TV was set to HDMI Input "PCM" and Output as "PCM". This gave my TV sound (from streaming local tv stations) great surround with loads of bass. Netflix and HBO wasn't bad either, but the surround wasn't convincing. My movies were great in surround but they lacked the bass punch. I tried a couple of test videos (DD, TrueHD, DTS and DTS HD-MA tests). These sounded ok, but not as great as I thought.

I then tried adjusting my TV's audio settings to HDMI "PCM" and Output to "Dolby Digital 5.1". This resulted in the test videos sounding really really good (extremely loud though), my movies had great surround and loads of bass (also very loud) and Netflix and HBO with great surround and bass (loud but not as the tests and movies). Sound from TV streaming however, was low, without great surround and lacked bass. I checked the level in the Sonos app and that was almost turned all the way down (around 2-3 clicks on the remote from bottom) and still movies and tests where really loud.

I tried changing HDMI to "Bitstream", which didn't change the sound but caused lagging in the videos.

Is this the way it's supposed to be set up? Could the missing bass and low surround from TV streaming be caused by TV channels sending out stereo audio instead of DD5.1? Can I do something else in my setup - maybe insert a dedicated video/audio splitter (that creates a DD5.1track) between my ATV 4K and the "One Connect" box and this way bypassing my TV entirely for audio?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.