Answered

Samsung Smart TV Remote


We bought the Samsung 55" UHD curved LED Smart TV on Amazon Prime Day July 12, 2016 but its smart remote won't control my Playbar's sound. I'm using the Optical jack on the TV and can hear good sound from the Playbar, but can't control the volume. I used the Sonos Settings --> Remote Control Setup to no avail... The remote seems to use IR.

Any ideas would be appreciated since both are 2016 models.
icon

Best answer by Ryan S 22 December 2016, 18:43

We've created an FAQ on our support site to include directions for using the Samsung Smart Remotes with Sonos. If you have any questions or trouble, please follow the steps here.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

59 replies

Userlevel 7
Badge +21
Either that or it's telling the remote to send out the IR code that your Playbar is looking for.
I guess so, but this would demonstrate a level of sophistication by Samsung not demonstrated in their previous support of the Sonos Playbar.
It must be controlling the Playbar volume via your home wifi network, as the Sonos app does.
I've noticed that the Samsung Smart View App on my iPhone can control the Sonos play bar volume. Confused how this is even possible as unlike the smart remote my iPhone can not emit IR. setup is a 2016 KS Samsung tv with play bar.
Userlevel 7
Badge +26
I'll pass that on inopinatus so they can look into it. The team will test it out and see about adding something to the end if needed.

Thanks!
Userlevel 4
We've created an FAQ on our support site to include directions for using the Samsung Smart Remotes with Sonos. If you have any questions or trouble, please follow the steps here.
The new FAQ is incomplete and misleading. In particular the last paragraph.

The K series comes with two remotes - one a smart device, the other a standard IR controller. If you want your Playbar's volume control to be adjustable with both (and who wouldn't?), then the Remote Control Setup in the Sonos app must be completed using the standard controller, not the smart one.

However the FAQ does not clarify this.

Yes it seems weird, and it is weird, but also happens to be true, and appears to be due to the smart controller emitting extra control codes before the standard volume up/down.

This is especially confusing because the Samsung TV requires that you use the smart controller during universal remote setup.

Re-tested today (23 Dec 2016) with Sonos version 7.0 and latest Samsung software 1154 on a KS9000.
Userlevel 7
Badge +26
We've created an FAQ on our support site to include directions for using the Samsung Smart Remotes with Sonos. If you have any questions or trouble, please follow the steps here.
Userlevel 4
...it should fallback to some kind of "default volume control mode", and I agree, so maybe our next campaign with Samsung technical support can be this.
I've lodged this via Samsung's CEO contact form (google it, this varies by country) and got an acknowledgement of the feature gap and a thank-you-for-the-feedback note written by an actual human, which is a better response than I expected. So here's hoping it makes its way to a relevant product manager.
Userlevel 4
As others have noticed, the smart remote only functions when the TV is powered.

Are you able to control PLAYBAR volume/mute from the Smart Remote when the TV is turned off - i.e. you are listening to music on Sonos?


No. See final comment above. This is to be expected; the smart remote isn't actually smart. It depends on the TV to tell it how to behave, depending on which source is currently playing. So it's actually the TV that is smart, and when the TV is off the smart control is reduced to being a dumb on switch.

I know what you're thinking, it should fallback to some kind of "default volume control mode", and I agree, so maybe our next campaign with Samsung technical support can be this.
As of a recent Samsung software update for my KS9000 I can now control the Playbar volume from both the Smart Remote and the IR remote. Hurrah!

Setup procedure:

With the Samsung Smart Remote:
1. Click the Home button and navigate to Source -> Universal Remote.
2. Select New device -> Home Theatre
3. Enter "Sonos" as the brand, attached via Optical.
4. Do the power on/off test. Tell it Yes and click Done.

Now in the Sonos App:
5. Go to Settings -> Room Settings -> Playbar -> TV Setup and Control
6. Select Remote Control Setup -> Add/replace current remote
7. Follow the prompts to program it with the Samsung Infrared (old-style) Remote Control. DO NOT USE THE SMART REMOTE FOR THIS STEP.

And after these steps I now find that the IR blaster on the Smart Remote sends the Samsung IR Volume Up/Down/Mute. It is mixed in with some other codes, which is why you have to use a classic Samsung IR remote in step 7. You must now select "Use With Home Theatre" when configuring other sources, to activate Playbar volume control for external sources like Apple TV, PS4, cable STB &c.

I had been badgering Samsung to update their IR code database to do exactly this. I know others have as well. Perhaps we finally got through to someone able to make a difference. It's definitely a change they made in the last few weeks.

As others have noticed, the smart remote only functions when the TV is powered.


Are you able to control PLAYBAR volume/mute from the Smart Remote when the TV is turned off - i.e. you are listening to music on Sonos?
Userlevel 4
As of a recent Samsung software update for my KS9000 I can now control the Playbar volume from both the Smart Remote and the IR remote. Hurrah!

Setup procedure:

With the Samsung Smart Remote:
1. Click the Home button and navigate to Source -> Universal Remote.
2. Select New device -> Home Theatre
3. Enter "Sonos" as the brand, attached via Optical.
4. Do the power on/off test. Tell it Yes and click Done.

Now in the Sonos App:
5. Go to Settings -> Room Settings -> Playbar -> TV Setup and Control
6. Select Remote Control Setup -> Add/replace current remote
7. Follow the prompts to program it with the Samsung Infrared (old-style) Remote Control.
DO NOT USE THE SMART REMOTE FOR THIS STEP.

And after these steps I now find that the IR blaster on the Smart Remote sends the Samsung IR Volume Up/Down/Mute. It is mixed in with some other codes, which is why you have to use a classic Samsung IR remote when programming the Playbar.

You can now select "Use With Home Theatre" when configuring other sources on the TV, to activate Playbar volume control for external sources like Apple TV, PS4, cable STB &c.

I had been badgering Samsung to update their IR code database to do exactly this. I know others have as well. Perhaps we finally got through to someone able to make a difference. It's definitely a change they made in the last few weeks.

As others have noticed, the smart remote only functions when the TV is powered.
One further note. When the Samsung TV is off, the old fashioned IR remote still controls the volume. The curvy one does not, which is not surprising since I suspect that the TV's Connect is pumping out the iR to the PLAYBAR.
Yes @daveharc, thank you. This works for my Series 8. I had an Apple TV connected and switched it's output to Home Theatre. Now both remotes work (the Curvy one and the old fashioned IR one). I am not sure how you would do it if you did not have an additional device connected to the TV but I am up and running.
Can also confirm as a new Ks8000 owner, this definitely worked. My Apple TV, XBoxOne and Cable inputs all work with the tv remote and volume controls the Playbar.

I managed to get this to work much simpler than this but it isn't obvious.

1) Go to the universal remote setup on the Samsung tv.
2) Type Sonos in the brand manufacturer selection box and select it.
3) When it asks if it powered off just select yes.
4) Now this is the key part...go back to the universal remote setup and select one of the other input devices, there should be an option that says use with home theatre select this option.
5) Do this for all of your active inputs.

Having to do those last two steps is not obvious.

This worked for me let me know if it worked for you.
Thank you so much community I have the SHUD 9500 Samsung 2016 curved 65in this has been an issue for weeks. Adding the Samsung as a sound system works great but I lost some TV functions in the remote. But found a way around that to.
Daveharc,

After trying all of the other suggestions in this thread, finally your solution works for my 2016 Samsung TV.

As an aside, the process will rename your input devices, for example, SKY becomes SKY-SONOS, BD becomes BD-SONOS. You are able to edit this though, and revert the name back to its original, to keep it all looking neat.

I've had the fix for a couple of days, and can confirm this sorts all channels including native apps etc like Netflix.

Thank you!!
Sorry I forgot to mention one part, select the input as Optical as you would expect, as this is how the Sonos is connected.
I managed to get this to work much simpler than this but it isn't obvious.

1) Go to the universal remote setup on the Samsung tv.
2) Type Sonos in the brand manufacturer selection box and select it.
3) When it asks if it powered off just select yes.
4) Now this is the key part...go back to the universal remote setup and select one of the other input devices, there should be an option that says use with home theatre select this option.
5) Do this for all of your active inputs.

Having to do those last two steps is not obvious.

This worked for me let me know if it worked for you.
Like many people in this string, i periodically tried again and again to set up volume control on a Samsung Smart TV controller for the Playbar, following instructions on sonos.com and in tech forums. I finally just started playing around with settings and made this discovery. When I changed the source for the Samsung and the Sonos components to HDMI, instead of Optical, the volume control worked immediately. (I did not try changing the settings independently, so if may have been only one that needed to be changed.)

Worked for me as well !
I have the Samsung UN75KS9000FXZA and can confirm this thread helped get me working.

Process went something like this:

Press Home Button on the remote.
Apps will be displayed across bottom of the screen.
Press the left arrow until you get to Sources.
Select Universal Remote (you'll have to push up once then left a couple of times).
Add a Home Theatre - JVC.
It'll do a power test, say yes.
In Sonos go to Room Settings | Select Room | TV Setup and Control | Remote Control Setup | Follow the wizard.

If that doesn't work you may need to adjust the settings inside the Samsung Universal Remote app. I had an Apple TV source, which now says Apple TV-JVC like they 2 devices are joined together.

Hope the helps!
Like many people in this string, i periodically tried again and again to set up volume control on a Samsung Smart TV controller for the Playbar, following instructions on sonos.com and in tech forums. I finally just started playing around with settings and made this discovery. When I changed the source for the Samsung and the Sonos components to HDMI, instead of Optical, the volume control worked immediately. (I did not try changing the settings independently, so if may have been only one that needed to be changed.)
You are all missing a key step. Add Samsung home theatre device and select optical. Do the power test and when it asks if it worked select No. Notice the message at the top of the screen changes and it will ask you to power test the device again. Select yes! It is this that then turns the IR on. Then add the remote for the playbar as per the normal process.
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?

hi Craig, the optical is on the end of the one connect box opposite end to the usb, and yes playbar sound great.


Also I'd like to say this tv comes with 2 remotes a standard type and a slim one which is pictured in one of the earlier comments,
the standard remote works on playbar fine along with sky remote its the slim one that wont work the sound, and sods law its the slim one i most like to use.🆒
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?

hi Craig, the optical is on the end of the one connect box opposite end to the usb, and yes playbar sound great.
Userlevel 1
Badge
Hi John, from looking up some information on this TV I was not able to find any optical audio outputs on the TV or the box which connects to the TV, just to confirm were you able to hook up this TV to the PLAYBAR?