Samsung one remote not working with Sonos Playbar (incl Workaround)

  • 4 November 2020
  • 15 replies
  • 10213 views

Userlevel 1

Hello,

 

For two weeks now I am the proud owner of a Samsung Q95T TV

When I installed the Sonos playbar to work with the Samsung One remote I followed the following instructions → https://support.sonos.com/s/article/3444?language=en_US

This worked like a charm.

 

However suddenly today the One remote no longer communicated with the Playbar, no matter what I tried (followed the instructions again , did a hard reset of my playbar etc. ) nothing worked. 

 

After browsing through the community I found a workaround (Select Samsung as home cinema brand).

 

I am nit-picking here but what I do not like is when I now press volume up/down it says Samsung instead of Sonos and of course I can perfectly live with it

But I just want to know Why do I need to select Samsung as brand to get my Sonos to work. ?

 

--------- Workaround ----------

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung (instead of Sonos)
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

----

#Shoutout to af2k for posting this Workarond at Community Post


15 replies

Userlevel 5
Badge +14

Hi @Robbert's son.

Welcome, thank you for reaching out to Sonos Community and Sharing your workaround.

If you need help with any other information, please be sure to let us know.

 

Crazy!

It felt like I was typing in a gamboy cheat code XD, but it worked!.

Thank you!

 

Work like a charm. Thank You !

Amazing! Thank you!

You sir, are a genius! 
 

Thank you for figuring it out and for sharing. 

Oh gosh thank you for posting. Been trying to figure out for six months. Sonos Support had no clue. For me, had to select Samsung and go through the four tests (not one, two or three - but the fourth), and then the Sonos remote setup (volume + push) and it finally worked. 

Awesome!
I almost gave up before I read your workaround.
I have a Samsung 65RU7475.

Seems like the 4 times trick did the magic.
SW is fun almost everytime ;)

Big thanks!

Userlevel 2

Wow!  Been messing with my Samsung Qn90a TV for 3 days. This worked!!

I followed the steps, however after the 3rd attempt to do the Power Test, my TV automatically goes to a screen to “Search for Model Number”.  So I don’t have the option to get to the 4th attempt.  I tried to set up the remote on the Sonos app at this point, but still no luck.  Any other suggestions?

For reference, my Samsung TV is UHD 4K MU8000 Series 8

I followed the steps, however after the 3rd attempt to do the Power Test, my TV automatically goes to a screen to “Search for Model Number”.  So I don’t have the option to get to the 4th attempt.  I tried to set up the remote on the Sonos app at this point, but still no luck.  Any other suggestions?

For reference, my Samsung TV is UHD 4K MU8000 Series 8

Mine is doing the same thing. Funny thing is this workaround succeeded for me about a year ago…..now remote stopped working and I can’t get to the 4th attempt now. 

Hi, same prob as above - playbar suddenly stopped working with samsung one remote - no 4th power test available after selecting “samsung home theater”, no 2nd power test on sonos, I am required to input model number instead...

sw v1300 on Samsung UE55MU7005

Anyone got an idea?

It’s been known in the past for updates to the TV’s OS (potentially without your knowledge) to change the Samsung One remote back from IR to Bluetooth. Have you gone through the recommended process for setting it back up?

I had the same problem and the workaround fixed it. Thank you!!!

Hi, same prob as above - playbar suddenly stopped working with samsung one remote - no 4th power test available after selecting “samsung home theater”, no 2nd power test on sonos, I am required to input model number instead...

sw v1300 on Samsung UE55MU7005

Anyone got an idea?

Same problem here.  I was trying a year ago to get my remote to work w/ Sonos but was so frustrated and gave up.  I tried this but it didn’t work as I’m getting the same thing after the 3rd power test.  Model UN65MU8000.  Remote is working with the TV fine just won’t control the volume on Sonos.  I do have an older play bar so maybe that might be the issue?

If your using a PLAYBAR, the commands won’t carry backwards across the optical connection. You’d need to tell the remote to use IR, and not a ‘smart’ connection. Probably covered in the FAQ.

Reply