Answered

Playbar--Switching from Music to TV


When I switch to a music service on the Playbar, I noticed it affects the volume range for the TV audio.

Going from music to the TV--->the audio seems low. I will raise the volume on the remote to hear the TV. It will be about 70-80 (out of 100) on the screen. It is usually at about 20 for the volume and it is fine. There are times that I noticed I reach the max and barely hear the audio from the TV

To get out of this condition, I change the volume to zero on the TV and then do the same on the App. The volume then works properly,
icon

Best answer by UKMedia 7 June 2018, 10:02

Hi

I suspect that you are still adjusting the TV volume rather than the Playbar volume directly. What remote are you using to control your TV audio? Have you followed the steps in this article:

https://support.sonos.com/s/article/2072?language=en_US
View original

26 replies

Userlevel 7
Badge +26
Great suggestions everyone! As others have said, if the Playbar (or any other Sonos player) switches to the TV input, it means that the signal was detected by Autoplay.

In my experience, it's usually from the TV waking up briefly to send data over the network (this can be done without the screen even turning on). So you can check auto-updates in the TV or some other settings that might include the wake on LAN or other data services that might kick on.
Badge
I am having the same symptoms of sean808, listening to music in 2 play 1 (LR) grouped to my playbar + sub and TV Hisense 55h9e Plus (androidtv) turned off, the music of playbar + sub turns off and I see in the app sonos on android phone cell phone that is active the TV, with the TV turned off!

any suggestions?


Continuing with the search to solve this problem, check and disable the settings of automatic updates of the system and applications, Wake on LAN and for now takes 2 days without the problem of changing without reason to the TV. Hopefully it will continue, I will report later.

My TV is Android TV.
Badge
Turn off autoplay for the PLAYBAR's room.

Your TV is sending some signal to the PLAYBAR, for unknown reasons, that's causing it to switch back to the optical input.

Try updating the firmware on the TV. Read Ken_Griffith's post above.

If all else fails, try contacting Hisense, and asking them why your TV is sending a signal out through the optical connection when the TV is off.
code:
 Airgetam, Thanks for your recommendation.
Turn off autoplay for the PLAYBAR's room.

Your TV is sending some signal to the PLAYBAR, for unknown reasons, that's causing it to switch back to the optical input.

Try updating the firmware on the TV. Read Ken_Griffith's post above.

If all else fails, try contacting Hisense, and asking them why your TV is sending a signal out through the optical connection when the TV is off.
Badge
I am having the same symptoms of sean808, listening to music in 2 play 1 (LR) grouped to my playbar + sub and TV Hisense 55h9e Plus (androidtv) turned off, the music of playbar + sub turns off and I see in the app sonos on android phone cell phone that is active the TV, with the TV turned off!

any suggestions?
Sean 808,

I use an LG TV, but I’m using a Sonos Beam rather than a Playbar and the connection is via HDMI-ARC.

Keeping things simple an optical switch just sits between the TV and playbar and allows multiple audio sources IN and just one OUT. My thoughts were to try one and see if that stops the signal getting through to the PlayBar, alternatively you could simply switch the audio source IN, so it effectively disconnects the TV from the PlayBar when you are playing music.

Its not ideal, but it should (hopefully) resolve the issue. Here is one randomly chosen example from Amazon ...

https://www.amazon.co.uk/LiNKFOR-Switcher-Extension-Dolby-AC3-Compatible/dp/B07KGQ5NLK/ref=sr_1_1?crid=3U51GBYN90AHE&keywords=optical+switcher+2+in+1+out&qid=1564045504&s=gateway&sprefix=Optical+switcher+2%2Caps%2C148&sr=8-1

Personally speaking, I would first call the TV support desk and see if they can offer a solution or suggestion to try.
I've been using Vizio TVs for around the last 10 or so years, used to be Sony (was for a time a Sony employee, so I got an employee discount, which made it attractive) While I'm mildly concerned about the data from the TV being used, I've followed all the suggestions on how to turn off data tracking....and frankly, pretty much use either Apple TV or DirecTV to feed the set, and none of the internal apps. I've had absolutely no issues with Vizio and Sonos....other than one time, about 5 years ago, when the TV firmware update that Vizio sent changed my audio preferences. There's been dozens of updates since then that I've had no issues with.

I think the one I have in front of me is a Vizio p75 f1, I've got a second Vizio in my bedroom.
Unfortunately I don’t have another tv to experiment the connection issue with.
last night I attempted disabling Apple TV in the Samsung settings and Anynet+ on the Samsung TV, unfortunately neither did anything and the problem still persists.

ken,
what is an optical switch?

what TV do you guys have connected to your play bars? I’m thinking of returning the tv to Costco already since I’m still within the 90days. I’m curious if there are better brands out there that you guys have that are less problematic. My wife and I only stream tv from Netflix, Hulu, hbo, etc... we aren’t very tech savvy and this tv and sonos speaker system is the first real quality entertainment system we’ve ever owned.

By by the way I appreciate all the input your guys have given us.

Thanks
sean
I’m pretty sure it will not be the PlayBar, as the Toslink connection is not a bi-directional connection and information flows just from the TV output to the Playbar. I think it’s easier to try another TV, to simply prove where the problem lies.

My advice would be to try that, and once the finger of blame points at the TV, then maybe speak to Samsung Support to see if they are aware, or perhaps have a fix, for the issue. It maybe the TV regularly polls it’s connected devices to ensure they are still there.

I’m just wondering that if it is the TV and there is no way to disable the feature, if an optical switch between the playbar and TV might be the answer here, to prevent the signal getting through when the playbar is playing music.
Userlevel 6
Badge +12
Try unplugging the tv completely, and batteries out of the remote. That might isolate the problem towards being the Playbar.
Hi Nik9669a,

no no pets and the tv and Playbar are both less than 1 week old. Just put in the remotes batteries the other day when we set up the tv.
by the way as I’m typing this the Playbar somehow switched from my music to the tv signal... and the tv isn’t even on! Darn it. The problem persists.
Userlevel 6
Badge +12
Just a couple of other possibilities I can think of:

Any pets walking on stuff?

Low battery power in the in the remote control?
Hi Ken,

So I have tried a couple of things so far, one by one to see if any particular one isolates the cause of the issue. Unfortunately my problem persists. I’ve tried the following:

1) ensured my Samsung series 6 (Costco) is up to date
2) lifted my speaker up off my carpet, I had it sitting on carpet with the cords facing down against the carpet.
3) disables auto updating on Samsung TV
4) factor reset of TV
5) called Samsung to report the issue to them. They simply said they didn’t know why sonos would claim the tv is putting out a signal because according to them when the tv is off it doesn’t send or receive any signals. I don’t believe that but it’s what they claim.

so far none of these have worked... I might try to go into the tv settings and see if I can figure out how to disable to hdmi auto detect. Aside from that I’m at a lose for what to do...
any other ideas out there? My other option is to return it all to Costco since I bought it all from there. Hoping to avoid this though.
I found this link too. It's a slightly different Samsung TV model, but with a similar issue perhaps. It's worth a read at least...

https://us.community.samsung.com/t5/4k-8k-and-Other-TVs/2017-Samsung-MU8000-Turns-itself-on/td-p/216750

I also wonder if the TV is checking for updates when in standby, or perhaps updating the TV guide etc?
In fact I was thinking of you having a Sonos Beam connected over HDMI, rather than a PlayBar over optical but it is quite possible the TV is sending out a signal of some sort over the optical port.

Have you checked to see if there is a firmware/software update for your TV? It might be a case Samsung are aware and may have fixed the issue.

I see no harm in disabling the HDMI auto detect feature. That's worth trying.

I would check/re-seat or replace the optical cable too, if the problem persists.

When re-seating the cable I would power off both devices completely (not just in standby mode).

A factory reset of the TV is also another consideration, perhaps?

i hope you find the cause, as it must really be quite frustrating.
Hi Ken,
i called sonos and they said almost the same thing... they believed the TV was occasionally sending a signal out when it was off. I have a Samsung series 6 and it’s connected via the digital optical audio cable rather than an HDMI. I do not have any other pieces of equipment connected to the TV aside from the Playbar, we just watch streaming programs like Netflix, no actually cable connection.
Do you think disabling HDMI auto detec help?
Sean 808,

It almost sounds like an HDMI CEC instruction coming from/through the TV whilst it’s in standby.. check/exchange the HDMI cable and see if that helps.

Also...

Do you perhaps have any other peripherals connected to the TV HDMI ports? If so, I would goto the setup on those peripherals and turn off their HDMI-CEC features, or just uncable them temporarily, to see if that may solve the issue.
So I gave the auto play selection on the tv another try and it did it again this morning. I was listening to music with the tv off and suddenly the sonos app switched to TV and cut music off to both my play bar and play:1 speakers.
I bought all the speakers at Costco. Do you think it’s a hardware issue?
i currently have the speaker sitting on my carpeted floor too as I haven’t had time to mount it and don’t even have a tv stand yet. Do you think that could cause an issue (overheating or wires underneath being triggered)?
thanks
Sean

also, do employees of sonos monitor this? Any chance they’ll chime in?
Let us know...I'm not the final word in all things in this world, despite my best intentions. It's certainly possible I've missed something.

🙂
Hi Bruce,
Thanks again for the response. Ok, that’s strange because I know my tv was turned off. I’ll try leaving auto play on again and giving it another try. I’ll post here again if I have another problem with the auto play function.
sean
The only reason that autoplay would be triggered is if there was a signal coming from your TV across the connection to the Sonos.

If your TV isn't causing that signal, which would switch from any music you were playing to the TV input, then I've got absolutely no clue what is going on. The Sonos doesn't switch without either a signal coming in on the digital input, or you selecting something on the controller.
Hi Airgetlam,

you may have answered the question earlier today. I’m not sure. Either way, I did just that and it worked but I was wondering if their is another fix. Reason being... I don’t want to have to open the app and switch the bar to the TV everytime I watch tv. I was hoping to take advantage of the auto play feature so that every time I turn on the tv it auto connects and overrides the Spotify audio app.
The problem I was having with the auto play on was that every time I was playing music with the tv off, after a few minutes the Playbar would some how auto configure to tv even though the tv was not on. Have you or anyone else ever had this issue and fixed it without having to turn off auto play?
thank you.
It's in Room settings. Turn off autoplay.

Didn't I answer this question earlier today?
Do you guys know how I can stop my playbar from switching (uncommanded) from my Spotify music to the TV when the TV is not even on? Any idea why this would happen also?
Thank you.
Thank you so much! I did not realize that they needed to pair the remote to sonos.

Reply