Question

Not receiving Dolby Digital


I have a Beam and two 1s set up as surrounds. I have changed all the settings on the TV to Dolby Digital but on the app it says Audio in: Stereo 2.0.

I’ve spent an hour on the phone with support but to no avail. Can anyone help - I am on the brink of returning all of this and getting a system from a different manufacturer. 

The TV is a LG 65um7000pla


4 replies

What kind of TV? this happened to me starting out, but I changed output from Bitstream to PCM, and voila! Secondary output mode should stay Dolby Digital. 

I’d contact Sonos Support directly to discuss it, before boxing it up, but it's certainly up to you.  

I usually suggest the phone folks, they have more tools available because they're on the phone with you, they are available Monday through Friday during business hours. The Twitter support folks are available 24/7.

I've tried it on multiple Blu Rays, Netflix, Amazon Prime, Disney+, PS4, all settings changed to Dolby Digital and it still doesn't work. 

Its connected by HDMI ARC.

Its maddening. I think I'll be boxing it all up and returning tomorrow.

The show itself needs to be in Dolby Digital. If you were watching a show that was a news program, or a talk show, the Beam will likely only report stereo. Choose a movie channel, and a movie made in the last 5 years before looking at the settings.

Depending icon the source feeding the TV, and whether it accepts HDMI-CEC info or not, you may need to go into its settings, and turn on Dolby Digital as an output option. 

Of course, you haven’t said how you connected the Beam, my comments above are based on HDMI-ARC, with HDMI-CEC turned on on the TV. If you’ve connected via optical, every device needs to be checked for audio settings. 

Reply