Answered

No Sound from TV with Ray

  • 9 June 2022
  • 8 replies
  • 668 views

Userlevel 5
Badge +14

Have Lg uhf 50 tv. Trying to add Ray. Sound out set as digital sound out auto (tried Pcm also) and simplink off as it’s not hdmi. No sound. Settings on Sonos are just standard. Tried turning on and off and reset to no avail. Does the audio out that comes with Ray different than previous? It fits fine in that but different shape on back of my tv which less than 5 years old. One on the tv doesn’t seem like it’s already in. Don’t want to push too hard as that’s what happened with the arc hdmi, it pushed the jack in so I can’t get at it. Any help appreciated. 

icon

Best answer by GuitarSuperstar 9 June 2022, 22:33

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Just to cover the basics, the Sonos app is set to TV audio for the Ray room?

Userlevel 7

Is the Sound Out setting on the TV set to Optical? The setting could also be called “Audio Out (Optical/HDMI ARC)”. If there is a DTV Audio Setting, set it to AUTO or Dolby Digital.

Have you removed the caps on the ends of the optical cable? Have you performed the TV Setup process under the Ray’s settings in the Sonos app?

Userlevel 5
Badge +14

Just to cover the basics, the Sonos app is set to TV audio for the Ray room?

I don’t know what this means, I never have seen a setting like that on any of my home speakers. 

Userlevel 5
Badge +14

Is the Sound Out setting on the TV set to Optical? The setting could also be called “Audio Out (Optical/HDMI ARC)”. If there is a DTV Audio Setting, set it to AUTO or Dolby Digital.

Have you removed the caps on the ends of the optical cable? Have you performed the TV Setup process under the Ray’s settings in the Sonos app?

Did not realize their were caps. Dumb a$$. Haven’t used optical in a long while. Removed both and still nothing. Yep your other questions are both yes it’s audio out, digital sound out is auto and simplink is off as I believe that’s for arc only hdmi-cec. Using a fire stick. Do I need to do something on that end? Reset things? Other ideas?

Userlevel 7

Is the Sound Out setting on the TV set to Optical? The setting could also be called “Audio Out (Optical/HDMI ARC)”. If there is a DTV Audio Setting, set it to AUTO or Dolby Digital.

Have you removed the caps on the ends of the optical cable? Have you performed the TV Setup process under the Ray’s settings in the Sonos app?

Did not realize their were caps. Dumb a$$. Haven’t used optical in a long while. Removed both and still nothing. Yep your other questions are both yes it’s audio out, digital sound out is auto and simplink is off as I believe that’s for arc only hdmi-cec. Using a fire stick. Do I need to do something on that end? Reset things? Other ideas?

Be sure the optical cable has been fully inserted into the optical ports. You should hear and feel a click.

Are you not getting audio from any source or is it just the Fire TV Stick?

On the Fire TV Stick, go to Audio > Surround Sound and set it to Best Available.

In the Sonos app, be sure TV Autoplay is enabled under the Ray’s settings.

What specific model LG TV do you have? Can you post photos of your TV’s current audio settings?

 

 

Just to cover the basics, the Sonos app is set to TV audio for the Ray room?

I don’t know what this means, I never have seen a setting like that on any of my home speakers. 

 

Select your Ray in the Rooms tab, then go to the browse tab to the left where you would see all your streaming service choices.  Near the bottom, you’ll see TV listed as a source.  

 

I tried to find the support document for this, but couldn’t find it.

 

edit: or setup the room to autoplay TV sources. 

Userlevel 5
Badge +8

Maybe try turning Simplink on? I gave my mum my older 2019 LG to hook up to her Playbase and I think we left that turned on 

Userlevel 5
Badge +14

Is the Sound Out setting on the TV set to Optical? The setting could also be called “Audio Out (Optical/HDMI ARC)”. If there is a DTV Audio Setting, set it to AUTO or Dolby Digital.

Have you removed the caps on the ends of the optical cable? Have you performed the TV Setup process under the Ray’s settings in the Sonos app?

Did not realize their were caps. Dumb a$$. Haven’t used optical in a long while. Removed both and still nothing. Yep your other questions are both yes it’s audio out, digital sound out is auto and simplink is off as I believe that’s for arc only hdmi-cec. Using a fire stick. Do I need to do something on that end? Reset things? Other ideas?

Are you not getting audio from any source or is it just the Fire TV Stick? NOT ANY SOURCE

On the Fire TV Stick, go to Audio > Surround Sound and set it to Best Available. NO SETTING FOR BEST AVAILABLE, JUST DOLBY DIGITAL AND SOME OTHERS BUT USE HDMI

In the Sonos app, be sure TV Autoplay is enabled under the Ray’s settings. IT WAS NOT, THAT WAS WHAT DID IT. SURPRISED IT DIDN’T AUTO SET TO ON BUT MAYBE BECAUSE OF MY NOT REMOVING THE OPTICAL NUBS.

What specific model LG TV do you have? Can you post photos of your TV’s current audio settings? HAD PHOTOS BUT IT’S ALL GOOD NOW.

Thank you, that did it.