Question

No initial sound from Netflix

  • 2 August 2019
  • 2 replies
  • 233 views

When turning on my TV (LG-55B8PLA) watching via an HDMI connection (Digital Decoder), the sound is coming through my Sonos speakers (2xPlay:1, Beam and recently added Sub).

When turning on my TV watching Netflix or Youtube initially, I cannot hear any sound. In need to switch the inputchannel of my TV to HDMI first, the sound starts playing through my Sonos speakers. After that I can switch back to any other input service (Netflix, Youtube, ... ), the sound will keep on playing through my speakers.

Any idea what is going on?
Why do I need to switch to HDMI and I cannot play Netflix directly?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

As a guess, your TV isn't properly initializing the change in audio streams. I suspect that when you change the input channel, it forces a "reboot" of the audio stream, and consequently refreshes the data to the Beam. If this is true, then any HDMI-ARC device would be experiencing the same issue. It really doesn't have anything to do with Sonos, per se.

I'd certainly recommend checking to see if there's a firmware update to your TV, it's possible that it may have been "fixed" by LG in a later version. If not, it might be worth sending a note to LG about the issue, so that they can fix it in a future firmware release.
As a guess, your TV isn't properly initializing the change in audio streams. I suspect that when you change the input channel, it forces a "reboot" of the audio stream, and consequently refreshes the data to the Beam. If this is true, then any HDMI-ARC device would be experiencing the same issue. It really doesn't have anything to do with Sonos, per se.

I'd certainly recommend checking to see if there's a firmware update to your TV, it's possible that it may have been "fixed" by LG in a later version. If not, it might be worth sending a note to LG about the issue, so that they can fix it in a future firmware release.


Thank you I will certainly have a look!