Answered

LG C1 and Beam Gen 2

  • 18 June 2022
  • 3 replies
  • 381 views

Badge

Hi all, looking for help please.

I’ve temporarily connected my Beam Gen 2 tony LG C1 through eArc. All works as it should. The Beam will normally stay in a facility room, but wanted to test the functionality before I dive deeper into Sonos.

Took a while to get it to connect, these is a well-discussed issue with this.

The issue is that I don’t always want the sound to play through the Beam, and want it to stay on the TV speaker for basic day to day viewing. I prefer to use external sound sources for something specific, like watching a movie and I want a bigger experience.

When I select TV speaker in the sound output options on the TV, after 3 or 4 seconds it reactivates the eArc connection and plays audio through the Beam. If I deactivate the CEC link on the LG, it reactivates it. I’ve turned off TV Autoplay in the app.

I have a couple of questions:

 - Is there a way of permanently disabling any automatic reconnection or activation of the sound bar, so it only works on command?

 - Is there a way of turning the sound bar off, not just having it go into standby mode?

I’m thinking of getting a Sonos Amp and feeding that from the TV, and using my existing tower speakers, but don’t want to have the same issue as I wont want TV audio always coming through the owners. This will be a deal breaker.

Any advice appreciated thanks.

 

icon

Best answer by Corry P 24 June 2022, 11:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +18

Hi @Darren.Hastings 

Thanks for your post!

 - Is there a way of permanently disabling any automatic reconnection or activation of the sound bar, so it only works on command?

 

As the TV needs to know to use its internal speakers, this would have to be done by the TV. In general, TVs will automatically select any external audio device over its own speakers because the audio quality is pretty much guaranteed to be so much better, therefore disabling CEC is usually the answer - I recommend you contact LG as to why the TV does not allow you to deactivate the CEC setting.

 - Is there a way of turning the sound bar off, not just having it go into standby mode?

Only by removing power. This way, it can respond to play requests coming from the Sonos app, our partner’s apps, or services like AirPlay. In addition, if it were off, you would have to wait for it to boot before hearing any audio when watching TV.

An Amp would behave the same way. Or rather, the TV will behave in the same way with an Amp connected. I wouldn’t recommend using Line-In for TV audio, if that is what you were thinking - you’d be limited to stereo, likely see lip-sync issues and would need appropriate line-out connections on the TV (which are often missing on newer models).

I hope this helps.

Badge

Thanks Corey. I’m now able to deactivate CEC link to allow audio to only to run through tv speakers. I can push audio through the Beam 2 by selecting that speaker when needed. I can then deactivate CEC link when done and reselect TV speaker.

A bit of a fiddle bet gets the desired outcome.

I’m still thinking of getting an amp to power my 2 bookshelf speakers and 2 One’s for rears.

Userlevel 7
Badge +18

Hi @Darren.Hastings 

I’m still thinking of getting an amp to power my 2 bookshelf speakers and 2 One’s for rears.

If these are going to be independent, that’s fine.

Please note, however, that you can only bond one pair of speakers as surrounds for the Beam - either the Amp or two Ones could do this, but not both. You could group a second room with the Beam, but this is likely to produce sync issues.

If you aim to replace the Beam with the Amp, the Ones will work in concert with either as surrounds.