Answered

Is it possible to listen to music with full surround audio using TV input?

  • 10 July 2020
  • 3 replies
  • 240 views

Userlevel 3
Badge +1

Would love to use the Apple Music app on my Apple TV 4K to view album artwork and live lyrics, but when I do, the music playback is a more ambient surround effect versus listening in full by streaming directly to the speakers.

 

Don’t think this is currently possible, but would love to be corrected or submit a feature request.

icon

Best answer by Airgetlam 10 July 2020, 04:54

Ah. Yes, that’s a good point I forgot. Because you’re using the Apple TV to stream the music, it’s going through the TV (HDMI) input, and the ‘full’ setting is only for streaming, not for the TV input. 

Not sure there is an elegant solution to this, but you could instead try to change the output of the Apple TV from the HDMI stream to an AirPlay 2 stream to the Arc. That would, I think, make the ‘full’ setting work, since you’re no longer using the HDMI input. I’ve never tried this, but in theory it should work. 

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

The Apple Music app, to my knowledge, only outputs a stereo signal, and not a Dolby Digital surround signal. The best you could do is go into the settings for the surround speakers, and set them to ‘full’ rather than ‘ambient’ for music playback.

Userlevel 3
Badge +1

The Apple Music app, to my knowledge, only outputs a stereo signal, and not a Dolby Digital surround signal. The best you could do is go into the settings for the surround speakers, and set them to ‘full’ rather than ‘ambient’ for music playback.


Right, that’s what I’m looking for. But the stereo signal from the Apple TV doesn’t sound the same as the “full” surround setting that is used when streaming music directly from the system. For example, vocals are only coming from the Arc instead of from every speaker.

Ah. Yes, that’s a good point I forgot. Because you’re using the Apple TV to stream the music, it’s going through the TV (HDMI) input, and the ‘full’ setting is only for streaming, not for the TV input. 

Not sure there is an elegant solution to this, but you could instead try to change the output of the Apple TV from the HDMI stream to an AirPlay 2 stream to the Arc. That would, I think, make the ‘full’ setting work, since you’re no longer using the HDMI input. I’ve never tried this, but in theory it should work.