Answered

Harmony Ultimate Remote stopped controlling volume on my soundbar

  • 18 April 2017
  • 39 replies
  • 20722 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

39 replies

same here. suddenly stopped working with my harmony. Any other action still fine incl. mute/unmute. It seems I am not the only one, atm. plz help
I can second this. My Harmony just suddenly stopped controlling the volume on my Sonos play bar today. Mute still worked. After trying a few different things I had to completely delete my Sonos then re-add it and then set up my activities via the computer app not the iPhone app. I also had to adjust the command repeats but I am happy to say it’s working again
Badge
I am having the same issue as you, boryst. The volume worked fine at one time, but it no longer controls my DirecTV sound. Sonos volume control when only playing music works fine.
Two things:
1) After I had success getting it working, it later stopped again. I think it coincided with a software upgrade to Sonos and I fixed it by removing all Sonos and adding them back in. They came into the Harmony software different than before, so something definitely changed. After doing this and recreating my activities, all has worked perfectly.
2) Boryst, your problem may just need recreating (instead of trying to fix) the DirecTV Activity. I have found that starting from scratch on activities is sometimes the only way to make certain changes. Kind of a PITA, but is what it is.
Need to revive this. I have the same problem BUT the following. My TV has a playbar connected via optical audio cable. With my elite when I switch to the Apple TV everything works great. If I switch activities to the DirecTV everything still works EXCEPT the volume control. Mute still mutes and unmutes just fine. I've tried assigning the buttons manually to the TV volume control but that didn't change anything. The original setup that didn't work was through the DirecTV box, reverted back to it, still nothing. Power cycling the playbar doesn't fix the problem, everything stays the same. Lil help?
Just wanted to let others know, I ONLY unplugged the Playbar for about 3-5 minutes and that did the trick. I didn’t remove the device from the remote or anything like that.

Thanks so much to all who posted and shared their fixes!! Really glad it was as simple as unplugging for a bit. 😃
You've just encapsulated my life 🙂
@airgetlam. Yea - don't feel guilty. I'm a tinkerer myself and I feel like it was something I knew, but somehow forgot. Once you get the "smart home" going, you kinda forget about the intricacies of things until you kinda have to remember again.

I think you're right on about the devices losing Wi-Fi. I'm not sure if an update did it, or if something "just broke" as my system is connected using both Wi-Fi and Sonos connect (my Subwoofer is hard wired). I had to do this because devices would sporadically disappear from my clients, but I digress...

When I realized that the device wasn't being detected, it was an Aha! moment and I was hedging my bet that replugging in the wired device first (Subwoofer) and then the Playbar would cause the devices to reconnect to Wi-Fi and Sonos connect. The tl;dr to my Steps to Fix in my previous post could be boiled down to those 2 power down/ups I bet.
Pure speculation here, I'm wondering if the Harmony Remote uses the wifi connection (I have two Harmonys, I should know this but I don't!) to send appropriate signals to the Sonos devices, rather than IR, and possibly one or both of your devices had lost IP addresses? That would explain why rebooting them would bring them back up in the system, and working again.

And I agree, 10 seconds seems not very long. When I'm dealing with an internet connected device, I try to go with it down for a minute, to make sure that all capacitors, designed to stabilize units during minor power surge/interruptions, have the chance to lose all energy. Makes power-cycling a tad tedious, but I feel as though it's worth it.
Ok. I solved my problem. I did a number of things and I'm not sure exactly which step fixed the problem, but it was certainly one of these things that did it.

1) via Harmony Mac Desktop app, I deleted the SONOS Device which automatically removes it from all my Activities
2) I then added the Device going through the basic flow. (i.e. Brand: SONOS Model: Playbar).

At this step, the Harmony App tries to find my SONOS Device via Wi-Fi scan.

Problem: It found no SONOS devices (I have a Playbar and a Subwoofer)

3) Thinking it was maybe my Subwoofer, I unplugged my Subwoofer for 10 seconds and then plugged it back in
4) Went to scan for devices again

The good: It found my Subwoofer
The bad: It didn't recognize my Playbar

5) I went to my Playbar and unplugged it for 10seconds and then plugged it back in
6) Went to scan for devices again

The good: It found it!

7) Hit "Sync" on the Harmony Desktop App (with my remote control plugged into my computer).


**IF YOU RUN INTO A MUTE PROBLEM. CONTINUE TO STEP BELOW. OTHERWISE. I HOPE THE PREVIOUS INSTRUCTIONS WORKED FOR YOU!**

So after it synced, ta da, volume worked! But an issue I had in the past came up. My remote could Mute, but it could not UnMute.

😎 I unplugged my Harmony Hub for 10 seconds, and then plugged it in.
9) Hit Mute and UnMute. WORKED!!!!


WHY 10 SECONDS????

I get it. You're skeptical about 10 seconds. Well I noticed with my Sonos devices (especially the Subwoofer), that unplugging and replugging immediately isn't sufficient. I have a feeling some of these devices hold some energy to account for quick downtime. Internal reserve battery if you will. I don't know if this is necessary with the Harmony Hub, but you never know...
I'm seeing a similar issue and it happened around the same time as folks here. The last few days I've had to use the Sonos app to control volume. My Harmony UR has been the "volume changer" for a year and a half now. Suddenly, it won't work.
Hadnt updated when problem occurred, have now. Still not working. LG tv in case that matches.
Userlevel 5
Badge +3
Sonos did release version 7.2. Did either of you upgrade to that, and if so did the remote issues begin shortly after?

I don't recall offhand any recent updates for Harmony UR.
Same setup here, same issue on the same time scale. Not found a solution. Anyone any ideas?