Question

External speaker warning on Samsung TV when using sound bar


My Samsung TV displays an external speaker warning message when the TV is set to use external speakers. Any clue on how to work around that? I don't want volume from both the TV and the Sonos sound bar, I only want volume from the sound bar.

29 replies

See the following link for instructions on How to Program Common Cable/Satellite Remotes to Bypass On Screen Notifications : https://support.sonos.com/s/article/2072
That'll work! Thanks for that link. This information should be in the install directions as part of setup and should ship with the Playbar.
So i have the same problem, but I don't want to screw up my remote, so could someone point me to the right guide to use. I have a SAMSUNG UE40F7005 LED-TV with the remote that followed.
Can a Sky HD remote be set to only talk to sonos playbar and not the tv for sound? If so how please... the samsung ue55f8000 tv external speaker message is getting really annoying to the point of my partner wanting to take the playbar back!!
Userlevel 1
Badge
So can the supplied Samsung remote be re-programmed this way ? The Sonos customer help link doesn't address that so the original question hasn't been answered. The Samsung on screen notification is really annoying each time you change volume.
Kevin: As I wrote above I had the same problem. I don't think the supplied samsung remote can be re-programmed. I never found a way. What I did was to plug in the IR extender cable (the wire with a little box attached to one end). That way the tv thinks that you have some 3rd party remote or device added and will not show the screen notification when changing the volume.
Userlevel 1
Badge
Dirkzor, thanks so much for the reply, that's a great solution that I hadn't grasped from the previous posts. I've had a play and what I've found is that it's not plugging the IR extender in but just setting up via 'System > Device Manager' the universal remote to make the TV think it has an external AV system. The TV then acts as an IR transcoder and you can then even remove the IR extender. Only had the TV a couple of days so still exploring it's features - this one is actually pretty neat. Thanks again for pointing me in the right direction
Programming R2 and XR2 remotes: http://customer.comcast.com/help-and-support/cable-tv/xr2-xfinity-tv-remote/#Program_XR2_work_w_TV ◦Press and hold the SETUP button for 3 seconds until the ALL POWER button changes from Red to Green ◦Type in 3-1-3-6-0 Re-learn in the new codes into the PLAYBAR and test. To re-learn new codes into the PLAYBAR, go into the PLAYBAR settings and select TV Setup and Control. Once here, select Remote Control Setup. This will walk you through the initial remote control setup process.
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 

i have a samsung 7100
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 
Eric, I have a samsung 8000 series and was having similar issues with the smart remote when trying to use it with the sound bar.  This article fixed it:
http://abhishekdev.wordpress.com/2013/06/10/configure-sonos-playbar-with-samsung-f8500-plasma-tv/
I had to do step two first, then step one, but it worked like a charm.  Hope this helps with your TV/smart remote.
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 
Perfect for the Smart Remote! Thank you for this easy to do solution, my UA55F8000 LED TV all set up with Sonos Playbar! BTW, I typed in the Sonos Brand name when prompted to choose so I'm set up with the right brand too.
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 
Dear all
I have goooood news for you
After month of fight with Samsung development engineers they will finaly correct this insupportable message. Here is what's comming :
- for the new H séries coming on 2014 the message will come only once and there will be an option ''never show again''
- for the 2013 F série there will be an update made in the next months to do as H séries

I hope that H séries in USA will be as ours in France.

Best regards to all
Dear all
I have goooood news for you
After month of fight with Samsung development engineers they will finaly correct this insupportable message. Here is what's comming :
- for the new H séries coming on 2014 the message will come only once and there will be an option ''never show again''
- for the 2013 F série there will be an update made in the next months to do as H séries

I hope that H séries in USA will be as ours in France.

Best regards to all
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 
Try this , cut the 3mm jack plug off a old set of ear plugs then put the plug in the headphone socket on the back of your TV. Then when you turn the volume up or down on your Sonos you will not see the external speaker pop up only the volume number with a small headphone sign. 
Until the update comes through, go to Menu' > System -> Device Manager -> Universal Remote Setup -> Start -> Home Theater System -> Specify Sonos as the brand -> Optical -> run the Function Test:Power -> say Yes -> Finish the setup -> enjoy your volume regulation without messages!

Cheers and good sounds 😃
You Sir are a superstar. Thanks a lot. Works perfectly for the Smart remote too. Sonos I suggest you make this more readily available to people.
Woo hoo, Frederix111. Solved problem. First, installed new updates for my version 7100, which did not. Thanks!
Userlevel 2
Ive set up the IR and also turned off the message - everything works on the remote and is responding but the sonos bar still is not responding 
This works like a charm on my Samsung PS51D6900 🙂
Has this update come through? I can't get rid of the annoying on-screen message and can't find the IR extended that would permit the home theatre step within the above instruction. F series Samsung
Userlevel 3
OMG never knew I could turn the smart remote into a universal remote. Followed the steps and WOW I can now turn the volume up smart remote, didn't wben need the ir blaster.
Thanks, solved the problem!
Hello.  It seems that the latest replies and submitted questions to this topic are 1 year old, so I'm posting to let Sonos (and perhaps indirectly Samsung) know that this issue is still prevalent.  My Playbar is hooked up to my Samsung F5300 60" Plasma TV and works great; however the annoying "Your TV is set to use external speakers.  Adjust the volume on the connected speakers directly" message keeps popping up each time I use the Time Warner DVR remote OR the Samsung remote.  Some posted solutions have been to connect the IR extender (my TV model doesn't have that option) or physically disconnect the internal speakers (too extreme for me).  Sonos: Is there a work around for this yet?  Or is this a Samsung issue and should be posted directly to them?  Thanks!
Hello
The upgrade of the firmware have been done for some models but not all
Take a 3,5 jack plug cut the wires you, only need a 3 jack plug, insert the jack inside the audio out
Use optical for connection to the Playbar and you will have zero message
 
Hello
The upgrade of the firmware have been done for some models but not all
Take a 3,5 jack plug cut the wires you, only need a 3 jack plug, insert the jack inside the audio out
Use optical for connection to the Playbar and you will have zero message
 

Hi Cyrille - thanks for the tip...but just so I am clear...insert a 3.5 jack plug into the Audio Out on the TV, correct?  Sounds like a good plan, but my TV doesnt seem to have an Audio Out option.  See image here: http://www.hdtvsolutions.com/images/articles/Samsung-PN60F5300-Back-Panel-1200.jpg

Unless I misunderstood your solution, it may not work for me.

-Chris
Hello
The upgrade of the firmware have been done for some models but not all
Take a 3,5 jack plug cut the wires you, only need a 3 jack plug, insert the jack inside the audio out
Use optical for connection to the Playbar and you will have zero message
 

On the sides ?
In France every TV have 3,5mm jack output... :-)
Maybe not in USA ... :-(
I'm 100% sure the jack plug solution work

Reply