Earc no sound

  • 24 June 2022
  • 2 replies
  • 40 views

Userlevel 2
Badge +7

Hi all , I'm curious about this , I have my beam 2 and TV connected via arc , been working fine , last night whilst watching TV I turned on in TV settings Earc , carried on being ok but this morning when I turned the TV on there was no sound from the beam , turned off Earc and sound came out of the beam , I only have sky+ hd and I know earc is not needed for mine but just curious as of why it might do that , thanks 


2 replies

Userlevel 2
Badge +7

It’s possible that the ‘controller’ for eARC, I.e. the software in your TV set, failed temporarily. Might be wise to do a couple of things. First, check for software updates for the TV. Second,  force it to reboot/reset by unplugging the TV from power for two minutes, then plug it back in. Just turning off the TV with the remote or power buttons on the set is not sufficient as that just puts the TV in standby, and doesn’t force the reboot. 

Thanks , could it be the fact that I've only got sky + hd ? Just curious as why it did this 

It’s possible that the ‘controller’ for eARC, I.e. the software in your TV set, failed temporarily. Might be wise to do a couple of things. First, check for software updates for the TV. Second,  force it to reboot/reset by unplugging the TV from power for two minutes, then plug it back in. Just turning off the TV with the remote or power buttons on the set is not sufficient as that just puts the TV in standby, and doesn’t force the reboot. 

Reply