Bravia Remote no longer syncs with playbar

  • 13 March 2021
  • 4 replies


I have a Bravia 4K UR2 from 2020 hooked up via optical audio cable to a PlayBar.  For one year, the Playbar has worked fine with the Bravia remote.  However, after the Bravia system update in March 2021, the playbar no longer recognized the remote.  The remote is still IR-enabled (I.e., Bluetooth is off), I replaced the batteries, and I’ve tried to go through the setup-a-new-remote flow on the S2 app a few times.  Any suggestions?


Thank you.


Best answer by BraviaHelp 16 March 2021, 06:42

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +18

Hi @BraviaHelp 

Welcome to the Sonos Community!

What happens when you try to reprogram the remote in the Sonos App? Does it detect any button presses?

Do you have another remote you can try? It doesn’t even need to be a TV remote, though you may need a mute button. If that doesn’t work either, I recommend you get in touch with our technical support team.

If another remote does work, I recommend you get in touch with Sony support. I have a Bluetooth remote for my nVidia Shield and noticed that it updated the firmware in the remote itself once, so this may have happened to your remote and something has been changed, or it needs reset.

Of course, someone else in the Sonos Community may have also had this problem after the Bravia update, which would indicate something in the update caused it (though it’s already pretty suspicious that this happened after it).

Thanks very much, Corry.  During the remote Programming flow on the Sonos app, the app didn’t recognize any button pushes.  I’ll see if there’s another remote around. Thanks for the tip. It would be disappointing to have to add another remote to the mix, though, especially since the PlayBar is supposed to integrate so well (and did for so long!).

Quick update: I seem to have resolved this issue by doing the remote setup flow on the app with the original Bravia remote, but with the TV off.  Not sure why that would be, but so far things seem to be working again.


Thanks again, Corry. 

Userlevel 7
Badge +18

You’re very welcome - I’m glad you found a solution! Thanks for updating us here too!