Answered

Beam Not Controlling Grouped Speakers

  • 27 November 2021
  • 10 replies
  • 173 views

I have my Beam Gen 2 connected via ARC HDMI.  The TV remote is set up and controls the Beam but it does not control the other 3 speakers that are in the group. Is there a fix for this?

 

icon

Best answer by Airgetlam 27 November 2021, 17:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

I don’t see that as logical at all. If it is grouped together, it should work together. Why would I mute the soundbar but want to other 3 speakers to keep playing?

If I group Sonos rooms it’s rare that the speakers are in the same physical room, as an example I might choose to group ‘Office’, ‘Bedroom’ and ‘Shower Room’.

The Bedroom is a Sonos Beam & Surrounds and I would not want its remote adjusting the volume in the Shower Room whilst I’m in the shower and the Wife is in the bedroom. 

Similarly if I take a phone call in the Office and reduce the ‘Office’ volume, or mute that room, I don’t want it to mute the Bedroom or Shower Rooms, where the Wife might be getting ready… so in my case, it’s logical for the hardware to just control its own room. I can always use the Sonos App, or Alexa enabled groups, or third party Apps, like Soro, or a Logitech remote / Harmony hub, if I ever need to change ‘group volume’… which is rare, compared to individual room volume.

wow, that makes no sense. so when I mute beam using the TV remote, the other keep playing the sound.  Well, I will be returning mine.  . 

What, along with the Ikea Symfonisk(s), Sonos Roam(s), and Sonos One SL(s) listed on your profile? Talk about throwing the baby out with the bathwater, over such a minor issue. I advise you to stop and think again

The TV remote controls just the local soundbar (and bonded surrounds/Sub) -- which is entirely logical -- but if you really want to mute an entire group there are other ways to do this.

For example install Alexa on the Beam and create an Alexa group. “Alexa, mute” may then do the trick. 

You already have Ikea Symfonisk. Have you explored the cheap Symfonisk audio remote? That acts on the entire group too.

Why would you have 3 other speakers grouped with the Beam for TV?  Are they all in the same room?  If so, besides the fact the grouped speakers will be delayed behind the Beam for TV, it will still sound awful.  There's a reason why surround sound systems have speakers playing separate channels to specific parts of the soundstage.  Grouping speakers ruins that soundstage.

More speakers are not always better sound, and they mean far worse sound if not placed correctly and playing the right signal.

Badge

Responses seem to have some debate on clarity of your issue. Is this a surround sound issue in one room, or speakers in another room issue? My response was based on one room, surround sound. Sorry my solution didn’t work for you.

My next suggestion would be to try Sonos support by either online chat or phone. I had an issue that they resolved in a way I didn’t even think was a problem.  They were very helpful.

If they fix your issue, done. Post the solution here.

wow, that makes no sense. so when I mute beam using the TV remote, the other keep playing the sound.  Well, I will be returning mine.  . 

 

The TV remote controls just the local soundbar (and bonded surrounds/Sub) -- which is entirely logical -- but if you really want to mute an entire group there are other ways to do this.

 

I don’t see that as logical at all. If it is grouped together, it should work together. Why would I mute the soundbar but want to other 3 speakers to keep playing?

Badge

I had the same problem, and I fixed it like this; I had to go to TV setup. My TV was set for stereo, which means surround sound did not happen, but the sound bar and 2x One SL were a “group” but not surround sound. I changed settings on TV to surround sound. Then the Sonos group could become surround sound. When TV set to stereo, then setting up surround failed in Sonos app. When TV set to surround, then group can be set as surround sound in Sonos app.Then volume control for TV worked for entire surround sound, all speakers.

Since my sound bar beam was connected to TV via HDMI, it gets the sound signal from the TV. If TV is not set to surround, then Sonos is not surround.

Also, I did an update to TV software via internet.

It worked for me, your TV may be different.

I had the same problem, and I fixed it like this; I had to go to TV setup. My TV was set for stereo, which means surround sound did not happen, but the sound bar and 2x One SL were a “group” but not surround sound. I changed settings on TV to surround sound. Then the Sonos group could become surround sound. When TV set to stereo, then setting up surround failed in Sonos app. When TV set to surround, then group can be set as surround sound in Sonos app.Then volume control for TV worked for entire surround sound, all speakers.

Since my sound bar beam was connected to TV via HDMI, it gets the sound signal from the TV. If TV is not set to surround, then Sonos is not surround.

Also, I did an update to TV software via internet.

It worked for me, your TV may be different.

didn’t work but thanks for the solution, glad it worked for you. 

No, unfortunately not. The remote control for the TV will only control the speakers in the ‘home theater room’ and not any grouped speakers. 

wow, that makes no sense. so when I mute beam using the TV remote, the other keep playing the sound.  Well, I will be returning mine.  Thanks. 

Odd. It makes some sort sense to the thousands or millions of other Sonos users who have a sound bar from Sonos, or they’re willing to put up with it to get the sound quality that Sonos brings. But it has been a request for a long time, so who knows.