Beam (Gen 2) disorted / metallic sound w/ TV (eARC) and Night Sound Mode


Userlevel 1
Badge +1
  • Trending Lyricist I
  • 29 replies

Similar to what is outlined here:

 

I experience in some cases a metallic / distorted / chirping sound on my Beam2. Happens with Panasonic and LG TV, so it’s not a TV issue.

The metallic sound is somewhat in the background, but clearly noticeable. It is also somewhat correlated to the original sound, seems to be directly „derived“ from it, like a distorted low volume copy.

For me only happens in night sound mode.

When i disable night sound, the issue disappears my.

Seem to happen more often on TV channels with PCM stereo. But I have not been able to relay reliably reproduce it. It happens quite often though.

Switching the channel can make the error appear or go away.

Wild engineering guess is some sort of Bitstream MSB/LSB alignment error. Re-init also means re-align and this can fix it. Possibly hardware not SW?

Anyone else experiencing this?

 

 


63 replies

Userlevel 1
Badge +1

I spent an hour or so on youtube and netflix to find some material that is longer then a few seconds clearly reproducing the issue… its more diffcult than I thought.

 

So for now, I have been falling back to testing with our superman video.

 

One thing to add, I disabled eARC on the LG TV, which leads to the audio channel falling back to “Dolby Digital Plus 2.0”.

I think I can say that the phenomenon is also clearly audible in this mode. So its not only „Dolby Multichannel PCM 2.0“.

Ken, I think this is the mode you also had, but an additional Feintech in the middle. So it would be really interesting to hear what taking the Feintech out of the loop would bring.

 

On the other hand, I played various 5.1 and Athmos tracks and in none of them heard anything like the distortion I have in 2-channel audio.

Call me old fashioned, but its kind of irritating anyway how many variants of “stereo” there are these days.

Anyway. In “Dolby Digital Plus 2.0”, with eARC disabled, also the sidewards pointing speakers are emitting audio also. So its pretty clear the Beam is doing some upmixing magic even on two-channel audio.

 

Userlevel 2
Badge +1

@Shnakey

 

Can you help us out here:

  1. does the error on your end sounds similar to what I recorded (see above)?
  2. what is your TV model?
  3. What is the Sonos App showing as the audio format, at the time you reproduce the error?
  4. if you had an LG tv, is the error also going away if you disable pass-through and switch to PCM?

 

Cheers!

1. Yes sounds similar.

2. Sony x950h

3. Depends on what's playing. I've heard the sound in 2.0, 5.1 and Atmos. The app reports the correct format in each case. 

4. The problem doesn't change based on passthrough but I can't hear it when switched to PCM. 

I spent an hour or so on youtube and netflix to find some material that is longer then a few seconds clearly reproducing the issue… its more diffcult than I thought.

 

So for now, I have been falling back to testing with our superman video.

 

One thing to add, I disabled eARC on the LG TV, which leads to the audio channel falling back to “Dolby Digital Plus 2.0”.

I think I can say that the phenomenon is also clearly audible in this mode. So its not only „Dolby Multichannel PCM 2.0“.

Ken, I think this is the mode you also had, but an additional Feintech in the middle. So it would be really interesting to hear what taking the Feintech out of the loop would bring.

 

On the other hand, I played various 5.1 and Athmos tracks and in none of them heard anything like the distortion I have in 2-channel audio.

Call me old fashioned, but its kind of irritating anyway how many variants of “stereo” there are these days.

Anyway. In “Dolby Digital Plus 2.0”, with eARC disabled, also the sidewards pointing speakers are emitting audio also. So its pretty clear the Beam is doing some upmixing magic even on two-channel audio.

Ok, I will try the things mentioned and will let you know if I am ever able to reproduce the issue here.

By the way you mentioned earlier about the Surrounds/Sub being disconnected, which I’ve been doing, but do you not notice it when you have your surrounds and/or sub enabled, even with that Superman video?

1. Yes sounds similar.

2. Sony x950h

3. Depends on what's playing. I've heard the sound in 2.0, 5.1 and Atmos. The app reports the correct format in each case. 

4. The problem doesn't change based on passthrough but I can't hear it when switched to PCM. 

Are you able to provide some examples @Shnakey that you use to reproduce the issue - it would be helpful if there was more than the YT Superman video, even better if the samples are perhaps available on the streaming platforms, like Amazon, or Netflix, Movies/Shows etc. 

Thanks 🙏 

Userlevel 1
Badge +1

1. Yes sounds similar.

2. Sony x950h

3. Depends on what's playing. I've heard the sound in 2.0, 5.1 and Atmos. The app reports the correct format in each case. 

4. The problem doesn't change based on passthrough but I can't hear it when switched to PCM. 

Are you able to provide some examples @Shnakey that you use to reproduce the issue - it would be helpful if there was more than the YT Superman video, even better if the samples are perhaps available on the streaming platforms, like Amazon, or Netflix, Movies/Shows etc. 

Thanks 🙏 

I would be particularly interested in something that is multi-channel, e.g. 5.1. Which I have not found in my setup.

Userlevel 1
Badge +1

I spent an hour or so on youtube and netflix to find some material that is longer then a few seconds clearly reproducing the issue… its more diffcult than I thought.

 

So for now, I have been falling back to testing with our superman video.

 

One thing to add, I disabled eARC on the LG TV, which leads to the audio channel falling back to “Dolby Digital Plus 2.0”.

I think I can say that the phenomenon is also clearly audible in this mode. So its not only „Dolby Multichannel PCM 2.0“.

Ken, I think this is the mode you also had, but an additional Feintech in the middle. So it would be really interesting to hear what taking the Feintech out of the loop would bring.

 

On the other hand, I played various 5.1 and Athmos tracks and in none of them heard anything like the distortion I have in 2-channel audio.

Call me old fashioned, but its kind of irritating anyway how many variants of “stereo” there are these days.

Anyway. In “Dolby Digital Plus 2.0”, with eARC disabled, also the sidewards pointing speakers are emitting audio also. So its pretty clear the Beam is doing some upmixing magic even on two-channel audio.

Ok, I will try the things mentioned and will let you know if I am ever able to reproduce the issue here.

By the way you mentioned earlier about the Surrounds/Sub being disconnected, which I’ve been doing, but do you not notice it when you have your surrounds and/or sub enabled, even with that Superman video?

I think it is a difference in our setups.

i have no sub and no surrounds. Not even configured nor set up, so I don’t need to disable them either. Could it be this changes upsampling behavior?

I think it is a difference in our setups.

i have no sub and no surrounds. Not even configured nor set up, so I don’t need to disable them either. Could it be this changes upsampling behavior?

Yes possibly... maybe some others here with standalone Beams will chime in. I will test that too, when I have the chance. 

It can just be a bit of a nuisance bonding/unbonding surrounds & sub and having to re-truplay the room, so I’ll hang on and do that later perhaps, maybe after @Shnakey, or others here, post some further audio examples to perhaps test too.👍

Userlevel 2
Badge +1

I'll try and record some samples over the weekend and report back. 

I'll try and record some samples over the weekend and report back. 

Just perhaps point to some samples on Prime Movies, Netflix etc (with approx. times) as I’m still struggling to reproduce the issue here.

I am experiencing the same issue with appleTV 4K, Beam Gen 2 and Sub mini. First I thought it’s because of my Samsung TV only being capable of arc instead of eARC but I also notice it via the vax0101A. I feel like it happens less when running Atmos, but it constantly happens when playing PCM 5.1 multi channel. Currently forcing 2.0 via the vax to prevent it from happening. I think it’s less prominent for me with stereo.


I recently noticed the phasing behaviour in the movie „Barbarian“ (tw: crazy horror movie) on Disneyplus with English audio. I slightly noticed it during the movie in some scenes with rain in the background but it really stood out when the credits started and music kicked in at the end.

 

Userlevel 1
Badge

Same problem here.

standalone beam gen 2, Apple TV connected via the feintech. So we can rule out the tv.

A good example is Slow Horses on Apple TV+ (Atmos audio). Listen to the opening theme, that usually starts some minutes later. It’s a Rolling Stones track. Listen that on headphone on stereo and it sounds really different.

Technically you can describe it as a phasing issue, it’s like a very short delay that sums up to the original audio and cause cancellation in some frequencies, giving that “metallic sound”. It’s probably due to decoding issues BUT phasing can also be purposely used to create psychoacoustic effects to recreate space, so I’m not sure it is a problem or a features : ) maybe some people are more sensitive then others and are not tricked into believing that fake “space” but just ear phasing. I’m into this category.

I don’t have rears but my believe is that with rears you don’t have this problem, because you have real speakers to create space and you don’t need this kind of audio treatment. Probably it happens only with sounds that should came from the rears, but having no rears the beam decode them in this (not very pleasing) way. But I don’t have rears to test it so I cannot confirm it.

you can definitely making it less apparent setting height to 0. I set mine to 8 some time ago and from that moment I’ve started noticing the problem. 

it’s audio processing not well tuned. I really hope Sonos will refine it in the future, but I’m the only in the family that has noticed it, so probably is not an issue for many.

@Eriksatie haved you tried setting the height to -10? Does it sound worse than 0?

Userlevel 1
Badge

@Eriksatie haved you tried setting the height to -10? Does it sound worse than 0?

Yes I’ve tried, there’s little difference to 0 but probably can be different if you test another movie (or maybe another room?). Also don’t wanna lose all the verticality (the effect is so small even at +8). I think that everyone should find his sweet spot. Zero seems to be a nice start point and definitely sounds better then +8, at least to my ears

Reply