Question

Arc won't switch on TV - but yes it does!!! Insights needed.

  • 12 September 2020
  • 2 replies
  • 74 views

I, like others am experiencing difficulty persuading the arc to switch the tv on, using google assistant on the arc via HDMI/CEC. No problems switching off. Just not on. 

Read forums, tried loads of tweaks on sonos app and google home app.

The TV is called TV in google app and sits in a room “Family Room” along with the Arc and a host of other gadgets. 

On the Sonos App the Arc sits in the family room and is paired with two Ones and the Sonos App describes this also as “TV” - which i do not think I named.

I have an LG TV - 2018-19. with Arc/HDMI 2.0 and I get dolby atmos (i assume the compressed variant).

Read some tweaks on forums. eg. toggle “quick start option” a few times …. in fact I thought it worked…. but it did not last and i wonder now if i imagined that it did.

Anyway I can switch the TV on via the Arc with a voice command --- but i am hoping someone can see WHY? this is working - and with it a way to possibly see a more elegant solution.

While playing with trying to get it work - I asked “okay google Family room on”…. this switched 15 devices on -- which was interesting as there are 14 lights in the family room…. so what was 15 …. lo and behold the TV switches on.

One immediate solution was to put the arc and One’s into their own room - called it just “TV Room” … and then asked google “okay google TV Room on...” (see how clever that could have been!). That did not work.

I then realised that maybe the arc and the tv have to be located in the “TV Room” on the Google Home App also … for consistency.  I did that and it still does not work.

 

So currently (reverting back to the original settings) . I can switch on the TV with voice by asking google to “Family room on” and then simply ask it to switch off the lights.??? Note i can switch it off, by the usual “ok google TV off”.

If anyone can see what I am missing (may have wrong) … to allow a simple (as expected) command to switch TV on - please let me know. 

Thanks

David


2 replies

Userlevel 4
Badge +12

Hi @David Reynolds, sorry for the late response.

I would like to know if you have other Google Assistant-enabled device than our Sonos Arc.

If you do, try removing Google Assistant in the Sonos App then try to command Google Assistant.

If the same behavior occurred, the issue is with Google Assistant. 

I would recommend calling Google for assistance to configure Google Assistant to turn your TV on.   

Userlevel 7
Badge +21

It might just not work. My LG can use CEC to turn on, but cannot use it to work off on a particular device. After parsing the CEC logs this was because the TV simply cancels the Off command. My LG is older than yours, so there is zero chance of a firmware fix, but there’s nothing I can do about it. Except buy a new TV with a better implementation of CEC.

Reply