Another 5.1 solution needed :(

  • 23 July 2017
  • 5 replies
  • 548 views

Badge
Hi everyone. Sorry for yet another 5.1 question. I've tried searching and couldn't find anything applicable to my setup. We just bought a Playbar and Sub.

We don't have cable/Direct TV.
Samsung UN55MU9000 with their unusual "One Connect" box. It's a special cable from the TV to best I can describe, a hub. HDMI, Optical, USB.
Apple TV - HDMI to this hub
Xbox One S - HDMI to hub
Optical from Sonos Playbar to hub. TV Set to optical

All we get is Stereo from any movies played from ATV. Same with playing any games via XBox.

Any guidance on solutions would be greatly appreciated. I'm sure if we can get 5.1 going, movies will be even more amazing (hopefully).

Thanks,

William

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Badge
Ok. So I think I may have solved it. I moved the ATV HDMI to the HDMI ARC slot on the Connect One Box. Samsung TV Expert settings both set to PCM. ATV setting moved from Best Available to 5.1. To be honest, I threw darts with a blindfold to see what stuck. Whether all or one of these changes did the trick, don't know. Almost anything within ATV I can now get 5.1. Whether iTunes or Netflix.

Last pony up is the XBox One S. It doesn't want to go there yet. It's HDMI is plugged into to HDMI 1 on the Connect One. I tried playing around within the settings but did not find a combo that worked. It keeps defaulting to Stereo.

William
Badge
You probably need to go into the audio settings for each device, as well as the TV, and make sure that they're all set to Dolby Digital. Each device will have it's own area for that.

Hi Bruce,

ATV is set to Best Quality Available. TV, as mentioned above, still working on it. I believe the Xbox will fall into place once this is figured out.

Thanks!

William
Badge
Have you tried looking at the "expert settings" ? :)

Hi there! I did look there. The HDMI Input Audio Format is set to PCM and Digital Output Format is also set to PCM. Dolby Digital is greyed out along with DTS and DD+. Only other highlighted option is DTS 2:5.

Is there a trigger to have DD highlighted to select it?

Thanks!

William
You probably need to go into the audio settings for each device, as well as the TV, and make sure that they're all set to Dolby Digital. Each device will have it's own area for that.
Have you tried looking at the "expert settings" ? 🙂