Amp, Apple TV and LGCX HDMI-CEC issues

  • 13 March 2021
  • 1 reply
  • 141 views

So I have a Sonos Amp plugged into my LG CX and whenever I wake the system up with my Apple TV 4K i notice that the volume buttons on my ATV4K remote don’t change the volume on my Amp. If I go to the settings on my ATV4K and change them from IR back to HDMI control the Amp will light up green and recognize it. 

I have TV auto play set to on. 

Anyone know why the Amp would have trouble? It worked fine with my Beam every time.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Water Monster 

Welcome to the Sonos Community!

I don’t know why your Apple remote would keep defaulting to IR mode - with HDMI, your Amp is getting the instruction to change volume from the AppleTV itself via CEC on the HDMI link. A better place to get help for why this is happening would be Apple technical support. Maybe a reboot of the Apple TV does this, though I don’t see why it wouldn’t save the setting - have you tried not turning it off (if you even do, that is).

I was going to suggest we program the Amp to accept the IR commands, but our Use an Apple TV remote with Sonos home theater products page indicates that the lack of a mute button may cause problems with this procedure.

Therefore, please unplug your TV, Sonos Amp and Apple TV from power for a minute or so. Turn them all back on and test. If the problem remains, I suggest Apple are the people to talk to.

There may some people here in the Sonos Community who have experienced this, however, and can tell you what to do about it.