Answered

Why Sonos One keeps casting to play music on my other Google device when I ask to play music?

  • 5 December 2019
  • 1 reply
  • 68 views

I got a pair Sonos One to listen to music in my bedroom. I use Google assistant as the voice control. Every time I ask to play music, the Sonos One play music on my living room Google Nest Hub. Even I tell it play on the bedroom speakers, it feedback that it does understand me or  some thing funny, just refuse to play music on itself. Since like this, why I buy this two speakers? I have been trying to figure out why, but by now, I didn’t get the why.

 

Another thing, when I tell it to play the news, only one of the speaker work, even though I have paired them as stereo speakers.

 

One more thing, I use MacBook Pro to cast to the pair, but the sound just keep cutting off and on. Can’t figure out why and what to do.

 

It’s quite weird and frustrating.

 

Please Help!!

 

 

 

 

icon

Best answer by Ryan S 12 December 2019, 20:52

Can you go into the Sonos app and under Settings > Services > Voice Control make sure that you’ve got Google Assistant enabled for your Sonos speakers? That might cause the issue you’re describing on that first step.

Playing the news is expected to come only from the side that has the microphone enabled as it’s considered part of Google Assistant’s response. I’ll let the team know you were looking for it to play from both sides, but I believe it’s currently the expected performance.

The MacBook trouble could be caused by some network communication issues. If it was AirPlay giving you trouble, there’s a new update from yesterday that might improve things, but if you’ve updated and are still having trouble, I’d start with the steps here to reduce wireless interference.

View original

1 reply

Userlevel 7
Badge +26

Can you go into the Sonos app and under Settings > Services > Voice Control make sure that you’ve got Google Assistant enabled for your Sonos speakers? That might cause the issue you’re describing on that first step.

Playing the news is expected to come only from the side that has the microphone enabled as it’s considered part of Google Assistant’s response. I’ll let the team know you were looking for it to play from both sides, but I believe it’s currently the expected performance.

The MacBook trouble could be caused by some network communication issues. If it was AirPlay giving you trouble, there’s a new update from yesterday that might improve things, but if you’ve updated and are still having trouble, I’d start with the steps here to reduce wireless interference.

Reply