Question

Sonos cant connect to google assistant

  • 14 May 2020
  • 1 reply
  • 62 views

Sonos displays that no voice service is connected but when i enter to setupa voice service, it displays that a voice service has already been set up.

 

 


1 reply

Userlevel 3
Badge +11

Greetings,

 

I am sorry for the late response. We want to make sure that you are only using one Google account with your assistants per household. While we understand you've already tried some of what follows, at this point we’d like you to perform the following troubleshooting steps in order. If you're unable to complete any step, simply move on through the list.

 

1) In the Sonos app, go to Settings > System. Select Sun Room, then select Google Assistant > Remove Google Assistant.

 

2) In the Google Assistant app, tap the account icon in the top right. Tap “Settings”, then the ‘Assistant’ tab, and choose ‘Home control’. Tap the 3 dots in the top right and choose ‘Manage accounts’. Tap Sonos and select ‘Unlink Account.’

 

3) Sign out of your account in the Google Assistant app.

 

4) Disconnect power from the Sonos One/ Beam and your primary Wi-Fi router for 30 seconds. It will take a few minutes for the speaker and network to reboot and reconnect.

 

5) After you reconnect power to the router and Sonos One, restart the Android device you run the Sonos and Google Assistant apps on.

 

6) Once the phone's back on and connected to your network, open the Sonos app again. Go to Settings > Services > Voice > Add a Service. Select Google Assistant and follow the prompts.

 

Let me know how it all goes regardless of the outcome.

Reply