Answered

Sonos Beam - Google Assistsnt doesn't work when watching TV

  • 17 April 2020
  • 2 replies
  • 62 views

Just installed my Beam. Connected via ARC to my Bravia. All good. Sounds great. Set up Google Assistant. All good. 

But..... When watching TV with audio coming from Beam it no longer responds to any voice commands. Like it's not listening at all. 

Plus after I've switched the TV off it won't respond to Google until I've started some music via the Sonos app. 

Any ideas?

 

 

icon

Best answer by Darren Waters 26 April 2020, 18:00

For anyone who has the same problem. I solved it by removing Sonos from my Google Assistant account completely and then reconnecting my Sonos account. At that point the Google Home app searched and found my devices. It picked up the names I had for them and so I didn't need to many any further changes to names or rooms. And voilà, it worked. 

View original

2 replies

Hi Darren, Thank you for bringing your question to us here and welcome to the Sonos Community. I can see that you have a case working with our agents. They will assist you from here, but feel free to let us know here how things are resolved for you. 

For anyone who has the same problem. I solved it by removing Sonos from my Google Assistant account completely and then reconnecting my Sonos account. At that point the Google Home app searched and found my devices. It picked up the names I had for them and so I didn't need to many any further changes to names or rooms. And voilà, it worked. 

Reply