Answered

Sonos and Google Assistant not connecting


Userlevel 1
Badge
Please help. I've been waiting for this, and now when Sonos controller tries to connect to Google Assistant, no devices are found. I have unplugged everything, restarted phone, tried several things and still not connecting to Google Assistant on my 2 Sonos Ones. What do I do? I have lost an hour and a half of my life on this!

Ok and now I must have clicked some answered thing on this forum. This is not answered!! Fix this issue ASAP what a waste of time, Sonos!
icon

Best answer by Airgetlam 23 May 2019, 04:36

You may want to contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

The community forum moderators tend to be online during work hours only, like the phone folks.

Moderator note: Some users have been able to resolve this via the workaround of temporarily removing their music services from their respective Sonos systems. In addition, we also have an article containing steps to start with here before contacting our support agents.
View original

52 replies

Same issue,
"No Devices found:
Make sure your Wi-Fi is on and that your phone and Assistant devices are on the same network and try again"

Both on Android and iOS. Everything is on the same network. Seems integration is half baked

Steve
Same. I can get Google Assistant to recognize my One in the bedroom, but not my Beam in the living room. Any tips?
Userlevel 1
Badge
This is not answered, Sonos please fix this

Had this same problem w/ my Sonos Play1s. Here’s how I got it to work. Note this only applies to iOS devices.

  1. Delete Google Assistant app from phone (this was KEY to making this work for me)
  2. Google Home app: unlink Sonos
  3. Google Home app: re-add Sonos and re-authorize
  4. Sonos App: Settings - Services - Voice - Add a Service - Google Assistant
    1. This will ultimately prompt you to download Google Assistant app
    2. Download Google Assitant App, it’ll scan for devices - only select 1 device to set up (ex if you have two Play 1 devices, only pick one of them
  5. Should be good to go -- if you need to set up another device start over at step 1 above but skip steps 2 and 3
Ok - this thread is definitely *not* answered.

"Some users have found" is not a solution.
Trying it 4 or 5 times is not a solution.

Here's a solution: follow steps 1-x and it works 100% of the time.

Anything else is "we don't really know what's going on."

I have numerous Sonos & Google devices. A combination of these in 1 location w/a Sonos network, fully integrated with the Assistant. In the other location, I'm trying to add my first Sonos device - a Sonos One. We also have Android phones.

I've tried all of the following approaches, with no luck:
a) Using the UI - Sonos App + Google Assistant
b) Removing all music services & repeating (a)
c) Using the Google Home app to add a new device
d) Hard reset, then (a) and (c)

Each step has been tried multiple times.

It would be great to hear from Sonos that:
a) this is a recognized and reproducible problem (or not)
b) a software fix is in the works

or

c) We really don't have integration with Google Assistant on Sonos One.

I'd say that maybe responsibility lies somewhat with Google, but they aren't putting the Assistant label on the marketing, Sonos is.
Badge

Doesn't seem right to call this thread answered when the answer was to contact support, especially since support specifically asked for diagnostics from those of us who tried all the steps posted and still failed. Many of us have posted diagnostics, but I do not see a single reply to these. Huge Fail from Sonos on this crap implementation.How often did you try to connect GA to Sonos - once, twice? It may work at third or fourth attempt.


More times than I can recall, at least 10 times. A few of those times I even removed Sonos from GA to start fresh, I have rebooted all speakers, my router/modem a few of those times as well.

I suspect the folks with issues are iOS users, I don't own any GA devices, no android. So I am starting fresh with GA. It does NOT work.
Badge
So frustrating, this roll out was not ready, this does NOT work.

Like many others I get no devices found.
Your confirmation number is: 734399290

I unlinked sonos from google Assistant and tried again, it asks for sonos login, then tried searching for devices and finds nothing. Yet in google Assistant I see both sonos one speakers and the beam and I can even turn the tv off (connected to beam) and on via google Assistant.

i am on same WiFi and have google Assistant running on iOS. Both google Assistant and sonos are using same email address.

how do I get this thing to work? I can add Alexa in like 5 seconds but this GA is garbage implemented.
Userlevel 1
Badge
Yeah something isn't right. Alexa has worked for a year on my speakers. Hopefully they get this right. You would think after two years waiting on this release there would be no hitch, but nope, doesn't work.
Userlevel 1
Badge
And I don't know what I hit on this godforsaken forum but this is not answered. Let's go Sonos I'm in to you like 2.5 grand so let's get a solution for this.
Userlevel 1
Badge
I hate this site for real.
I have been having trouble for days. I initially had it working on a single Play One. Feeling encouraged I dug out a Google mini I had tucked away and decided to change my Beam as well. Wouldn't find it at all. Finally did when directly connected. I then unplugged the Ethernet cable and waited a few minutes. Everything was good. I unplugged and moved it back only to be greeted by silence and then,"something went wrong. Try again in a few seconds." Now I have Alexa back on the Beam and the Play One has the GA with the hiccup. It will play music after a delay but won't answer questions. I've had contact with Sonos and have monitored the forums. I can't seem to find a solution.
Userlevel 3
Badge +1
Same issue here, will not connect to my 2nd surround sound system. The first surround system provisioned just fine.
@Jp2378, don't worry about the 'best answer' being selected. It doesn't mean Sonos staff or others won't look at this issue. It just helps others looking for answers to possibly see an answer without having to scroll through the entire thread..if possible.

Regarding the issue, because this is a brand new configuration, most of the regulars around here are not yet familiar with the potential issues with setup just yet. Sonos staff may also be seeing some issues that did not pop up during beta testing. I'd recommend checking back on this thread a little bit later to see if a solution or trouble shooting steps have been established.

Not trying to say your frustration isn't valid...
I think I might have found the solution, unlink all music services from your Sonos device. This worked for me and immediately after I was able to set all my sonos speakers to google assistant and discovery went fine.

Before I also had the problem with it not finding the speakers.
I did get mine going last night. I rebooted my Sonos 1 and the bridge. It came right up. Don't know which one was the issue, but it works.

Steve
I just bought a beam for my new TV a week ago. I would not have purchased a sonos if it wasn't going to work with voice command. I am looking to expand the system to the kitchen and bedrooms but will now wait. An open box return is looking likely if they don't figure this out.

When Google Assistant prompts me to sign in to my sonos account, it doesn't recognize or connect after signing in.

SONOS Representative please respond to this thread. Your Google Assistant rollout does not work!

This worked for me!!
1. Download Google Home app. Go to ‘Home’  and find your device. Click onto device and the ‘unlink Sonos’ for each device you have. 
2. Go back into your Sonos app and set up your devices all over again. 
Google assistant will also be part of the set up and Voila. 

Just had this problem.

 

In my case, I had reset my sonos controller on my android device plus I had separated a pair with google assistant already set up. If you have used a pair you might have noticed one is a master and other a slave with the master only responding to google assistant. The one I am setting up was the slave.

 

To fix it 

I still had my sonos "skill" whatever it's called in my google home app so after going through the sonos setup I unlinked the sonos skill from google home, and added the speaker to a home and room, tried to setup google home in sonos and it worked.

 

I think because I no longer use the master but had reset sonos, Google home still had a memory of the master? And because only one works with assistant out of a pair it would not let me add another until I cleared it by relinking my sonos account to home again.

 

 

Hope that helps 

Userlevel 1
Badge
You may want to contact Sonos Support to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

The community forum moderators tend to be online during work hours only, like the phone folks.


I don't use social media so I am going to follow instructions that Jeff from Sonos gave us to follow right here in this thread, posting diagnostic confirmation. I'll try to call when I'm not working.
Userlevel 3
Badge +3
If you have any google devices, you can get things working through google home app as well. Worked for me.
Multiple attempts from me fail as well.

Network setup:
  • Fritz Box 5490 router w/ 1750 mesh repeater connected over ethernet
  • SonosNet used for Sonos system with ZP as the "hub" connected over ethernet to the router
  • Google Home Hub also in use and already connected to Sonos and Spotify accounts
I keep trying to add the GA capability to my Sonos One. I have gotten to various stages of progress but never 100% successful. The furthest I got was when I was able to get GA enabled but then the Sonos One would never be able to do anything after the "hey google" command.

Occasionally it will discover the Sonos One but then when I give permissions I get a "there may be a problem" screen and we are back to the looking for devices screen which fails with "no devices found" 95% of the time.

I am guessing that the issue here is a non-vanilla home network setup and/or the coexistence with a Google Home Hub / Google Home app.

Diagnostic: 1489249209

Alexa just works...
Userlevel 1
Badge
Hi folks,

The outage should now be resolved. If you're still having some troubles with Google Assistant, please try the steps in this thread to get it working. If that doesn't help, send in a diagnostic report and reply here with the confirmation number.


Confirmation number: 300995857

Although my issue differs a bit with anything else I've come across on the forums in the past few months, I thought I'd add my experiences in case this helps some other poor soul with tech-support baggage nearing the give-up point on Sonos.

 

Background:

I purchased a Sonos Playbar and Sonos One pair to use as a home theatre system for my TV. Setup went relatively smoothly as I expected for the premium that I had paid (albeit temporary physical ethernet connections were needed for all speakers before switching to wifi), and I was able to use the various integrations including Google assistant without issue. I hummed and hawed about the Playbar soundstage width for a couple of weeks but eventually decided that the compromises made for the compactness of the setup were not worth it and replaced it with the new Amp and a set of Klipsch bookshelf speakers (much to my satisfaction on the home theatre experience end).

This is where my problems began. Setup of the system itself was about the same as before, but I had no end of problems getting Google Assistant working without a wired ethernet connection to one of the Sonos One speakers. All other internet-requiring functionality worked without issue (Spotify, Google Play, speaker configuration, etc.), And Google Assistant would even work when connected via Ethernet (after some rather tedious multipl-attempts setup as described here: (https://en.community.sonos.com/google-assistant-and-sonos-229109/unable-to-set-up-google-assistant-6830205). However, following any instructions I could find, and every kind of reset and renewing I could think of, Google Assistant would always time out after any prompt and respond with "something is not working right now, try again in a few seconds...".

Although it was a bit of a pain, there was no way to get a wired ethernet connection to the speakers in their intended locations in our rather large and oddly-shaped living room, so I removed the Sonos One pair from my home theatre and set them up as their own independent stereo set. Infuriatingly, this worked, and I was able to set up and use Google Assistant normally without a wired ethernet connection. When I was watching a particularly good movie I would go through setup and add them back into the home theatre as surrounds, and then split them out as an independent stereo set each time. I was very disappointed and regretted my Sonos purchases but this was workable as an interim before working up enough angst to call technical support.

 

Solution:
Last night I tried mucking with the IPv6 settings for my wifi modem, and Google Assistant started working on wifi with my One/Amp home theatre setup for the first time. In the end I think this is what did it:

1) I changed the modem DHCPv6 auto configuration type from "Stateless" to "Stateful". I have no idea what IPv6 or any of these things mean, but this was the only IPv6 setting available to me without contacting my internet service provider (Ziggo). I had to access my wifi modem's advanced DHCP configuration settings via web browser to find any mention of IPv6.

2) After waiting a minute or so, there was no effect and Google Assistant still didn't work. I next unplugged the Sonos One with Google Assistant (I only powered down this speaker).

3) It took 30 seconds or so for the speaker to boot up and then I said "Hey Google, what's up?" I was immediately greeted with something to the effect of "According to Wikipedia, Whatsapp is a social media service...", and this was music to my ears!

Thanks everyone for your input on these issues. I can now use my wireless talking computer box in peace, subtle ambient surround effects included, like the pompous long-winded curmudgeon that I am.

Badge
Doesn't seem right to call this thread answered when the answer was to contact support, especially since support specifically asked for diagnostics from those of us who tried all the steps posted and still failed. Many of us have posted diagnostics, but I do not see a single reply to these. Huge Fail from Sonos on this crap implementation.
Anyone having trouble with google assistant (GA) and sonos? I opened the Sonos app and realised that GA had dropped out. I have tried to reconnect via the Sonos app but no luck. I disconnected Sonos from GA app also prior to reconnecting and still no luck.

GA cannot reach Sonos...I receive this error...

Reply