Google Assistant Radio Playback

  • 18 June 2020
  • 1 reply
  • 49 views

I am currently experiencing this problem as well… All i want my sonos to do is to play the music and listen to the news through GA.. THAT IS ALL I WANT.. IT WORKED PERFECTLY FOR THE FIRST HALF A YEAR AND IT SUDDENLY JUST KEEPS CUTTING OFF HALFWAY..

ALL I WANT TO DO IS TO LISTEN TO THE NEWS EVERY MORNING…..

I am honestly very frustrated… For the longest time i thought that maybe they were just playing the snippets of the news?

I factory reset the device twice and tried connecting to 2 different google accounts, re added the google assistant. I thought it might be a problem with my wifi, which was exactly the same set up as it was the whole 6months. I plugged in the ethernet cable, nope still the same thing.

“Here is the latest news”

10 seconds later

“That’s all for now”

If i am lucky i can maybe listen to 15 seconds of the news right after that.. or maybe abit 20 seconds if i am extremely lucky… 

There is no way the news ended then because HE WAS TALKING HALF WAY AND IF I USED GA FROM MY PHONE THEY PLAYED THE SAME NEWS FOR 10 MINUTES WITHOUT CUTTING IT OFF..

OH COME ON I JUST WANT TO LISTEN TO THE NEWS. Please FIX GA, I MIGHT AS WELL USE A PHONE TO BE USED AS MY GA. 

My diagnostic number is 1759749108.

H..E..L..P


1 reply

Userlevel 5
Badge +16

Hello @richardkai,

Welcome to the Sonos Community and thank you for reaching out with your diagnostic report.    

Which radio stations are you trying to play through Google Assistant and which radio tuner are you using, Tune-In or another service?

If you start playback manually via the Sonos app, does the report play all the way through? 

Is it possible to test this radio station using a different service such as MyTuner or Sonos Radio? 

Reply