Answered

Google Assistant problem with Beam


I recently google for voice on my beam. When  i say a command like "play elton John", I get the reply " playing a playlist of elton John on Spotify" (which is what I would expect), followed by "sorry,   I don't understand". then nothing is played.

There are no other people or sounds in the room when this happens. I have tried a few times with the same results. Any ideas?

 

icon

Best answer by Annazel S 12 July 2020, 18:03

Hi I have submitted a diagnostic 1416997269.

In answer to your questions, I have tried several artists and songs with the same outcome. I have tried specifying the device " dianna ross on front room beam". All have the same outcome. I get confirmation the command is understood "playing diana ross on spitify" then  "sorry, I don't understand". 

All device names are unique.

I couldn't figure out how to set a default device name but did try specifying a device in the command. 

 

Hi @Ernie29.

Thanks for the response.

It shows on the diagnostic that the Google Assistant voice service is active on Sonos.

The Beam’s room name is ‘Living room Beam’.

To set the default speaker, please click the link for the steps provided on the Google website.

View original

16 replies

Userlevel 4
Badge +15

Hi @Ernie29.

Thanks for reaching out and welcome to the community!

I’d be more than glad to help and try to get this figured out.

 

To understand it better, I’ll need some more details that can help us identify where the issue is coming from:

  • Is this playback failure universal or are there some artists/services that Google Assistant will play? 
  • Have you selected a default speaker so content always plays in a specific room without saying the room name in the command?
  • Can you try asking for a more generic music request and specify playback in the Beam’s Room name?
  • Please ensure that all device names under the voice assistant are unique, the assistant may not be targeting the correct device for commands.

 

Kindly please submit a diagnostic report through the Sonos app, and reply with the confirmation number.
It can help up identify what is causing your issue.

 

Let us know how it goes and if you have any other questions or run into any issues, please do not hesitate to reach out.

Hi I have submitted a diagnostic 1416997269.

In answer to your questions, I have tried several artists and songs with the same outcome. I have tried specifying the device " dianna ross on front room beam". All have the same outcome. I get confirmation the command is understood "playing diana ross on spitify" then  "sorry, I don't understand". 

All device names are unique.

I couldn't figure out how to set a default device name, but did try specifying a device in the command. 

 

This morning I see the same behaviour when trying to select music. However, once I had selected music through the app I tried voice control to skip a track, that worked ok.

Userlevel 4
Badge +15

Hi I have submitted a diagnostic 1416997269.

In answer to your questions, I have tried several artists and songs with the same outcome. I have tried specifying the device " dianna ross on front room beam". All have the same outcome. I get confirmation the command is understood "playing diana ross on spitify" then  "sorry, I don't understand". 

All device names are unique.

I couldn't figure out how to set a default device name but did try specifying a device in the command. 

 

Hi @Ernie29.

Thanks for the response.

It shows on the diagnostic that the Google Assistant voice service is active on Sonos.

The Beam’s room name is ‘Living room Beam’.

To set the default speaker, please click the link for the steps provided on the Google website.

Userlevel 4
Badge +15

 

This morning I see the same behaviour when trying to select music. However, once I had selected music through the app I tried voice control to skip a track, that worked ok.

 

@Ernie29

I appreciate that you also tried other commands and good to know it works.

As we get the issue isolated, it looks like it is specifically happening when you’re trying to ‘play music’?

Please ensure that any music services you add in the Google Assistant app have also been added to your Sonos system in the Sonos app.

I see that Spotify is already on your Sonos account, is it also added to the Google Assistant app?

What music services have you added on Google Assistant?

  • To see available music services, open the Assistant app for iOS or Android, tap your profile icon to get to your account page, and then tap Services > Music.
  • Available services are listed under More Music Services.
  • Music service availability will vary by region.

You can ask your Google Assistant to play music, if those services are already added to your Sonos system, but they can’t be directly added to your Google Assistant app.


Let us know how it goes and if you have any other questions or run into any issues,  please do not hesitate to reach out. 

Thanks for the additional instructions. I count find ant settings wrong, so I removed google assistant from the Beam and reinstalled. This helped and the " don't understand " message went away and music played, but not on the Beam. Even when said play B52s on living room sonos, the music played on the Sonos in the kitchen.

It seems now there is a fight between my Samsung S10 which is Goolge voice activated too and the Beam. Both react to my voice. The Beam speaks to me, but I think the phone is winning out when it comes to the commands. I do get the right result when I cover the Samsung S10 microphone when I issue the voice command which is why I think the two devices are fighting each other.

Any more ideas?

 

 

 

Userlevel 4
Badge +15

Hi @Ernie29.

Thanks for the response.

 

I recommend testing the Beam without the other voice-activated device to see how it will respond.

Is it possible to try and disable Google Assistant on your phone to test it?

 

How to turn off Google Assistant:

  1. Open the Google app and select Menu.
  2. Go to Settings.
  3. Then, Google Assistant section click Settings > Phone and disable the Assistant option.

NOTE: You can turn back on the Assistant option if you prefer to, after the test using the above steps.

 

Let us know how it goes and if you have any other questions or run into any issues, please do not hesitate to reach out.

Hi, I turned my phone off completely to test. Things looked better, but the default device still seems to be the Sonos device in the kitchen, not the Beam in the living room. If I specify the device I want to use (living room beam), this does work. Definitely progress. 

Just need to figure out how to change the default sonos device and how to stop my phone fighting for control.

Badge +1

Hi @Annazel S 

I’m getting the same problem with a Beam and One speaker.

If I say “Play <station> from TuneIn” it says “playing <station> from TuneIn” followed by “sorry, I don’t understand”.

I get the same issue if I say “play spotify” or more specifically say “play <plylist> from spotify”.

It’s not a general Google Assistant issue, as a non-Sonos smart speaker has been responding fine to Assistant requests with no problem.

This has been ongoing for a number of days.

Diagnostic 922527666.

Userlevel 4
Badge +3

I think you will find that this has been ongoing for a number of weeks. Read this forum. All complaints about the terrible integration of GA on SONOS

i have an extensive setup I’d SONOS devices and google home devices(mini, home, hub, hub max)

 

if I ask the google device to play BBC RADIO 2 it works fine. When I set the default speaker as a SONOS speaker it fsils

same for music played using google play music and you tube premium. The SONOS fails so often that my wife has take a radio out of storage

Badge +1

I did manage to get the GA working again by removing and re-adding it to the speakers. 

Hi @Annazel S 

I’m getting the same problem with a Beam and One speaker.

If I say “Play <station> from TuneIn” it says “playing <station> from TuneIn” followed by “sorry, I don’t understand”.

I get the same issue if I say “play spotify” or more specifically say “play <plylist> from spotify”.

It’s not a general Google Assistant issue, as a non-Sonos smart speaker has been responding fine to Assistant requests with no problem.

This has been ongoing for a number of days.

Diagnostic 922527666.

I am also seeing the same issue with my Sonos Arc and GA

I now seem to have a working configuration. I made two changes and both seemed to help.

First, I removed then reinstalled google assistant from my Sonos Beam. That got rid of the "sorry I don't understand" error. It didn't fix that it played music in the wrong room.

Second, having reread the instructions in the ticket, I realised that you configure default devices for EACH room, so not a default device house.

I was able to set a default for the living room to Sonos Beam, then all was well.

 

Userlevel 4
Badge +15

I did manage to get the GA working again by removing and re-adding it to the speakers. 

 

Hi @sonows.

Thanks for reaching out and for giving us an update.

Sorry for the delayed response, just got back from my off.

It’s so nice to hear that the issue was already resolved and it’s back up and running.

 

If you have any other questions or run into any issues,  please do not hesitate to reach out. 

You are always welcome in the community. 

Cheers!

Userlevel 4
Badge +15

I now seem to have a working configuration. I made two changes and both seemed to help.

First, I removed then reinstalled google assistant from my Sonos Beam. That got rid of the "sorry I don't understand" error. It didn't fix that it played music in the wrong room.

Second, having reread the instructions in the ticket, I realised that you configure default devices for EACH room, so not a default device house.

I was able to set a default for the living room to Sonos Beam, then all was well.

 

Hi @Ernie29.

Thanks for reaching out and for giving us an update.

That was awesome, you did great!

I am so glad that the issue was resolved and now all seems to work well. 

 

If you have any other questions or run into any issues,  please do not hesitate to reach out. 

You are always welcome in the community. 

Cheers!

Userlevel 4
Badge +15

 

Hi @Annazel S 

I’m getting the same problem with a Beam and One speaker.

If I say “Play <station> from TuneIn” it says “playing <station> from TuneIn” followed by “sorry, I don’t understand”.

I get the same issue if I say “play spotify” or more specifically say “play <plylist> from spotify”.

It’s not a general Google Assistant issue, as a non-Sonos smart speaker has been responding fine to Assistant requests with no problem.

This has been ongoing for a number of days.

Diagnostic 922527666.

I am also seeing the same issue with my Sonos Arc and GA

 

Hi @nostou12.

Thanks for reaching out and sorry to hear about that trouble.

I  would like to look into this more, but I’ll need some more details to look into it better, kindly tell us more about it.

  • Is it also happening on the same music services and on specific command(s)?
  • Have you tried using other services? Please note the behavior of the Sonos device(s).
  • Is this a first time Google Assistant set up on Sonos or this is an existing service already that suddenly experiences this issue?
  • When did you notice the issue started?
  • Were there any changes made on the system or on your network?
  • Are you using other voice-enabled devices aside from Sonos speakers?

 

Kindly please reproduce the issue and submit a diagnostic report through the Sonos app then reply with the confirmation number.
This will help me review your system further to see what options may be available. 

Reply