Answered

Google Assistant on Sonos One okay with one access point, not with multiple...?

  • 8 July 2019
  • 7 replies
  • 325 views

Userlevel 2
Badge
I have a frustrating issue related to Google Assistant on my Sonos One. With a single internet access point, the Sonos One with Google Assistant works flawlessly in conjunction with my other Sonos components (2*Play-3's, 2*Play-5's and a Play-1). When I set up multiple access points (moved to a larger house so need to), the voice control no longer works (talks about a problem, a glitch, try again in a few seconds etc.). Everything else (all Sonos components) works though. The Sonos app on my phone still sees the device and it can function perfectly well as a Play-1, it's just the GA voice assistant that's messed up ... I've had the Sonos One (as well as the entire Sonos network) in wired and wireless mode - same result. I've backed out the multiple access points to a single one and the Sonos One / Google Assistant all works great again so that does seem to be the cause.

I've not changed back to Alexa to see if that works as I really don't want Alexa...

Anyone got any ideas or seen this before? Known issue?
icon

Best answer by Ken_Griffiths 8 July 2019, 22:19

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Hi gxprice

By single access point I assume you mean your router. If all works well through it but problems arise when you bring the access points on line; therein lies you problem. Make sure the access points have the same SSID and Passphrase as your router. Turn off DHCP for each access point. Let us know how things sort out.

Cheers!
gxprice,

Set all wifi access points to operate on the same 'fixed' WiFi channel. I would also opt to use SonosNet with one Sonos device cabled to the main router.

If you do choose SonosNet (recommended), then also go onto do the following things...
  1. Set your SonosNet channel at least 5 channels away from your chosen 2.4ghz router channel.
  2. Remove your WiFi credentials from “Advanced Settings/Wireless Setup” in the Sonos App
Hopefully that will resolve your issues.
Userlevel 2
Badge
Hi gxprice

By single access point I assume you mean your router. If all works well through it but problems arise when you bring the access points on line; therein lies you problem. Make sure the access points have the same SSID and Passphrase as your router. Turn off DHCP for each access point. Let us know how things sort out.

Cheers!

Thanks for the reply! Yes, as you say (I wasn't very eloquent), the problem is when the other access points are online. SSID's / passphases / channels are the same for each router and DHCP off all except the primary router. Each subsequent router (AP) has a hard-coded LAN IP within the subnet of the overall network.

One thing that I will try is to change out the primary router for one of the others. I'm in the unenviable position of having 1 "noname" (from the cable company, used as the DHCP), 1 dlink, 1 netgear and 2 Asus...

What's annoying is that the ONLY feature that isn't working is the google assistant - everything else is flawless 😞 That's why I'm thinking that there's an issue somewhere in the Google Assistant code...
Userlevel 2
Badge
gxprice,

Set all wifi access points to operate on the same 'fixed' WiFi channel. I would also opt to use SonosNet with one Sonos device cabled to the main router.

If you do choose SonosNet (recommended), then also go onto do the following things...
  1. Set your SonosNet channel at least 5 channels away from your chosen 2.4ghz router channel.
  2. Remove your WiFi credentials from “Advanced Settings/Wireless Setup” in the Sonos App
Hopefully that will resolve your issues.


Hi Ken, Thanks for the response 🙂 I've fixed the Wifi channel on all routers (AP's) and am using SonosNet (as verified in the "about" text in the app). Initially, one of the Play-5's was hard-wired, now I've also hard-wired the Sonos One directly to see if that helps (it didn't)

I'll take a look at your 2 points as I've not seen this before - didn't know you could set the SonosNet channel independently from the router! How can I do this? Also, I'll remove the Wireless credentials, maybe somehow, the Sonos One is using this for it's Google Assistant portion of its functionality...?
gxprice,

In the Sonos App Settings/Advanced Settings on the mobile App you should see the option there to change the SonosNet channel to 1, 6 or 11. Choose one furthest channel away from your local (hopefully fixed) WiFi channel.

Hope that assists.
Userlevel 2
Badge
gxprice,

In the Sonos App Settings/Advanced Settings on the mobile App you should see the option there to change the SonosNet channel to 1, 6 or 11. Choose one furthest channel away from your local (hopefully fixed) WiFi channel.

Hope that assists.


Thanks Ken, I've set it up like this now and everything, in theory, is bang on with what I've read for the recommended (required?) Sonos setup. Google Assistant still doesn't work.

HOWEVER, I gave up resisting Alexa and put her voice service back on the Sonos One as a test. It worked immediately and flawlessly.

So, there is a bug in the implementation of the Google Assistant on Sonos One under the certain conditions I've mentioned above.

@SonosSupport - if you need further info, ping me.
gxprice,

Have you tried going through the manual installation method of the Sonos device/skill in your Google Home and installing each Sonos speaker in your Google Rooms one by one before then going back to the Sonos App to install the Google Voice Assistant in your Sonos One Room 'voice services' section?

i would go through that process and see if that works for you, if you haven’t tried it already.

You need to ensure multicast DNS services are available across your network, before attempting that... so check if that needs enabling in your access points or speak to the manufacturers support on how to enable it.

Hope that assists.