Answered

Google assistant music play back issues

  • 1 September 2019
  • 67 replies
  • 5667 views


Show first post

67 replies

Im having the same issues with the GA and music play back. I either get the error that the speaker isn't available right now or the content cannot be found. Sonos want to schedule a phonecall with me at some point. If we figure out a fix I will post it here.
Any updates here? Emailing with support, but I am not expecting much here... JoeYan, do you have any more details?
Userlevel 1
Badge
From the troubleshooting I did with tier-2 support, this problem seems to be related to specific Google accounts, and there is an ongoing open issue with Google about this.

Also posted about here: https://en.community.sonos.com/google-assistant-and-sonos-229109/sonos-not-working-on-google-assistant-6829259
Userlevel 2
Badge
Hi everyone, there were some playback issues over the long weekend, but I believe for now they should be resolved.

If you're still having trouble, I'd suggest that you contact the team live to troubleshoot, after you've already done the basics.

This issue is not fixed... It hasn't been working for many people for many weeks.
Userlevel 1
I am having the exact same problem for two(ish) weeks now, since the first Google Assistant outage some time ago...

I went through everything with $support_person, and the problem is, that they can't even see me calling for music playback in any logs they might have. There's definitely a bigger problem here somewhere, and I really hope for a fix, like, soon! 😮
I am experiencing the same issue. Super frustrating. Has anyone fixed this yet?
Userlevel 2
I'm still having this issue too. I did everything glaciercat outlined.

Is there a way to mark this question as not answered?
Userlevel 1
@Ryan S Tried again this evening. No difference. Removed and re-added Google Assistant. No difference. Frustrating...
Badge
Confirming I'm still having this issue after several weeks despite taking the following self-troubleshooting steps. Posting here for posterity. Contacting the support team is my next step.
  1. Restart the Sonos app; restart the Spotify app
  2. Unplug/recycle power on Sonos One
  3. Restart my phone
  4. Reauthorize Spotify account under Sonos app under Settings>My Music Services
  5. Remove and reconnect Spotify account under Sonos>Settings>My Music Services
  6. Unlink Sonos One and Sonos account from my Google Home under "Device settings" and "Manage accounts"
  7. Unlink my Assistant from all devices under "Manage accounts" *this was a drastic measure😓
  8. Set Sonos One up through the Sonos app
  9. Select "Add Voice Assistant" through the Sonos app under Settings>Room Settings>[Room Name]>Voice Services to set back up with Google Home/Assistant. Ensure it's configured to the right Home and Room - add Music Service(s)
And after all that, still get the same error message: "Sorry, I don't know how to help with that" in response to any "Play music" command.
Will update with where support leads me next...
Userlevel 2
Re: The reply from Ryan: This problem existed for me before the weekend, and still exists. The device is basically broken.
Userlevel 7
Badge +26
Hi everyone, there were some playback issues over the long weekend, but I believe for now they should be resolved.

If you're still having trouble, I'd suggest that you contact the team live to troubleshoot, after you've already done the basics.
Userlevel 1
Sonos support on Twitter DM have asked for all my hardware details and apparently someone will be in touch tomorrow to schedule a call.
Did anyone figure out what the problem was?
Userlevel 2
I’m having this exact issue with Spotify and TuneIn.
Userlevel 2
I’m having the exact same issue.

Google Assistant queries like, “What’s the temperature?” work fine.

Google Assistant queries like, “Play The Rolling Stones on Spotify” do not work, but result in a response with the Assistant seeming to understand things “Playing This Is The Rolling Stones playlist on Spotify. Sorry I don’t know how to help with that.”

This is awful.
Userlevel 1
Yes, sure mine was working before.
Unsure if it’s a Sonos issue, an Assistant problem, or YouTube music issue?

Sonos have tried all their troubleshooting tips and no joy.

A rep is due to call me back.

Let me me know if you find a solution?
thx
Mine is doing the exact same thing! Just today worked yesterday, tried re installing and same deal

Reply