Google Assistant does not play Radio Stations

Userlevel 1

When I ask my Sonos: "Hey, Google! Play Heart 80s". It replies with: "Playing Heart 80s on TuneIn". However, it then says: "Sorry I can't find what you asked for". This is really disappointing, because Alexa plays radio stations without any issues. Any suggestions on how to fix this? 


Exactly the same issue reported


Weirdly Sonos seems to just keep closing the issues so you can’t comment on. Very poor customer service.


As described in the other issues - this is 100% a Sonos issue. The error comes after control is handed back from Google to Sonos and the exact same voice commands work on google home devices on the same network.

55 replies

Userlevel 5
Badge +13

Hi @JamesDan, thanks for your reply. Just to let you know that starting playback through voice aren’t available at this time for the Global Player and Sonos Radio. For now, voice assistants will utilize the default radio services selected from within the respective app, and while starting playback of Sonos Radio and Global Player using voice aren’t available at this time, you can control basic functions through voice such as volume control, pausing music, and even asking your voice assistant what’s playing. 

I'll make sure your voice is heard with the team. We and the community are always here.

Userlevel 4
Badge +7

The GA command to play my local news station from TuneIn has suddenly started working after more than a year! I’m not sure when exactly that happened within the last few weeks (I accidentally tell GA on Sonos to play that station at least that often, forgetting that I am talking to Sonos instead of one of the Google Home units).

Until now, I would say “Hey Google, play (station)”, it would respond “Ok, playing (station)”… and then “I couldn’t find that content”. And then the next two commands to GA on Sonos would fail with “Something went wrong”, doesn’t matter what commands.

Today I accidentally told Sonos to play that station again, and now it works! To be clear, it has never worked before - the problem has been there since I first converted to using GA on Sonos last year.

Userlevel 5
Badge +13

Hi @Doug Ames, thanks for your response and for letting us know here. I’m glad that it’s working now, and if in case you had trouble again, reach out to our phone/chat support team to better assist you. 

We and the community are always here to help.

Userlevel 4
Badge +7

Continues to work fine for me.

Badge +2

Sorry I could not find the solution.

Can you please refer me how to fix it?