conflict between Sonos Ones?

  • 6 July 2019
  • 4 replies
  • 131 views

I have two Sonos Ones that are used as left right speakers in my living room. I never had any issue with them. Recently, I added a third One, this time in my bedroom. I have been having random errors not being able to play music since this new purchase. Today one radio station stopped working within the Sonos app, stating an encoding error. I could not cast anything to Sonos from my usual Podcast or Radio station app either. It would just not connect. I tried unplugging my speakers and force quitting the app but it wouldn’t do anything. My only other devices on the wifi are my iPhone and iPad. I have a Wyze camera in another room. The wifi coverage is excellent in my entire apartment, and the network is set to automatically assign devices to 5Ghz or 2.4Ghz. I went through the list of wireless interference issues but I really don’t see anything related to my set up. My Ones are far away from any other wireless device, microwave or anything that could interfere.
I did manage to get the radio station back to working in the Sonos app after a while but it stopped working again with the “encoding error” as I am typing this :(
Any clue why this would happen?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +21
Wait for the error, submit a diagnostic within 10 minutes and contact Sonos support with the number, they can check your system internal data you/we can't see.

Probably not the issue but you could assign static/reserved IP addresses to your Sonos using the router's DHCP page. Unplug Sonos, reboot router and replug Sonos at one minute intervals.
Thanks! I managed to at least get Sonos to play from my other music/podcast apps by restarting my iPhone. As for the single radio station not working, it’s still there. I’ll wait a bit, maybe it’s a problem on their end!
Userlevel 7
Badge +20
Thanks! I managed to at least get Sonos to play from my other music/podcast apps by restarting my iPhone. As for the single radio station not working, it’s still there. I’ll wait a bit, maybe it’s a problem on their end!
There is an issue with Google Voice Control at present, please monitor: https://status.sonos.com/
Userlevel 7
Badge +21
If you post the station you'd get folks here to try it and post their results.