Can't reconnect Google Assistant

  • 7 March 2021
  • 1 reply

I had google assistant working before, but moved homes and had to set everything up on a new wifi. I reset my beam and connected it to the new wifi, but can't seem to be able to connect google assistant again. I've tried disconnecting all devices from google home/assistant. I've deleted the google home app. I still have the google assitant app. When trying to link the device via the sonos 2 app it takes me to the app store to download the google assistant app, which I already have. I click to open the google assistant app and nothing happens.


I've submitted diagnostics: 1886200429


Best answer by Corry P 8 March 2021, 10:59

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Marcelo Lima 

Welcome to the Sonos Community!

Thanks for your post, and for the diagnostics. I recommend you switch the router, Beam and Sub off. Wait 30 seconds, and switch on the router. When you get WiFi back, switch on the Beam, and when it’s light goes solid white, switch on the Sub too.

Try adding Google Assistant again, and if it fails, try using another controller device, if you can. 

If it’s still not working, please get in touch with our technical support team - they may need to adjust some router settings for you.