Question

Assistant on Beam turns on all lights rather than just the room its in?

  • 15 November 2019
  • 4 replies
  • 63 views

Userlevel 2

I have the Beam newly setup in place of my home mini. For some reason although it’s in the right room and all that when I give the lights off command it insists on handling every light in the house rather than just the room it’s in. 
 

 

antone got any ideas 


4 replies

Userlevel 5
Badge +11

If your command is “lights out”, GA will turn all the light off that are in your house. The right command would be something like “lights out in the living room”.

Userlevel 7
Badge +20

If your command is “lights out”, GA will turn all the light off that are in your house. The right command would be something like “lights out in the living room”.


This isn’t the case anymore, to turn the lights out across all ‘rooms’ you need to ask ‘turn off all the lights’ - as long as the devices are assigned to the correct rooms then the command turn lights on/off will only affect the lights associated to that room.

Userlevel 5
Badge +11

I hadn’t noticed this. I’ll try it on my system.

Userlevel 7
Badge +20

Hi and welcome :)

 

This isn’t Sonos functionality and so I expect it is something to do with the Google Assistant set-up. (Sorry, if I’m insulting your intelligence here!)

Can you open the Google Home App on your mobile device and then scroll down the list of rooms and see if there is a room with all of your lights within it?  I assume from your original post that you have checked that the Room containing the Beam only contains the correct lights?

 

The other thing to check as you have just added a new device (the Beam) is that you don’t have any duplicate names. As both Alexa and GA use Groups/Rooms for context, I always call my Sonos devices Room Name + Device Type. e.g. Kitchen Sonos contained the room Kitchen.

Reply