Windows 10 Sonos Controller won't launch, stuck on icon (AGAIN!!!)

  • 23 September 2021
  • 7 replies
  • 135 views

  • Contributor I
  • 4 replies

This BUG is still present, more than a year after being reported on this forum for the first time.

Issue, cause and workaround have been documented in: 

The problem and workaround were acknowledge by a Sonos rep more than 6 months ago.  But the problem persists.

Would it be possible for Sonos to actually fix the bug in the next update?


7 replies

Userlevel 7
Badge +22

Seems very specific to a few configurations. Do you know what is using that port on your PC?

Or try a third party Sonos app from the Store :-)

Standard Windows NAT.   Which on its turn is used by Docker, Kubernetes and some Virtual Machines. So I expect this will affect many software developers using these products on Windows 10 and WSL.

Killing the hanging Sonos controller, then restarting the NAT service and then starting the Sonos controller again, works around the issue.  I mostly use my phone as a backup, less work than the workaround.

It is a bug in the Sonos controller in trying to get access to a port is doesn't own.  I imagine that it wouldn't be too hard to fix quickly.

 

Userlevel 7
Badge +22

Strange. I did a network capture of both S1 and S2 starting up and running on my PC and port 3410 was not used for TCP or UDP. I wonder why Sonos is wanting to use it on your system?

None of my apps have ever needed to use that port.

That port is also not listed on the Firewall page: https://support.sonos.com/s/article/688?language=en_US

Not a clue where it is used for and why it isn't used on your system.

The controller app writes an xml startup log file.  The error -including the port number- appears there.  With netstat you can see if the port is in use.  It is not.  With netsh int ipv4 show excludedportrange protocol=tcp you can list the reservations.  And since it is reserved, so only the reserving app can use it.

The reserving app in this case is the Windows Nat Service, if you disable the service, the reservations go and the Sonos controller can run.

If the port is only used for local communications between Sonos processes it wouldn't (perhaps even shouldn't) need to be configured in a firewall.

---

Actually just got an update pushed.  My version is now: S2, 13.3, build 65121150.

Problem did not appear after the update, but today the NAT did not reserve port 3410.  It reserves a large number of blocks, not always the same.  The problem is intermittent, depending on the NAT's mood during start-up.

I'll check again tomorrow after boot-up.

 

 

Hanging again.  Not solved during latest update.

I had the same issue today (win10 & s2), suddenly I would be stuck with only the sonos logo. Tried everything on all ohter posts mentioned.

 

Then this worked out for me:

  • Disable wifi
  • Open S2 app - it did open now with the question to join to a new/existing system
  • Also it asked something about the firewall, I opted for the firewall configuration changes
  • Re-enabled wifi
  • tadaa! :)

@sonosmonosuser  Had it again today with latest update in.

The problem is quit intermittent,

Also, when WiFi is disabled and it is your only network, you can bet that Windows shuts down the NAT service.

Going to complain agan...

Reply