Why does sonos controller and connect stop playing when audio is quiet?


I have a Late 2013 Mac pro and I'm using the headphone (stereo) line out which connects to the line in on a connect. (not the amp, just the bridge). Don't get me started on the fact that the play3 has no line in - $300 later I got over it and bought a connect. From there I connected the connect directly to two Play:3s. I had tried wirelessly connecting to the speakers, but it was so delayed over wireless that it made watching any video unbearable and out of sync. Airplay, even worse. So much for wireless hifi eh?

Connecting the speakers directly with ethernet cables fixed the delay but now I have another annoying issue that I can't figure out how to make go away.

If the audio output in a video (say youtube) stops or even gets too quiet, the sonos controller automatically switches itself from play mode to stop mode. If I leave the controller open on my computer I can sit here and watch it happen consistently in any quiet part of a video or song. If I press play on the sonos controller then the audio comes back until the next quiet point and it stops again, forcing me to continually open the sonos controller app to tell the device to play the line in audio. Sometimes if I spike the volume, it'll pick it back up on it's own after a delay.

Is there a way to force the sonos controller /connect to stop doing this and just always stay in play mode?

It's really really annoying if the sound on a movie or something is quiet and all the sudden the audio stops until I reset the controller or go press play on the device.

Please help. I bragged about sonos to everyone, I've bought 4 Play:3s, 1 Playbar, a Connect and a Play:1. How is it that I spent this much money and still can't use a simple line properly on my computer? Is sonos really so single purpose that it can't be used for line in on a computer?

8 replies

It looks as if the music doesn't even need to be completely quiet. If I have the sound output from the computer on the lowest setting, even just quieter (like an ambient part) will cause the sonos controller / connet to go stop itself.
Userlevel 6
Badge +4
I use it for line in from my computer. You may need to update the input signal level to lower level signal so sees it better. Under setting for room under input tab there is the input level adjustment.
Userlevel 4
Badge +3
Hi Kyle,

Chris is right. The issue is most likely due to the sensitivity settings of the line in level. Try adjusting the source level, here's how: How to adjust line in level.
Chris / Jeff, Thanks for your response.

I adjusted the line in level to the lowest setting, which in turn should result in the highest sensitivity and I am still consistently see it happen anywhere in the <30% volume range. While it's slightly less frequent, it's incredibly frustrating. Is there not a way to just tell line in to ALWAYS be active unless I manually pause it? I would expect this to be the usual behaviour for an analog line-in. 

I can understand having the device switch off when there is absolutely no signal, but for it to turn off when volume output level from my mac is at 25%, is a really poor user experience that obviously someone along the way thought was a good feature.

This should really be changed. Is there no work around for this?
The only thing that seems to improve this situation is to crank my computer audio and compensate at the controller level. The result is that my computer volume set at 75% with sonos set at 25%.

Seems to me like whatever exponential that is being used to detect line levels is off by at least 3x.
Userlevel 4
Badge +3
Kyle Campbell wrote:

The only thing that seems to improve this situation is to crank my computer audio and compensate at the controller level. The result is that my computer volume set at 75% with sonos set at 25%.

Seems to me like whatever exponential that is being used to detect line levels is off by at least 3x.


Hi Kyle,

You can choose the line in source from your music menu rather than rely on auto play. The CONNECT should play the line in source until a different command is received.

If that doesn't help, or if you would prefer to get the auto play working, please give us a call. We've created a support ticket for you: 150310-001005. If you call us, we'll work with you to get things working properly. Here's our contact information: contact us.

Jeff S wrote:

Kyle Campbell wrote:

The only thing that seems to improve this situation is to crank my computer audio and compensate at the controller level. The result is that my computer volume set at 75% with sonos set at 25%.

Seems to me like whatever exponential that is being used to detect line levels is off by at least 3x.


Hi Kyle,

You can choose the line in source from your music menu rather than rely on auto play. The CONNECT should play the line in source until a different command is received.

If that doesn't help, or if you would prefer to get the auto play working, please give us a call. We've created a support ticket for you: 150310-001005. If you call us, we'll work with you to get things working properly. Here's our contact information: contact us.



While I appreciate this workaround, I am also having this issue. Already changed input setting to the low setting, and still its happening. The cause of the issue definitely seems to be a quiet video source, my TV doesn not allow me to turn up the volume on an optical out (Using optical to RCA converter to connect TV to Connect). Not sure why auto-play is designed to stop playing if the source is quiet in the first place, seems like a very odd 'feature'. Maybe just disable that, and all will work as expected.
Maybe get a Sonos component that is intended for use with a TV, i.e. Playbar or Playbase.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)