"Updating Music Library - Please Wait"

  • 5 December 2014
  • 8 replies
  • 2879 views

I have just installed a new computer. Moved my music to a new drive. Upon adding the folder to my Sonos controller on the PC I have a "Updating Music Library - Please Wait" message. It's been stuck there for a few hours now. I am on a windows 8.1 desktop computer.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +22
Is your network profile set to HOME not Public.  I know that has caused sharing issues for some.

I would probably first delete the share in Sonos and re-add and see if have better luck 2nd time.
Userlevel 7
Badge +22
may not be it but here is the firewall settings part https://sonos.custhelp.com/app/answers/detail/a_id/823/kw/windows
It is a home network -- but the music is on a disk on the same computer ( D:). I am not using the "My Music" folder as it is on a small SSD drive. Sonos is also allowed through the firewall on both public and private networks.
Userlevel 6
Badge +3
There is really no share to delete in Sonos as the Music Library Tab is stuck. Please see the screenshot of the music library screen



Depending on the size of your music library and your local network, the indexing can take up to 1 hour. If it's still updating (indexing) your music library can you submit a diagnostic and reply with the confirmation number. Here is a FAQ showing you how to submit a system diagnostic. I will have a look and if needed open a case ticket number.

Thanks
Badge
For anyone who has the perpetual "Indexing Music Library - Please wait" problem, we finally came up with a solution in my specific case. I had a few Audible files in my iTunes > iTunes Music > Audiobooks file that had been downloaded from Audible in the wrong format. Sonos only works with Format 4 Audible files. All of the Audible files in my music folder had the "aa" suffix, even the non-Format 4 ones. So, you can't tell by looking at the suffix.

However, I had downloaded six books a couple of weeks ago in a different format because the format designated in the drop-down menu on my Audible Library page was defaulting to the wrong one. I had caught it and re-downloaded the correct Format 4 files at the time, but the problem is I left the incorrect ones in my iTunes Audible folder as well, rather than trashing them.

Ideally, Sonos, when indexing new files, would just ignore incorrect formats, but instead it choked on them and I got the perpetual "Indexing Music Library..." message every time I tried to update the library. But, when I removed the wrongly-formatted Audible book files from my iTunes folder, rebooted my Sonos Bridge and all speakers/players, and then retried the indexing, it worked.

Now I have my whole iTunes/Audible library back in Sonos.

Hopefully that helps someone.

Dave
Mx, Turns out that my problem was quite identical. Sonos choked on some (probably malformed) file and refused to go ahead -- getting stuck on the "Indexing Music Library" message. 

A quick way to check if this is the case is to go to 

http://ip:1400/status/zp

where ip is the ip address of the zone player. You can see what files it is indexing currently. 
If you find that it's stuck on the same file after a few minutes try moving that file and restarting
the system. (http://ip:1400/reboot is a quick way of rebooting the system from the browser)

Worked for me and am happy to have my music back ....
Badge
I’m having this same problem, but when I type the address above I get a lot of info about my zone players but I don’t see any file names.
Userlevel 7
Badge +21
That post is from four years ago, much has changed in the last four years. Maybe start your own topic with your problem and a diagnostic code included?